[Done] How Can I *Not* Record Midi-Mapped Parameter Changes?

We use the right mouse button to record automation for effect parameters. We use the left mouse button to just change them without automating. However, if an effect parameter is midi-mapped, it behaves like a right mouse button. Any changes while in edit-mode are recorded as automation.

How can I make midi-mapping behave like the left mouse button, ie not record the changes?

Record & Play Filter

Either uncheck the pitchbend and controllers box or type in the CC value to ignore.

Thank you!

This won’t apply to MIDI mapping. I think we need a new option somewhere to disable recording of MIDI mapped parameters. A global option (preferences) in the MIDI Mapping dialog might do the trick…

Ouch. I never really tried it, just assumed it would work.

Using a global option, I assume you would just have to Ctrl-M and toggle the option on/off? Ie not have to remap everything (PITA)?

Yes, this is something I have suggested too a couple of times.
Fundamentally, it could be implemented as a tiny record button next to the MIDI-Map button, or inside the MIDI mapping dialog itself.

I know taktik is working around the clock to squash bugs and I guess the answer is no, but I still want to ask: any possibility of this being fixed in 2.5? It feels like an easy fix - a toggle button in a dialog…

Keeping my fingers crossed, and very impressed with all your nice work on 2.5!

At the risk of being called something worse than “mulish” or “Johann, der Mullbacken abholer”, I’m bumping this request again. Cause right now it’s making me crazy…

Already in the queue. Don’t worry. And sorry for the “mulish”. Wasn’t meant like this.


On the contrary, it’s been great fun! I’ve been asking all my German friends what a “Mullbacken abholer” is and nobody knows, LOL!