Easy Way To Install Renoise In Linux

hey all. new here. i was messing around with renoise on my brother’s macbook i ended up liking it but he won’t let me use his computer as much. i have a laptop on my own that runs ubuntu 10.10. i tried to download the .tar package, extracted it then a similar set of folders and files opened up. i do not think it actually installed on my computer but i the program runs. also pressing play makes the demo song run glitchy which never occured on my brother’s mac.

i hate windows and would rather run renoise in linux. can someone be kind to please help me configure this on my laptop. also please spare me the linux technicalities like how and why the certain terminal codes work the way they do. i could learn that later. i just want to start making music.

all i want is know what to type on the terminal.

for ex. step 1: type this, this happens then type this. step 2: type this, etc.

thanks in advance.

Well, I really don’t see how installing Renoise could be any simpler:
As the install instructions say, unpack the downloaded archive, go into this folder in a terminal and write ‘sudo ./install.sh’.

That’s it!


i know this sounds like im asking “how do you eat food?” lol but bear with me here. how would one go “into a folder through terminal”? im not too familiar with this. ok well i extracted and opened the folder which contains: installer folder, resources folder, install.sh(<–is that it??), license, tutorial, a read me, one labelled “renoise”, faq, and uninstall.sh.

trying to open the “install.sh” opens up a dialogue box asking if i want to run or display contents. trying to run in terminal opens the terminal for a split second then it disappears.

Open the terminal (Linux/OSX equivalent to Windows Command Line) it’s under applications > accessories > terminal

Type sudo sh (with a space after it)

Drag the install.sh file into the terminal window and it will auto-complete the line

Hit Enter

Enter admin password when prompted

Yep. This did it! THANK YOU!

Thanks to the both you actually.


Never knew you could do drag and dropping onto the terminal. Generally browse to location then paste in with Shift+Ctrl+V but may try and remember that…

MasterG111: But having it installed, rather than just running from the download, isn’t likely to make much difference to the fact you said you are getting glitchy playback. What are the specs of the laptop? Have you got an audio interface? I guess you are running standard Ubuntu, not Ubuntu Studio, correct?

Also I hope you have read and taken heed of this page: http://tutorials.renoise.com/wiki/Linux_FAQ

Neither did I!

This works for Windows as well.(At least Windows 7)

never knew about the drag-drop terminal thing either. was pretty amazed to read that :)

anyway, the glitchy stuff could very well have to do with your linux audio-setup. it is recommended to run linux with the Jack audio server with Realtime threads. don’t go asking me how to do that because i am pretty new to linux myself and haven’t got it to work perfectly myself yet. in other words, i think it is a matter of settings, and the priority that Renoise gets in your linux audio-setup. there are a couple of forumthreads dealing with this particular thing.

if you are not up to figuring out how to fix this yourself, you could, as kazakore suggested, try Ubuntu Studio or AV Linux, which are both more focused on doing linux audio, and might give you what you want right out of the box.

i do still experience some glitchy playback and so i installed jackd and qjackctl but for some reason it wont connect to the server. it still runs terrible, guh.

im running on amd turion dualcore, with a gig of ram. no audio interface. im using the laptop’s headphone and mic output with a usb iMic.

in my experience, Jack is not very easy or intiuitive to set up. try to do some Googling on the subject, or maybe someone around here can help you out.

Jack actually makes things slower, cause it adds another layer. I repeat: Jack makes things slower, not faster, contrary to what some people might say.

Try configuring the number of periods in audio settings under renoise preferences. Set it do an odd number like 3 or 6. Try if this solves your issues.

If you want to use Renoise in isolation then you may as well use ALSA. Where Jack comes into its own is for connections between programs, both on the MIDI and the Audio levels. Makes running an external synth like ZynAddSubFX or sampling from other Jack enabled programs (eg wire VLC straight into Renoise) a breeze. Also those that are Jack Session enabled will also load the correct patches etc whereas otherwise you’d have to do it manually after starting.

So have you run through the points in the Linux FAQ I posted for you earlier? You still haven’t said what version of Linux you’re using and whether you have a RT or stock kernel.

wow, never thought about it that way. that makes sense.

recently read about alsa dmix (i think), which allows alsa to have multiple signals. what i hate about my current setup is that only one piece of software can play audio at the same time, and that was the reason i installed jack. seems that is not necessary.

So Jack would only be needed by someone who wants to run more than one audio program simultaneously. In my case I guess won’t be needing Jack. I only want to run Renoise alone at the moment. Perhaps I would need to learn advanced Jack configurations if I end up installing another program like Ardour for example.

Yes. Good reference. I’m using ubuntu (not studio) 10.10. I haven’t got into installing a realtime kernel.

from what i’ve read, a real-time kernel is not absolutely necessary. at least in Jack you can let Renoise run as a realtime thread, which is, i believe, quite the same thing. but, as i said before, i’m by no means an expert so i might very well be wrong.

Unwanted glitch: terminated. Worked like a charm. Initially I set the period buffer to 3. It worked for some of the demo songs but one made a minor hiccup. Set it again at 6 and it now plays smoothly! Aaaallright.

I am looking at my cpu percentage usage and at certain points it still goes up to a maximum of 70%. I could deal with that, for now. At least it doesn’t overload and crash by itself this time.

Doing some research linux configuration settings landed me on this. Although I might not need Jack for my needs others might find this info useful. Oops if its already posted elsewhere.

Hyper Low-Latency Audio with a Real-Time Kernel

I just always launch Renoise as root (super user, aka admininstrator of Linux) so I can set the program to real time priority instead of dealing with changing the operating system itself.

This is easily done by opening Renoise through the terminal by typing sudo renoise

Or if you’re feeling fancy, you can change the launcher in the applications menu to launch with root priviliges. To do this right click the main menu on the top panel, click edit menus, find and highlight Renoise in the opened window, click properties, in the command box change the entry to gksudo renoise %f

Only inconvenience is having to type the password everytime you launch, but it significantly improved the performance on all my machines and is easy.

Launching as Root does not automatically give you RT threads!