[fixed 1.1.2] Redux not receiving keyboard events in Ardour and Reaper under Linux

@taktik, thanks for editing the title, but please be aware that the same issue is present in Reaper as well, it is not exclusive to Ardour! I edited the title again to reflect this correctly.

Hi!

@taktik As a new Redux user, I hit this. I am using Mixbus as my DAW. I also verified, same problem appears in Ardour 5.12.

I can see that Redux is receiving key presses, because I see those ‘keyboard’ keys animated to be pressed, but nothing happens in Phrases-editor. And yes, it is in edit mode, and same operations done when running from carla work ok. I also recorded video of problem:

When I start Carla as plugin in Mixbus, and Redux in Carla, then it works, but seems to be very crashy, not usable.

i cai can chime in with mixbus and redux combo. I’ve made some project with redux, and saved it. Whenever i open that project and i open plugin -mixbus001
it just freeze daw - mixbus32c - until i terminate the process… macos mojave 10.14.6 (latest redux - latest 32c)

Seems silent here, should this be formally reported as a bug?

Just saying, I think you’ll find ‘the-Linux-Redux-VST-keyboard-forwarding-event-issue’ is already known about.


Ok, thanks. So Ardour side is fixed, but still waiting for Redux to be fixed.

So most likely this is somehow related to Renoise strange behaviour regarding keyboard. Keys that are bind in window manager do now work as expected when using Renoise (which is annoying)

Most likely that same code is causing problems here when Redux is embedded inside Ardour own plugin window, and it can’t see itself as ‘focused window’. Sounds like some change in X11 key event handling is needed.

I tried redux in the latest dev build of reaper and can play samples (enter phrases etc) with the computer keyboard when the editor window is open. Can’t remember if this was working before but i don’t think so.

1 Like

It somehow only works in fluxbox not xfce, this is very strange.

1 Like

I am running BitWig 3.2 on Linux and I’m having the same issue. Keys can only be used to play notes. Everything else doesn’t work. I faintly remember this working before, but I’m not sure what changed. I can get the keys to work in Carla, but as an earlier poster said, it crashes a lot.

I was just testing it in Bitwig 3.1 and it was working.

I used my package cache to test BitWig v3.1.2. It worked, indicating BitWig made some change in v3.2 that broke redux. I’ve contacted BitWig support and will update when I hear back.

1 Like

I’m testing 3.1. at the moment with Debian. I get sporadic xruns, especially when using e.g. DIVA. This issue still prevents me from buying it.

I took at look at their changelog for v3.2

  • Linux: When plug-in window is focused, allow key events to still work as though the Bitwig window was focused (for example, keyboard note input will still work)

I bet this is causing the problem.

Yes, seems so. Right, I read this yesterday and forgot about it. Maybe write an email to the support team.

So Bitwig was the only host in which it worked correctly and now they explicitly changed that? Those people are hilarious.

Bitwig and Tracktion.

After some back and forth to show the actual problem, this is what I got from BitWig support:

thanks, keyboard input for plugins is a bit complicated under Linux.

We contacted the Redux developer to see if we can improve the situation.

lol… it was working before, but there must be a reason why they changed it.

At least they try to solve the problem.

Working on this with the Bitwig team to get it fixed again.

I’ve also finally found out why it didn’t worked in Ardour and Mixbus, so this will be fixed in the next update.
Will check Reaper on Linux again as well.

6 Likes