Linux: Redux computer keyboard does not work in Ardour


(mevla) #1

Hello,

When the on-screen Redux keyboard keys are clicked, they show as such by becoming grey and a sound is made. When the computer keyboard is used, the corresponding on-screen key becomes grey, but no sound is heard. Seems (sounds) like a bug. Redux demo version, Linux Mint 17, Redux used as a plugin for Ardour. External MIDI keyboard works fine.

Edit: As I follow along the Quick Start, the Esc and TAB keys do not work, to edit and move along columns, as they do in Renoise. I think it would be safe to say that the computer keyboard does not work at all, even though, when trying to play a sample, the corresponding key is greyed out (eg. pressing ‘z’ will make the hexagonal on-screen ‘z’ become grey). This means that Redux recognizes the computer keyboard, and that there’s a problem further down in processing. As such, it is not possible to buy Redux with this problem.

I do have Renoise 3 on the same machine and everything works just fine.


Any news for future versions ?
Redux & Ardour
Hexagonal keyboard does not work.
(taktik) #2

That’s unfortunately a problem or “missing implemented feature” in later versions of Ardour. There is an option to forward keys to plugin windows in ardour, but it seems that it’s not implemented or working for VSTs.


(Meef Chaloin) #3

Is there a way to forward keys to plugins in renoise? I haven’t tried redux in renoise when if you have a synth plugin window focused you can’t play that synth.


(mevla) #4

What is misleading here is that when the ‘z’ computer key is pressed, the Redux hexagonal ‘z’ button is greyed. It means that the computer keyboard key press is recognized by Redux, isn’t it ? Which would mean in turn that Ardour does not block the key, would it ? If there was no reaction on Redux part I could understand that keys are blocked. But there is reaction. Are you certain Ardour has a blocking role and if so, can you explain technically what it would be. This is Ardour 4.2.0.


#5

Mevia just out of curiosity try these steps…

First of all, get a simple project saved that just uses one instance of Redux on a midi track (and an audible instrument in Redux) in Ardour. Close everything and start again…

Load in Ardour

Load up your simple session.

Now very careful here (read my post completely before trying this…)

In the mixer view you’ll have an instance of Redux on your track. Click your right mouse button on it and go to the option ‘Edit’ (Don’t double click on the Redux insert to open up the GUI !!!)

Now the Redux GUI should open with the instrument AND you will see that popup box stating that this is a demo version.

Don’t click anywhere with the mouse!!! AND Don’t move the Redux window!! (This is really important!)

BUT, make sure your mouse pointer is floating somewhere inside the Redux window.

Now press keys on your keyboard. Does it play the sample sound?

It does for me. Move your mouse pointer outside the window. Now for me it doesn’t sound (but the GUI still responds as you say.)

Also as soon as I move the Redux GUI window, that’s it. It never sounds again.

[Edit: Ah, TakTik found the possible issue with Ardour not implementing the LXVSTPluginUI::forward_key_event function :)]

[Interesting though as when the Redux window initially pops up, you do actually get ‘Key Events’ sent (and it does work as intended.) But if the user clicks on the title bar or moves the window, Ardour/GTK reassess itself and stops sending the key events.]


(taktik) #6

What is misleading here is that when the ‘z’ computer key is pressed, the Redux hexagonal ‘z’ button is greyed. It means that the computer keyboard key press is recognized by Redux, isn’t it ? Which would mean in turn that Ardour does not block the key, would it ? If there was no reaction on Redux part I could understand that keys are blocked. But there is reaction. Are you certain Ardour has a blocking role and if so, can you explain technically what it would be. This is Ardour 4.2.0.

If the hexagonal Z is reacting on the keypress it should work, yes. Have tested Redux in Ardour 4.0.something only, will check 4.2.0.

Regarding the not implemented function I meant “LXVSTPluginUI::forward_key_event (GdkEventKey*)”:

https://github.com/Ardour/ardour/blob/master/gtk2_ardour/lxvst_plugin_ui.cc

Also check the little keyboard icon on the top right of Ardour’s plugin UI.


(avoca) #7

Hi,

If I use the Fluxbox window manager, the computer keyboard does work.

Ardour-4.2.64

Mixbus-3.0.1508

But on KDE, Gnome, XFCE, it doesn’t.

Debian Jessie.

But there are seg faults from time to time. When saving a session with Redux loaded for example. Not always, though…


(mevla) #8

Mevia just out of curiosity try these steps…

(…)

In the mixer view you’ll have an instance of Redux on your track. Click your right mouse button on it and go to the option ‘Edit’ (Don’t double click on the Redux insert to open up the GUI !!!)

Now the Redux GUI should open with the instrument AND you will see that popup box stating that this is a demo version.

Don’t click anywhere with the mouse!!! AND Don’t move the Redux window!! (This is really important!)

BUT, make sure your mouse pointer is floating somewhere inside the Redux window.

Hi, can’t do that. Because Redux does not start in editor mode. I would tend to think that the computer keyboard would work also when Redux is not in editor mode, but it does not. I use KDE.

From what avoca said it looks like a desktop manager issue. Then I fear there might be a dead end. I know as a fact that Paul, Ardour’s creator does not hold KDE in high esteem at all. Any bug fix that is related to KDE would be difficult, I fear, from that side.


(mevla) #9

Also check the little keyboard icon on the top right of Ardour’s plugin UI.

Thanks for mentionning this. Although, even when it’s green, the computer keyboard still does not work. In both regular use, and the ‘edit use’ described by 4Tey. When trying with 4.2.0, please use a desktop manager such as KDE, or the ones that avoca listed.

Ah, the github link does not work.


(Meef Chaloin) #10

I know as a fact that Paul, Ardour’s creator doe snto hold KDE in high esteem at all. Any bug fix that is related to KDE would be difficult, I fear, from that side.

If it is bug in ardour which can be replicated then Paul or rgareus will have no issue with trying to fix it. If it is something on the KDE side then there’s not much he can do about it, report it to KDE.


(mevla) #11

If it is bug in ardour which can be replicated then Paul or rgareus will have no issue with trying to fix it. If it is something on the KDE side then there’s not much he can do about it, report it to KDE.

So far the keystroke is received by Redux since the hexagonal on-screen key responds. It is not clear that after receiving it, a desktop manager would prevent subsequent handling within the Redux application. Any idea how this could be ?


#12

Hi, can’t do that. Because Redux does not start in editor mode.

On the preferences GUI tab of Redux there is an option to allow Redux to start in a non compact mode so you can see the hex keyboard from startup.

My two cents… If I was writing a Redux and I came across this problem my first point of call would be to triple check my code, not assume that Linux, window managers, Ardour was the root cause of the problem. In other words, when I program something on a computer (and it doesn’t quite work) I ALWAYS assume I’m in the wrong :slight_smile:


(taktik) #13

Yup. Am working on it but will need more time for this to compile, debug with the latest Ardour and co on various Window Managers and stuff.

Right and Wrong in a fuzzy environment like Linux desktops is impossible to define though. It’s more about getting it “working” in most of such environments instead of getting it “right” :wink:


#14

I’m sure you’ll do it sir. You’re a better programmer than me :slight_smile:


(avoca) #15

Thanks very much, taktik :slight_smile:


(taktik) #16

Regarding the not implemented function I meant “LXVSTPluginUI::forward_key_event (GdkEventKey*)”:
https://github.com/Ardour/ardour/blob/master/gtk2_ardour/lxvst_plugin_ui.cc

Also check the little keyboard icon on the top right of Ardour’s plugin UI.

Did a few more tests. The missing “LXVSTPluginUI::forward_key_event” implementation really seems to be the problem here:

Ardour’s window, which hosts the plugin window, grabs away key events, so Redux does not receive any key events. LXVSTPluginUI::forward_key_event is then responsible to forward the keys to the plugin window, when the plugin window is not a GTK window.

The hey keys in Redux’ UI do light up, because they poll the keyboard state, ask the system which keys are currently held down - they do not reflect the state of key events that got received by Redux.

I’m unfortunately not very familiar with GTK, especially not on Linux, so I’d forward this to the Ardour devs. If someone here has some experience with GTK and Linux development, any help would be very apropriated. Of course we’re very interested to get this working.


(avoca) #17

Hi taktik,

Thank you for looking into this.

I might ask on the #ardour irc channel if they can have a look at this, if that’s OK with you.

avoca


(taktik) #18

Hi taktik,

Thank you for looking into this.

I might ask on the #ardour irc channel if they can have a look at this, if that’s OK with you.

avoca

Yes, that would be great. Or if they are aware of a workaround for us.


#19

Just a thought. As a quick (only partial, as phrases would have to be edited with the mouse) side step around that unimplemented function for the moment. It may be possible to use VMPK (which turns your QWERTY into a piano keyboard) to send midi notes into ardour and then ultimately Redux :slight_smile:

Attachment 5917 not found.


(lilith) #20

Here’s a post from the Ardour forum concerning the keyboard problem: https://community.ardour.org/node/15778#comment-50208

Are there any news about that issue on the Redux side or could any Redux dev comment on that?

Same issue is apparent with Reaper / Redux.