How Do I Record Aftertouch And Pitch Control At The Same Time?

I want to record the notes, the aftertouch and the pitch values from my midi controller. Sadly it writes only one column at the same time with midi control data to the track:

Attachment 2970 not found.

I would like to first record the pitch changes, then maybe some ribbon controller values.

How can I record multiple controller data at the same time?

If I use a midi automation device, I cannot map the pitch bend to the pitchbend slider, because it doesn’t recognized by the midi mapper. So this isn’t the right way, too.

Another question: Can I record the controller values directly to the graphs instead to the pattern commands?

it is strange that the pitchbend wheel doesn’t get recognized by the MIDI mapper: as long as you have set up the MIDI autoation device correctly, it should work.

using a MIDI automation device is the way to go to solve your problem, normally. You could maybe use the automation device for the aftertouch instead.

look for the third button from the left in this panel:

related documentation here

Hmm, about this, it’s no, I think.
I’ve tested the pitchbend wheel here too, and it doesn’t recognized by the MIDI-mapper indeed.
So we cannot record the movement of the pitchbend wheel to the automation envelope in realtime, as Jurek said.
Maybe, we can use the mod wheel instead, but it doesn’t return to the center position automatically like PB wheel. :(

Hi It-Alen,
of course I know about this button and it’s activated. The documentation is imo not very helpful when it comes to external midi.

I hope this problem will be fixed for 2.8, because pitch pend / aftertouch recording (as graph, the same time) is a very essential function for making music, don’t you think?

There is nothing special on the way the Korg M3 sends the pitch bend. It’s the standard pitchbend control values, in general midi way, that is sent. Also the aftertouch.

I made a midi automation meta device setup now that looks like the following. The only stuff I can not remote control is pitchbend/aftertouch so far. In the midi mapper I did not use the learning mode for choosing the right slider, but the path “Global mappings->Track DSPs->Selected FX”. There I mapped all sliders to the correct general midi cc#s.
Attachment 2972 not found.

AFAIK the MIDI-mapping dialog does not accept pitch bend or after-touch, only MIDI-CC and note messages.

I have created a replacement for the standard keyboard which you can try instead. Still beta, but I think you’ll get the general idea?

Thanks man for the hint. This is really helpful. I mapped pitchbend to cc#118 and aftertouch to #119. Now I can map it. Cool stuff :)

danoise: One suggestion for your plugin:

If I now remap pitchbend/aftertouch to midi cc’s and have mapped them over the midi mapper, the pitchbend is still written to the pattern fx column, although I selected “Record midi mapped parameters to automation” in the mapper. The only way to prevent this, is to disable record of control/pitchbend in the midi settings.

But maybe this is not fixable now from your side…

I’m glad you like

Hmm, it might be, might not. Did you disable/deselect the keyboard from Renoise preferences -> MIDI input ports?
As this is a purely scripted solution, you no longer need to select it there.

That is because his pitchbend wheel doesn’t send CC values probably. Mine doesn’t either and is also not recognized by the midi mapper.