how to configure multiple outputs for kontakt?

Hi, I’m trying to use kontakt’s multiple outputs with renoise, and have no idea how. I’m familiar with the general workflow for multi-output plugins but can’t figure it out with kontakt. When I pull up kontakt and look at the output section, it has a single stereo channel and four aux channels. St 1 is mapped to physical outputs 1 & 2 whereas the auxs 1-4 are on 11/12, 13/14, 15/16, and -/- respectively (I assume -/- means unassigned?). I can create more stereo channels but I can’t figure out how to map them to “physical” outputs (which I think are really the host outputs that renoise recognizes). If I create a new output channel, it lets me choose physical outputs but the numbering doesn’t really make any sense to me. I’ve attached a screenshot of the options that I have. Kontakt can apparently do up to 16 stereo outs, so all I want to do here is create multiple stereo output channels that are on separate host outputs. Does anyone know how to do this? Thank you.

edit: I’ve read every post on the forum that includes “kontakt” but can’t find anything that actually tells me how to do it.

I do not own kontakt. However, more than likely, this is what you are looking for. It works with my multi-timbrels, I can not think of a reason why it shouldn’t work with Kontakt.

Have your web browser maximized, and scroll down about 3/4, you will see a bold heading for Plugin Aliases

You have to reload the VST after changing the channel config (then you’d have to save the config as default!) or save the whole track instead. However, after restarting (delete VST from instrument list and load it again), your config should work properly and stereo-tracks should be available as such.

There are usually different Kontakt VSTs available from the VST list.
Kontakt 8out
Kontakt 16out

It’d make more sense to select the 16out from the beginning, instead of changing your default channel config all the time. But… you’d still have to save and reload the whole song then, to make changes work. Kontakt actually tells you then, you have to save and restart/reload things to make the new channel config work.

So, again in short:

  1. Do your changes to the channels (in Kontakt only!)
  2. Save XRNS
  3. Reload XRNS
  4. Assign the (now proper appearing) outputs in Renoise

yeah I’m familiar with instrument aliases and adding channels in kontakt. even after restarting it, I can’t choose output channel #s within kontakt that make sense. See the screenshot in the previous post…

For me works flawless. I can’t see a screenshot btw.

Edit: You have to assign the output channels in Kontakt BEFORE restarting/reloading. Otherwise you only reload half of the new config. So this is part of step 1 I described. Just select an unassigned output there. Kontakt will automatically make it the required number of channels afterwards itself. And it’s also gonna rename these channels.

And sorry, but it doesn’t really appear like you’re familar with adding channels. That’s why we’re talking here, right!?

ah weird I guess I didn’t submit the screenshot. anyway bit_arts you’re right I definitely misspoke…I’m familiar with renoise’s instrument aliases and setting up multiple outputs, but clearly not familiar with attaching new kontakt outputs to plugin outputs.

so…it turns out I got confused on the naming within kontakt. When pulling up the channel output configuration window (by pressing the little -|- button below an output channel), I was looking for something that said Kt. St. 2, Kt. St. 3, etc. But it has Kt. St. 1 [1], Kt. St. 1 [2], then Kt. aux 1 [1], Kt. aux 1 [2], then a few more auxes, and then Kt. unassigned… Kt. St. 1 corresponds to plugin outs 1 & 2, aux 1 is plugin outs 3&4, and so on for the remaining auxes and “unassigned” outputs. Basically a difference of opinion on how stuff should be named :P

Thank you 2 daze j, bit_arts, and vV for your patience and tips in helping me set this up.

No sweat, Kontakt is known to be a PITA to get it working properly the first time. Seems to work like a charm when everything is settled.