Instruments Selected When Cursor Jumps Through The Tracks

Ok, it’s late and I did not think about it throughly if it’s really bug or not ,just reporting. Maybe it’s useful.

-pattern view
-lots of tracks with lots of columns so that scrollbar is visible
-auto capture instrument from pattern is on

Now, place cursor in the first track and scroll to the last track, so the cursor jumps through the columns.
In the meantime observe instrument box. With cursor in each new track, also new instrument is selected.
In Renoise 2.7.2 it didn’t happen.

win7 32x, beta 5

To test it just load DemoSong - BeatSlaughter vs Tenda - Psydrums

Might be that that the auto capture instrument function has been made more sensitive to presence of instruments on the track or are there no instrument reference whatsoever on that track?

I think it’s not really useful, because its just random, cursor land just on the most left or right track.
And cursor should not actually move while you scroll using scrollbar.

If the cursor moves out of sight, i rather have it to travel along to stay in sight, just to prevent having stuff added or deleted unintended and unawarely. But it doesn’t have to move as long as it remains visually present and that is the current situation.

Back to topic: the instrument only changes if there is a reference in the column inside the current pattern. If the track or column is empty, it doesn’t change.
There have been debates and suggestions made about the automatic instrument changer to alter its behavior to the method that is used right now.
I believe somebody even wrote a script that did it…
But the word “Debate” already suggests there will be always people for it and against it.
It makes these topics never ending.

I think of two scenarios
1/ moving cursor through tracks using Tab or Shift-Tab (or just cursors).
2/ moving or just looking through pattern using scrollbar. for example have cursor on track1 but want to check something on further tracks. and in this scenario cursor should remain intact on track1

take for example m$ excell, cursor dont move when you are only scrolling to diffirent area, it just stay there when you leave it. so when you’re back to that area it just still sit there.

Okay, i added more info to the topic title, regarding that, because this seems to bother you more than that the instrument is changing (which is just a side effect of this)

Its true that previous Renoise versions did not auto capture instruments in this case, but I think it definitely should. As soon as the cursor jumps, for whatever reason, it should also capture whats below of it.
And the cursor does jump in this case, to make sure you always see it. ”Exel” does not, but its not Renoises brother.

I see your point of view, especially when it comes to new users, but it would be nice to have option in the preferences to change this, eg.‘cursor not follow horizontal scrollbar’, or something like that. So the cursor behaviour in pattern view was the same as it is now in the mixer view, too.

I do understand that such an option would solve “your problem”, but in general we should try avoid cluttering the preferences with options which are “extremely” specific.
Let’s see what others think about this. Maybe we can find a compromise…

I neither like or dislike what’s being described here, but I’d like to share my own experience.
Personally, I would never enable such an auto-capture instrument feature. I did once, and it confused the hell out of me. I’m perfectly happy with the keyboard shortcut (capture nearest instrument), which I use all the time. Also, it’s an integral part of my workflow to select a sample, and then quickly trigger it in various tracks to hear how it sounds with different DSPs applied.