Issues with Arturia Pigments 3 VST GUI Elements

Hello, having this weird issue with the Arturia Pigments VSTi. When closing/reopening the editor window or rendering a sample from the pattern editor (ctrl + r) causes the editor gui to lose some elements. This will always cause the waveform view the disappear:

Other instances I have lost the ability to move sliders or even bring up the menu to load new engines. I have disabled the auto scale function and the issue still persists and this has occurred on (2) separate windows laptops I have. Anyone have this issue or know of a potential fix?


Same thing happening here, its rather annoying.

I’m on Win10 and don’t have that issue with Pigments V3.5.0.1831
Make sure you are on latest version as last update had some UI updates.

Just checked, on the latest version as well!

I bought Pigments a few months back and haven’t really got into using it properly due to similar issues. Had no idea if it was Pigments or Renoise so figured I’d wait it out for an update or two and see what happens but there’s still a lot of weirdness going on.

Sometimes knobs will just stop working, modules you’ve turned on will still be turned off, just lots of glitchy behaviour in general.

can you try setting the scaling function in the windows parameters to 100% (right click on desktop → display settings) ?

That fixed it for me.
Drawback is that your windows desktop will be smaller, but you can always resize the renoise gui in the parameters.

Thanks, but my Windows scaling is on 100% already.

Are you using the VST3 or VST2 version? I’ve had gui issues with the VST3 Pigments (as well as other Arturia plugins). Certain elements disappear or stop updating, and the tooltips that show number values are comically huge sometimes. I have no issues with the VST2 versions though.

Managed to find the VST2.4 version in the standalone installer (ie not going through the Arturia Software Centre) and spent a little while with it - It definitely seems a lot better but still has some issues. I’ve just had the same thing as in the OP with the harmonic engine display going missing and things becoming unresponsive.

Still no real idea how much of this is Pigments and how much Renoise (if any).

Having similar issues with the new EFX Fragments plugin. Using the VST2 version of the plugin resolves the GUI issues, but I do not consider that to be a resolution to the overall issue.

I also have issues now after using it more seriously, it’s not always happening but occasionally elements simply disappear. Did anyone report this to Arturia or else I will?

I had tried, but they were having me try out all these other things on my end that I timed out the ticket.

Okay… I’ve just reported it and will try go through their support. I want to make it my main synth but that’s obviously impossible when features suddenly disappear :confused:

Hopeful bump to see if anyone has gotten this sorted yet :slight_smile:

Just to be clear, do you all use version 3.7 of Pigments? I’ve had crashes on versions 3.0 and 3.5, but currently, seems fine (but I did not go deep into the internals of the plugin)


double-clicking on the “Pin Editor” button brings back the whole gui of pigments.
waveforms, pulldown menus, etc pp.

i guess it has something to do with that. devs, maybe this is a small hint to find the actual gui bug?!

and yes, it also happens with version v3.7. afaik with different arturia guis.

so use the temporary Pin solution. for arturia fx dsps, please add a vsti-alias of the fx and use the same “Pin Editor” trick solution. i only tested this on eFx fragments.


then again, my assumption that it might has to do with the “pin editor” feature could be wrong.
because the fx plugins of arturia have this problem aswell. so i guess it’s some gui refresh issue.

…until then…


I have this same problem with ALL Arturia plugins. It sucks, because their emulations are one of the best to sample from. I know there’s this workaround above, but it’s not the same as an actual fix.

Has everybody disabled GUI scaling for HiDPI screens for each and every plug-in they use? Fixed all issues for me, even with Synthmaster.

Just an update on my end…

I used to have many GUI related issues especially with VST3 including Pigments, other Arturia plugins and more on my Windows system but I revisited most of my VST3 plugins the last few days (some tested both in sandbox and without) and most issues appear to have gone away over time through various updates, I have noticed Arturia have updated various GUI issues for awhile so…
But anyway I’m left with issues on Arturia Solina and Arturia Vocoder that are not working at all, NI Flair has a little cosmetic glitch and Soundtoys Effectrack has an issue where you can’t scroll down to see all its effects.

NI flair - sandbox

Updating to release 3.4.3 resolved the GUI issues I was having. :slight_smile: