Anyone using Plogue OPS7? GUI issues

I think this is a Renoise thing because it’s really similar to the Pigments issues described here which I also experienced. Pinning the VST seems to be a temporary fix there but not with OPS7. Guess I should mention that I’m using the VST3 version.

Sort of hard to describe because it’s a variety of slightly janky things going on but UI elements just don’t quite behave properly a lot of the time, it’s especially noticeable with the modulation generators but I’ll also get things like disabled operators still being active (then the next time you disable them it works as it should) and other weird stuff like that.

Just wondering if anyone else is using this plugin much and if it’s working OK for them.

Always add your system specs in a bug report.

Reads a bit unnecessarily blunt/patronising considering most of the topics in here don’t list them, yet didn’t receive the same response… but whatever.

Latest Renoise
Latest version of Windows 11
RME Babyface Pro FS
AMD 5800X3D
32gb DDR4
X570S Tomahawk
RTX 3080Ti

I also don’t know whether it’s a bug report, I specifically asked whether others had been using the same plugin without issue for the purposes of trying to figure that out before reporting it as such.

1 Like

i run various chipsynth plugins on MacOS M1 in renoise without any trouble… something win11 related? been a while since i was on win but did you try to enable/disable openGL?

i recently ran into a gui bug with zebra2 though, tabs totally not working. switching on or off keyboard focus fixes the problem (uhe peeps are aware of the problem and will fix it soon)

1 Like

Thanks, I tried disabling hardware acceleration if that’s what you mean? Or is there a way to switch rendering in Renoise specifically somehow?

It’s not a massive issue, it’s similar to the Pigments thing in that you can work around it, was just curious if anyone else had encountered the same really. If there’s still just slight general issues here and there with VST3 plugins that’s fair enough, at least I can stop wondering if there’s anything I can do about it.

I get inconsistent jank in the UI of KV331 Synthmaster 2.9.9 in Renoise, some of the UI doesn’t reflect what is going on or the cursor changes shape to apply an action but doesn’t change back after.

yes that’s what i ment, sorry been a long time on win. but yeah plugins like Pigments are quite GPU heavy so you kinda need hardware rendering i think.

personally i also have the impression Renoise got a bit less snappy regarding plugin GUI’s over the years (it got better on mac with metal rendering though) not scientifically tested but i also have the impression CPU usage got higher since v3.x somewhere (or plugins became heavier and don’t play as nice with Renoise compared to 12y ago). for me that change happened with the advent of quad core cpu’s, renoise not really gaining that much from more cores. but again not scientifically tested. and i cannot really blame Taktik, must be dev hell to keep up with all the various architecture/SDK changes and optimizations through the years.

1 Like

Yeah, I think inconsistency is the hard part. Sometimes you’ll do something and it’ll behave but other times you’re like ‘Hang on, that wasn’t what I expected… Am I doing something wrong here?’ and you can waste a lot of effort troubleshooting, especially if you’re like me and tend to assume user error!

It’s worse when it’s a plugin you’re not familiar with, it’s difficult to get a feel by trial and error when the results vary. I spent quite a long time scratching my head with Pigments before I realised it was the GUI having issues and not something I was messing up/not understanding.

I’ve had some weird problems with the Chipsounds VST’s. I don’t have the OPS7 but I do have the Mega Drive, the Porta Sound, and the SNES one. I think it’s the plugin itself, just UI elements being difficult to click on or drag. I’ve also had the parameters reset a few times after putting together multilayered/split patches, which is a real pain in the ass. I’ve just started using multiple instances instead and haven’t had any problems since.

1 Like

I have ops7 , love it to death , an incredible achievement .
I did encounter some gui issues on my desktop , verry slow loading and once the gui was shown all other gui processes in renoise were incredibly slow .but none of the issues you mention .
I resolved the issue with killing the diagnostice policy service from within taskmanager .
See topic here

Now on laptop , everything runs fine ,

1 Like

Ah, that’s interesting - I haven’t had that with any of the Plogue stuff but I have had something similar with other plugins where everything else starts running at a choppy 15fps or something while the plugin window is open. ChowTape was the one I could remember and disabling that service doesn’t make any difference there unfortunately but I’ll have to try it with the others I come across so thanks for the tip.

Strangely the other couple of Chow plugins I have don’t cause the same issue and I imagine they’re all using the same graphical framework.

which VST modell of OPS7 are you running (VST2 or VST3). Are you using the actual version of OPS7 (v1.105).
Did you try to change the GUI or the GUI size (Zoom)?
Screenshot 2023-03-08 092630

That is not really related , I also have some plugins that slow everything down when loaded , but the plogue issue was once every few weeks .
Chow : see if 'use open gl ’ works ( cogwheel settings )

1 Like

Good call! That sorted the ChowTape, cheers :slight_smile:

Hiya, yeah it’s the latest VST3. Changing back to the original GUI is a good idea actually, I should have thought of that. I’ll do that and try to spend some time with it to see if it sorts it, might be a while since it feels a bit pot luck whether it’ll start being weird or not :sweat_smile: