Kenton Control Freak Studio Edition

Here are some links to the controller :

When I press the mute button for a channel, nothing happens in Renoise. The Midi activity button lights up, but that’s all.
Using midi mapping doesn’t work either. The midi value for channel 1 says “Ch1¦CC7”, but when I try to use the button afterwards … nothing.

Could you have a look at it please?

I’m using Windows 7 64-bit edition

To what are you mapping it to exactly?
There are several types of midi options that you can map the midi controller to, for a value shifter (controller is a wheel or knob or fader that ranges from 0 to 127), toggle (value changes to 0 or 127 when pressing) or switch (value changes to 127 when pressed, back to 0 when released).
There are specific functions in the midi map table of Renoise that allow you to pick either one of those options assigned to the same function.
If you get my drift…

I’m not too good at Midi so I’ll try to answer your question.
I’m doing the following :

  • go to Midi Mapping
  • press “Mute” (which activates all 3 options, Active/Off/Mute for mapping)
  • press the channel 1 button on my Freak (Renoise then says “Ch1¦CC7” over the 3 options)
  • the Midi Mapping pop-up then says (next to the Clear button) : …/Mute/Unmute/Track XX [Set]/Track #01 [Set] Cha:‘1’, CC:‘7’
  • Map Mode is set to “Absolute 7 bit”

The display on the Freak shows “Mute Chan 1 - Value 0d” when I press the button and it sends the mute, and “reset Chan 1 - Value 0d” when I press it again.
(btw shouldn’t it be sending Value 127 when I unmute the channel?)
Renoise shows Midi activity but it doesn’t do anything. It should go from “Active” to “Off” on channel 1, that’s what I want anyway.

Does this answer your question?

You seem to get close, so it by defaults picks the “set” option…
Look at the following screenshot and notice the lines where it also offers the same options but then with “trigger” and “toggle”.
You can unfold the “Available and active mappings” clicking on the arrow to the left of it:

Try to find the “Toggle” option for that mute assignment, click it and then hit your controller again to make it learn the CC for that option.
Then try it again.

First I did
“Track #01 [Toggle] Ch1¦CC7”
(Used MIDI Mappings : Track Muting:Mute/Unmute Track XX [Toggle]:Track #01 [Toggle]: [Cha0/CC7])
Result : nothing

Then I tried
“Mute/Unmute - Current Track [Toggle] Ch1¦CC7”
(Used MIDI Mappings : Track Muting:Mute/Unmute Current Track [Toggle]: [Cha0/CC7])
Result : nothing

So both “Mute/Unmute Track XX Toggle” and “Mute/Unmute Current Track [Toggle]” don’t work, nothing happens …

Using the button to play a pattern works! I assigned it to the Renoise play button and it works.

I’m having some reaction now : if the slider below the button has values 0 to 64, nothing happens.
But if the slider has values 65 to 127, both moving the slider and pressing the button mutes/unmutes the track.
So both button 1 and slider 1 get assigned the “Ch1¦CC7” value, Renoise can’t distinguish between the two.

It seems odd the slider and button both use the same CC message to broadcast their values on.
This is something Renoise can’t really filter. Duplex can however, because in Duplex you can set minimum and maximum values for each defined controller range.
I think you might be better off building a duplex template for your device. May be a bit of work, but once done, you are set for every new project to go (and if you share your controller template, you could save someone else the same hassle).

I’m going to ask Kenton about this and ask if I can change it manually.

I must be the worst programmer in the world since it mostly looks Greek to me … :(

To start with :
Launching the Renoise executable with the argument “–scripting-dev”

gives me the following error :

The name 'C:\Program Files\Renoise 2.8.1\Renoise.exe --scripting-dev' specified in the Target box is not valid. Make sure the path and file name are correct.  


Couldn’t I do the same with this?