Linux FAQs


(taktik) #1

Neurotix has set up a quite large Renoise on Linux FAQ. Recommended for everyone who already runs or plans to run Renoise on Linux…

See: http://tutorials.renoise.com/wiki/Linux_FAQ


(pussi) #2

I think instead of running renoise as root or setting the SUID (actually I don’t properly understand what the latter does but still) it would be better to use either realtime-lsm module or pam’s limits.conf to enable realtime priority. The latter requires recent pam but I think at least 0.98 should work.

Both methods are explained quite well here: http://www.gentoo.org/proj/en/desktop/sound/realtime.xml

I must admit that I don’t fully understand this realtime stuff so correct me if these won’t work with in this situation or something :P

edit. one more thing: maybe you should mention qjackctl in jack section.


(pussi) #3

What I wasn’t sure of was weather the application would actually be run as root or not when using SUID but that’s clear now.
My point is that running programs as root is always risky and shouldn’t be encouraged. realtime-lsm and pam_limits are proper way to allow regular users to use realtime capabilities safely and without the need of running executables as root. These aren’t really that new technologies either, actually I think realtime-lsm is considered deprecated now that it’s capabilities can be achieved pam.

Of course I understand that at this point these kind of things aren’t top priority but I thought it would be good to point this out. :)


(It-Alien) #4

if you have a laptop and experience shutterings while playing songs, there are high chances that you are using an HDA/Intel soundcard.

in this case, the best option you can choose, as of version 1.91, is to run Renoise thorugh JACK and set the periods to 3 instead of the default of 2, as 3 periods are needed for best performances of audio applications under Linux for this soundcard, and there is no option inside Renoise to set this, although there will be on in next version.

howto for Ubuntu users:
install QJackCtl from a terminal by typing:
sudo apt-get install qjackctl

open qjackctl form the
Applications => Multimedia => JACK Control
menu, then go into the Setup menu and change
Period / Buffer
from 2 to 3.

now open Renoise, configure it to start with JACK and see if there is any improvement.


(prei26) #5

I’m experiencing these problems aswell, but setting Renoise to Jack results in an instant-crash with me, as soon as I select Jack
Unhandled Exception (Thread: GUI)
any ideas?


(taktik) #6

Are you running a 64bit Linux distribution?

Then this crash might be the result of trying to connect a 32bit application (Renoise) to a 64bit Jack server. Jack unfortunately simply crashes without spitting out an error in these cases.

There are ways to build a 32bit Jack in a 64 bit environment but thats highly unrecommended. Use ALSA for now in Renoise until we provide 64 bit builds. Or if you have the choice of a new Linux dist, choose a 32bit version…


(prei26) #7

thanks for the swift reply. yeah, I’m on 64bit


(It-Alien) #8

tip:

If you are using a laptop and are on battery power, use the realtime kernel only if strictly necessary: I’ve done some tests which showed that using the realtime kernel dramatically raises power consumption (15-18W with standard kernel, always over 20W with the realtime kernel) and then lower the battery life.

resuming: when using Renoise (or any other application requiring realtime kernel), it is always better to have AC power available.


(meloday) #9

thanks for this!

a really horribly noob question though-- when i type sudo apt-get install qjackctl into the terminal i am then asked to give my password. i try to type my password but the terminal isn’t allowing me to type anything…the cursor just sits there…

any help is greatly appreciated!


(It-Alien) #10

hi meloday,

first of all, since renoise 2.0 you can change ALSA periods into the configuration preferences, so this should not be necessary anymore. however, if you still want to install JACK, then your problem is simply that the password will not be shown, neither the classic asterisks will (f.e. if your password is “hello”, you will not see “*****” when you type it). So, simply type your password and press ENTER


(taktik) #11

Michael:

I’ve split your topic to:
Linux Jack Reconnect/Timeout Problems (Jack Reconnect/Timeout problems)


(vV) #12

I wasn’t talking about the latest update :)
Try 0.113.
If that still keeps buggin, i guess there should also be something else playing along


(Brian Grassfield) #13

Hello!

My dream is a netbook with very low cpu time of OS and much more cpu time for Renoise - this is the xsession in my opinion. I did the steps in the FAQ and everything works well, except the error of native startup which says Renoise can’t initialize the ALSA driver. However if I click down the message and Renoise continues the startup, I go to preferences -> audio and pickup the ALSA driver from the list - it initializes without problem, and everything works well.

How can I force the starting session to load ALSA driver BEFORE starting Renoise?

Any answer are welcome!

Thanks
Grassfield


(Rainfly_X) #14

Not to cut off Brian, but I’m having some serious issues on 64-bit Ubuntu. Version 2.5.1 worked like a charm, despite having to punch ESD in the nuts before launching in order to get the sound to work (and without that, really, what’s the point); however, Version 2.6.0 won’t even start.

Without sudo permissions, the terminal output is ```
bash: /usr/local/bin/renoise: cannot execute binary file

And with it, we get ```  
/usr/local/bin/renoise: 1: Syntax error: "(" unexpected  

I kinda feel responsible since I didn’t participate in the beta. Does anybody know what causes this? It’s not a particularly enlightening error either way.


(Rainfly_X) #15

I wish. I’ve already tried all the things recommended in that topic, none of which work. But thanks for the link anyways.


(MF Vicious) #16

I am also trying to get Renoise 2.6.1 running on Ubuntu correctly. I am using UbuntuStudio 10.10 Maverick on a 64bit Intel i5 laptop. My normal setup is Renoise in Win7 on the same laptop, however I wanted to learn JACK and linux audio and am looking for a comfort zone in Renoise.

I first tried to simply extract my 2.6.1 x86_64 tar and run renoise out of the box. (like it says it should work)
As Rainfly_x said, using either $ renoise or $ ./renoise without sudo returns “cannot execute binary file”.

using $ sudo renoise returns /usr/local/bin/renoise: 3: Syntax Error: Unterminated quoted string
I also repeated the above steps after having run the system installation script; to no avail. However the installation completes successfully. further yet, ldd renoise returns “not a dynamic executable”;

I have tried to download the other linux version of 2.6.1, and even 2.5.0; both did the same thing. Because of this I am guessing it is a problem on my end. I’m basically a linux noob, so I have no idea where to go from here. Any help would be appreciated.


(kickofighto) #17

To anyone using Ubuntu, and this has probably been mentioned elsewhere, you will have a far better experience using a light window manager like X11 intead of KDE or metacity… I use LXDE for this reason… vast improvement on an old laptop


(Conner_Bw) #18

A user named mangueJOE did some extensive testing in this regard:

@see: Linux, Renoise And Choppy Sound

A must read thread for Linux users.


(ungleichklang) #19

As general information, I tested all WMs with Renoise and on my systems (Mandriva 32bit and 64bit) Renoise runs best with XFCE.
XFCE is far smaller than KDE or Gnome and a bit bigger but easier than LXDE (LXDE is quite new and not yet 100% stable).

It even gives me less XRUNS with QJackCtl then LXDE, but I use Rneoise mostly as ALSA-Standalone DAW.


(rhowaldt) #20

How does it compare to Openbox?