Linux: Redux computer keyboard does not work in Ardour

Here’s a post from the Ardour forum concerning the keyboard problem:

Are there any news about that issue on the Redux side or could any Redux dev comment on that?

Same issue is apparent with Reaper / Redux.

Original poster of said post here. Would be very interested as well in any news regarding this issue, as it affects whether or not I will buy the full license.

As I won Sononym or Redux I have to bring this topic up again. I discussed the topic with the Ardour devs and they said it’s likely a problem with Redux.

Redux works fine in Bitwig and Tracktion, but not with Ardour and Reaper. Hexagonal keys are flashing, but the notes don’t find their way to the pattern editor.

I guess only taktik knows what’s going on here.

Yes, that would be great. Or if they are aware of a workaround for us.

@taktik: I there any chance to get this solved or is there any workaround?

The “XEventProc” thing is now implemented in Ardour

So I’ve tried implementing it in Redux ´too to check if it’s working, but it’s not. Not exactly sure why. I’ll need to build and debug Ardour from sources to find out more info here. This unfortunately will take a longer while.

Basically, the reason why the keyboard in Redux is working in Carla, Renoise, Bitwig and Co, but not in Reaper and Ardour, is because the latter hosts are embedding the plugin window into child window frame. In order to receive/handle keys, the Redux window needs to gain focus.

The highlights in the Hex keyboard are generated by polling the global keyboard state. So they always work, even when the window is not focused.

1 Like

Also if anybody, while waiting, wants a quick keyboard ‘workaround’ technique: Redux in Reaper Linux - How to use Keyboard in Phrase Editor ?

1 Like