Linux - Renoise Titlebar causes problems, possible disable setting?


(DWRL) #1

(Edited title to better summarize problem/suggestion/bug/wish)

Hello,

I’m running Renoise (latest) on Manjaro Linux (latest) in Fluxbox Window Manager (v. 1.3.7-5), and can’t drag the window between desktops, as stated here.

My workaround was to force the WM to draw its border on the Renoise Window, and with the titlebar of the windowmanager in place everything works fine (buttons are where they belong, my custom mouse actions work, draging between workspaces… etc), but now I have a doubled titlebar, since Renoise’s is still there.

Since my window border is cutomized to have layout and behaviour more like on the Amiga than on windows, Renoise’s default border doesn’t fit in anyway, so I would really love to be able to simply deactivate it.

My search turned up similiar functionality discussed here, albeit on auto-detect for compiz, would it be possible to make this a configuration option, at least on Linux?

This should solve those problems, and us Linux users get to have our crazy, customized window borders and workflows preserved :wink:

All the Best,

Daniel

P.S.: Attached is a screenshot showing the double border.


(gimmeapill) #2

Hello fellow Fluxbox/Renoiser,

I’m using Renoise with Fluxbox as well (on Arch), and can confirm the behavior, yet I never found it to be much of a problem (at least to the point where the double window decorations would be needed).

Click + Drag doesn’t work, true, but the “Send To” context menu does, as well as the keybindings (I think those are the default):

~/.fluxbox/keys

# send the current window to a specific workspace
Mod4 Shift 1 :SendToWorkspace 1
Mod4 Shift 2 :SendToWorkspace 2
Mod4 Shift 3 :SendToWorkspace 3
Mod4 Shift 4 :SendToWorkspace 4

# send the current window and change to a specific workspace
Control Mod4 Shift 1 :TakeToWorkspace 1
Control Mod4 Shift 2 :TakeToWorkspace 2
Control Mod4 Shift 3 :TakeToWorkspace 3
Control Mod4 Shift 4 :TakeToWorkspace 4
...

BR,

LX


(DWRL) #3

Thanks for the kind reply :wink:

Actually I’m not unhappy with having my customized Fluxbox titlebar on the Renoise window, since it behaves as I expect, has the buttons where I expect (i.e. ‘close’ on the left) etc, I’m just not happy about wasting 26px in height. The Renoise titlebar simply doesn’t behave like the titlebars on all my other windows, which has driven me crazy in the past, until I finally forced ‘my’ titlebar on top of it.

So while using keybindings is a valid solution to the problem technically, it’s still more or less a crutch (by making it the one programm I can’t drag with the mouse as I expect to).

To be honest, I put ‘dragging between desktops’ in to have a hint at one of the many problems the client side decoration causes, instead of just whining about it without concrete technical backing, hence my wish to be able to disable it.


(gimmeapill) #4

Yeah, I see your point. I have it glued to Desktop 2 in full screen so it’s not bothering, but if I had to move it that would be an annoyance.

Just an idea, as I’m not in front of my linux box: did you try to maximize Renoise within the fluxbox decorated window with Alt+Enter?

I guess it might be going full screen but that’s worth a shot…


(DWRL) #5

Yepp,

went fullscreen…

But well, it works somehow :wink: