Looping samples only works outside the Waveform view

Ok, while I’m lurking here… This is possibly not an actual bug, but I didn’t manage to find an answer so here goes.

Brief description:

Inside Sampler | Waveform view - and then setting a loop - I can’t play the sound (using a keyboard/MIDI keyboard) with the loop inside that view. Looping works perfectly everywhere outside of the Waveform view.

Steps to reproduce:

Load up a short sine wave for example, with the aim of making a looping sub bass instrument which you would then -play- on the keyboard or MIDI keyboard.

Insert a short loop, forward-mode in this case.

Expected results:

The sub bass can now be played (with the keyboard or on the MIDI keyboard) and the loop can be fine adjusted (to get rid of clicks, for example) while playing, all done inside the Waveform view.

This is how it worked in Renoise for 15 years, and was also incredibly useful when working with long samples and trying out different looping regions in between the long sample, dragging the loop points back and forth and playing from different parts of the sample.

You could, for example, click near the end of a 5-minute sample, set a loop right after that, and then hear the loop you have set there.

Actual results:

Sine wave sample only plays through once. Looping doesn’t work.

Looping immediately works again, when exiting the waveform view - going to modulation (or any other) view for example.

As soon as going back to waveform view - where you would actually fine tune the loop points while playing - the looping doesn’t work.

(And in the case of that 5-minute sample scenario - it is actually now not possible to do any of that at all, since the samples always play from the -beginning- when outside of Waveform view. So you would have to wait 4 and a half minutes to be able to hear a loop you have set near the end of that 5-minute sample - when with previous versions, you’d do all this inside the Waveform view.)

What am I missing?

Hard to say if you don’t post informations just like your operating system, your used hardware or else.
Your problem could be caused by the activation of “Trigger One-Shot”, which you can find below “Sample Properties” on the left. If this is activated of course there’s no loop. But in this case you couldn’t hear a loop outside of the waveform view, too, which is self explanatory.

Anyway, I cannot confirm what you’re reporting. I’m on WIndows 10 64bit using Renoise 3.4.1 (x64) and everything works fine and as expected. I just have created a loop without any problems. It works perfectly. Forward, Backward, Ping Pong, it doesn’t matter, it just works fine.

Do you have this option selected in the sampler window? (the one highlighted in blue in my screenshot)

Screenshot 2022-10-05 142155

That will cause the behviour you’re describing. With this on, the sampler will only play the part of the sample you have selected, and if you have nothing selected it will play the whole sample but ignore the loop.


This was it! It works. I did have an itchy feeling this was probably not a bug at all…

I’ve been using Renoise since 2004 and am so set in my ways at this point… Some things I just don’t even realize are there, right in front of me.

Thank you.


Ah. Hm. The 5-minute-sample thing I mentioned though?

→ I can disable that button, and looping indeed works. But I cannot play from anywhere in between the sample.

→ or, I can enable the button - I can start playing from anywhere in between the sample (clicking there) but looping doesn’t work.

So if I’m not mistaken, I can’t do the thing where I start playing from somewhere in between a long sample, and still make it loop. This could be done in older versions. Please, do correct me if I’m wrong.

Not sure about the looping part, but you can also play from anywhere in the sample by scroll-wheel clicking a point or selection in the sample

Thanks, though it still always seems to disable looping whenever a sample is started mid-way.

Just to summarize, with some real life scenarios, why I think it would be important to have the functionality from version 2.8 brought back:

I’m currently working on samples for an app, which need to be seamlessly loopable. These samples are generally over one minute long.

With the old (v 2.8) behavior, it would be possible to just set a loop and hit play near the end of the sample - and immediately hear if the sample transits from end-to-beginning seamlessly or if it needs further adjusting.

With the new (v 3 onwards) behavior, this cannot be done, as, while I can activate the loop by disabling the sample preview button (re: @highway_rehab 's pointer above) but I then cannot play from anywhere in between. So I’d have to wait a full minute to be able to hear if it loops well or not.

Another scenario:

I load up a 5 minute jazz track for example, and do a quick search for nice loops in between. Previously (v 2.8) I would set a loop and then drag the loop marks back and forth, while clicking on different parts of the sample to play it on my keyboard/controller, from different pitches etc. - always able to hear the loop right after the point where I’ve clicked play.

With the new version (v3 ->) this can no longer be done because, again, if I have the looping enabled, I then can’t play from anywhere in between the sample - I can only start from the beginning. Which would force me to listen to the whole 5 minutes if I wanted to try out loops near the end.

Hope this makes sense.

I can replicate the described issue.

Below is a possible work-around:

  1. locate a sample offset locatoin near the loop marker.
  2. create a phrase, populate it with a note and the sample offset command.
  3. play note in waveform view using the keys, it should trigger from the offset and loop.



These instruments and tools might also help •GRAIN SCRUBBER• xrni which allows you to offset sample start position via macros, so you won’t have to wait for the whole sample to play to hear the loop.
New Tool (3.0): Loop Control
New tool (3.3.2): Sample Multi Controller v2.1 build 060 - Get more out of Renoise’s sampler! both of these tools offer more flexible loop control

1 Like

Thank you.

Well, my 2 cents on this is that it would make sense to have an option for the old functionality included by default (=not having to download a special tool for it, especially if one doesn’t need any of the other additional features of said tool - don’t get me wrong, though, it is an amazing thing that we have tools, I use 'em myself).

When the button (mentioned above by highway_rehab) is disabled, working with longer samples immediately becomes a chore, as you can’t play from a selected point within the waveform, only from the beginning.

Having the button enabled by default is so much better in terms of general workflow - but, again, in that case you can’t pre-hear loops at all. So you would have to switch back and forth with that button - and there’d still be no quick/easy way to be able to pre-hear loops when working with longer samples (unless playing everything from the beginning every time).

So yeah, just my view on this; the old functionality was perfect, why fix it if it ain’t broken… But I do appreciate the suggestions all.