[???] Melodyne Plugins: Renoise Play Button Stops Transfer

Don’t know if this has happened in older versions, since I haven’t used Melodyn Plugin before.

Anyway, when I press Transfer-button in Melodyne Plugin it’ll record incoming audio when host starts playing, but when I press play in Renoise Melodyne thinks it should stop recording (which should happen when you press stop-button).

Works fine in Reaper, so I guess it’s Renoise bug.

YES. This has indeed been an issue for as long as I’ve used Melodyne in Renoise (at least 2.6, but I believe before that). Thanks for the reminder and +1 on fixing this if possible.

Which melodyne versions do you use on which platform (Mac, Windows?). Audiounits or VSTs?

Tested VST versions and 1.2 on windows and they both do work fine.

Windows VST, Melodyne Plugin Should be latest (and probably last) version of Melodyne Plugin. At least it’s what Celemony offers me as a download.

The latest demo is (includes a plugin version):

Different product. That is Melodyne Editor, not Melodyne Plugin.

Don’t know how important it is to support discontinued product tho.

This editor thing does include a plugin version too. The download link above at least does install one.

Something to check:
Is auto suspending disabled for Melodyne in Renoise?
Does enabling or disabling “Static Processing Buffers” for the plugin make a difference?

See “?” button in Renoises editor of the Melodyne plugin to setup those options.

Actually I noticed similar bug in Melodyne editor too. When starting playback when pattern loop was on, the the transfer switched off. When starting playback with pattern looping turned off, and then turning it on, the transfer stopped on the first loop.

Have to check the settings when I get home.

But just to clarify: this IS a different product. Melodyne Plugin is older version and doesn’t include for example DNA. Bought this second hand month or two ago and haven’t upgraded because it’s not a free upgrade.

I discovered that it works fine as long as you don’t use it from pattern 1.
So, my guess is some wrong data gets sent to plugins in the beginning of the first pattern.

None of the plugin settings had any effect.

Perhaps the midi panic fix might address this issue as well then…

I still can’t replicate the issue here. Sauli: could you please set up a small example song where this does happen for you. Is there a demo version of the old Melodyne Plugin version available somewhere?


Sorry, just noticed I had been using b2 and it seems that something has fixed the issue.

B2 expired and I downloaded beta5 and everything seems to work just like it should.

Thanks and sorry for taking your time :)

Sorry, false alarm. For some reason it worked for a while, but now again I have situation where it doesn’t work and I have no idea why. I’ll do some tests tomorrow and try to find a scenario where it works and where it doesnt.

Installed b5, drew a sample, made short melody, transfered it to Melodyn Editor and everything worked fine.
Settings were: Record mode on, follow on.

Replaced the sample with virtual instrument (Aria player/gpo 4) and transfer stopped working, but bugged differently this time. It never stopped recording, no matter if I stopped playing or pressed stop button. Closing plugin was only option.
Made another instance of Melodyne Editor to different track and it worked, but bugged like I described in my original post. Moved it to the same track the previous instance of ME bugged (differently) and it didn’t change it’s behavior (bugged the “old way”. Deleted this instance and made another one and again it bugged with “different” way. Really really confusing…

bump:any more tests done that could filter out more?

Upgraded to Melodyne Editor, but the bug is still here.

Seems to work fine if not used on first pattern and the bug only appears with some vsti’s.
Doesn’t even matter if the vsti is used or not, as long as it’s loaded the transfer is automatically turned off on beginning of first pattern.

Tested with several vsti’s and bugs with for example these: Alchemy, FM8 and Keolab Spicy Guitar.
Spicy Guitar is free and can be found here.

Here is a test xrns which uses Spicy Guitar and Melodyne Editor. Transfer works fine on second pattern, but bugs on first.

any progress with this one? anyone even looking for solution?

this has been an issue for me since years throughout various different versions of melodyne (plugin or editor) as well.
sometimes it works like charm and sometimes it drives me nuts because it does what’s described above.
i never filed a bugreport because i wasn’t able to replicate the problem as well, but i always had the impression that the more “complex” the song becomes, the more likely melodyne will have problems.
i think it never happened in a fresh project with no futher plugins and fx loaded.
maybe this is related to how renoise handles PDC?

I think it is!

Tested without PDC and no problems! PDC back on - Melodyne transfer stops automatically when I press play. Other plugin used was Kontakt 4.

renoise 2.8 b3 gets terminated/killed instantly when using melodyne (editor) v2 on samples and vstis.
no matter on which pattern, no matter which vst config. … with PDC disabled.
it also terminates on samples with pdc on but with vstis it just records a very small snippet, thats all.

and it even happens on an empty channel with no audio.

OKAY!!! …

i had my audio settings on 44.1khz, no hardware buffer.
changed this back to 48khz, with hardware buffer and tried it again and used
‘can run in multi processor env’ turned on for the plug. rest off …
with and without pdc. it worked on samples but still doesn’t work with vstis.

and if i load the same song again, load melodyne plug again, renoise crashes
because of some gui problems with melodyne.