New column being created every note

Ok so, I don’t know what I did to cause this. I thought maybe it had something to do with me disabling “record note off” in midi prefs but I changed it back and it still does it, so I’m stumped.

When I’m recording live input, every note I hit creates a new column. I’m just recording a ride, it’s the same note over and over, and every single one creates a new column. It’s only doing it on this xrni, so it has something to do with an xrni setting, but I can’t imagine what.

The note needs a note off thru midi first or a new column will be opened. You also can set the instrument to mono to avoid this. Of course more sophisticated midi recording settings would help a lot, e.g. quantization shouldn’t quantize the parameter recordings etc.

What is causing it to not receive a note off though? I reenabled the record note off and it still did it, and it doesn’t do it for other xrni’s. Shouldn’t it be getting a note off from me releasing a key?

Are you playing notes on the actual piano keys, or via drum pads?

If it’s drum pads, are the pads actually configured to send note offs? On my Novation Remote SL, the pads don’t send note offs by default, which is rather annoying.

If you check the instrument’s MIDI tab in Renoise, do you actually see the note off events being logged there?

It’s piano keys, I don’t have drum pads unfortunately :frowning: . I’ll check the midi tab when I get home from work. When I switched to other instruments live recording worked exactly as expected, it’s just this .xrni, which seemed really weird to me.

Probably worth uploading it somewhere, so the rest of us can give it a try?

Unfortunately I can’t because they’re commercial samples.

Ok, I’ve had some time to have a look at it while not being half asleep at 2am. It’s actually inserting the note offs, but still creating a new column every note, as if I was playing a chord, but it’s the same note over and over and you can’t play a chord with one note so I have no idea what’s going on.

I also noticed something else, that it only does this if the new note is played before the end of the sample. The samples are NNA continue so that they don’t interrupt each other, so I want the samples to continue playing despite there being a new note in the column.

I’ve found that if I disable one-shot, that this odd behavior stops. So one-shot is causing this, but why? Is there a way to make it not do that?

I batch silenced the samples, saved them as .ogg’s, and put them back into the .xrni so that I could share the .xrni, but this might be reproducible with just any long enough sample set to one shot.

https://www.dropbox.com/s/34wpn99bd0azq7g/newcolumns.xrni

edit: Should I submit this as a bug, or is this somehow the desired behavior of the effect of one-shot on live recording?

Any ideas on this? It makes it really hard to record. I can temporarily toggle one-shot off, but then it doesn’t sound right because you have to hold the note for the entire length. But with one-shot on, I end up with like 6 note columns.

I don’t think that’s working as intended. Internally it sees that the note is still being played, so it makes a new column.

I cannot reproduce your issue with your song.
What i do notice is that Renoise does not record note-offs for the unassigned keys, this is default behavior for keys that are not assigned, but i’m not sure if that would be disturbing the process if you accidentally hit an unassigned key.
I do notice that the NNA of all your samples are set to “Continue”, not that this should trigger this behavior, but perhaps might interfere with the unassigned keys. From my side, i cannot reproduce your behavior though.

I believe this is the issue

http://youtu.be/QZ2P6bU1bQI

^Yeah that’s exactly what’s happening. Since it definitely seems to be a bug I’m going to submit it. Thanks for the video capture gova.

It does it no matter what NNA is set to. I can actually repro with any sample that’s long enough. The only thing required is to load the sample and set it to one-shot. I went ahead and submitted it as a bug.

https://www.youtube.com/watch?v=-dtkvaXLF3U

That video goes through the whole process of reproducing.