New Tool: Automation Cleaner (2.7)

Update (4/5/2011): Added a menu item to apply Automation Cleaner to all patterns. (2.7 version only).

Update (19/3/2011): I uploaded a new version that is compatible with Renoise 2.7. The old one has been renamed to …_26 and will not be updated anymore.

This tool deletes automation points with values that lie between the preceding and following values for easier editing. The tool can be found by right-clicking in the parameter list on the left side of the automation editor.



It is my first tool and my first encounter with lua tables (I don’t think I like them), so I don’t expect it to be perfect. It seems to work for me, though. Thanks to taktik for his help.

Update: solved an issue when a parameter with no automation was selected.
Update: moved the menu entry from the Tools menu to the context menu of the parameter list in the automation editor.
Update: added a menu item for the automation editor’s context menu (right-click on the ruler to see it).

Oh. This is pretty neat. Thanks!

Awesome, thanks a lot!! :)

thanks works great

Though when selected parameter is not automated it acts funny. On the parameter list it’s shown as the parameter is automated, but in the automation window there’s nothing (no points, no line and no fill).

Yeah, I noticed that too. I’ll look into it.

I guess it may be a bug in Renoise…

I’d like to see the opposite of this - script that converts linear and cubic curves to points.

I posted a new version that displays a message in the status bar and terminates when the currently selected parameter has no automation points.

Yeah. Makes more sense.

Nice tool!

Wouldn’t it make more sense to have this in the automation editor right click context menu?

Good call, I posted an update. The script now appears in the context menu of the parameter list of the automation editor (the automation editor itself doesn’t have a context menu). I removed it from the tools menu to prevent clutter.

i must be blind,i cant find it now

That’s strange… I just re-installed the version I posted, and it still works. I get this:

Is there anyone else who can’t see it?

You can get the entry in the tools menu back by deleting the double square brackets on lines 4 and 10 in the main.lua file. Does that work?

never mind it is working,i just didnt tried to right click :rolleyes:

Disabling and enabling the tool in the toolbrowser should do the trick perhaps?

Cheers, nice tool. :)

I agree. Unfortunately, this is currently not possible. There is no right-click menu for the automation editor.

(Although the scripting documentation does mention Track Automation as a possibility for adding menu entries. I tried it, but it does nothing. Maybe this is an error in the documentation, but I hope that it is a sign that there will be a context menu for the automation editor in the future.)

Ideally, I would like to have this as a button below the editor, but this is something that Renoise scripting does not allow.

“Track Automation:Something” shows up the automation !ruler!s context menu. In the automation right clicks are used to create new points, thats why there is no context menu.

See also The Selected Parameter In Automation Editor please…

Aha, that is why I couldn’t find that menu! I tried right-clicking the graph area and the toolbar, apparently I forgot the ruler. But the Renoise manual does mention it, so I should have known.

By the way, for me, the right mouse button does not behave the way it should according to the manual. Without modifiers, it behaves exactly the same as the left button, which is why I wondered why there was no context menu in the first place. Makes sense if it has a different function, though.