No sound with Superwave VST's


I’m having an issue when using the Superwave Equinoxe (or any other VSTs of Superwave) with Renoise: there’s no sound and I cannot register the free edition --pushing the Register button in the VST window has no result.
I did start Renoise with admin rights (per [Solved] No Sound With Superwave? ), but there’s still no sound.
Further, setting admin rights for AudioPluginServer32 and AudioPluginServer64 didn’t change anything.
Toggling the “run plug-ins in separate memory space” option also didn’t improve anything.

There is CPU activity while running the plugin and the note-on commands appear to reach it.
Both x86 and x64 versions of the VST plug-in exhibit the same behavior.
I tried Renoise versions 2.8, 3.2.1, 3.4.0 and 3.4.2, all with the same outcome.
My OS is Win10 x64.

Any hint is more than welcome :slight_smile:
Thank you!

I’m using the same operating system WIn10 64bit and Renoise 3.4.1 or 3.4.2 and I just have checked Superwave P8, because the one you’re using costs money and I don’t want to buy any more synths. Anyway, Renoise doesn’t even detect the 64bit version of P8 and a rescan also doesn’t help. On the other hand the 32bit version works as expected, no issues at all. I guess these Superwave synths are outdated, at least P8 (last update 2017). If you really want to use specifically these synths I would deinstall every single Superwave VST and reinstall the 32bit versions of those you want to use. Make sure it’s in the same folder than your other VSTs. If Renoise doesn’t detect it try a rescan. If it still doesn’t work I would recommend to fart on that shit and use Serum instead. :wink:

I did try both 32-bit and 64-bit versions, both output no sound.
No need to buy the plugin, a demo version works (or rather, doesn’t work :slight_smile: ) just as well.

I tried running the whole thing on a Win8 machine, and all is fine: Equinoxe demo + Renoise 3.xx sound ok out-of-the-box, no Admin rights needed etc.

Ok, so let me try to get this right first. You used the demo version for 21 days, afterwards you’ve bought a license and now you’re trying to register but it doesn’t work?

As for the sound, there’s a limitation as you can read on the website:
All SuperWave products are fully operational for 21 days from the date of installation.
After this time period, audio output will be inaudible.

Once you’ve installed the demo on a specific computer and you used it for at least 21 days, there may be no sound anymore on that specific computer if you’re using this demo, even after deinstalling and reinstalling. You have to register if you want to make it work. If you can’t register contact SuperWave. :wink:

I installed Equinoxe the first time yesterday, so it should work fully.
Also, pushing the plugin’s register button does nothing on the win10 machine, whereas on the win8 machine it opens the registration window.

Ok dude, I took a few minutes to check for you. There are absolutely no issues with the demo of SuperWave Equinoxe 64bit on my Win10 64bit system. It runs, there is sound and the register window opens trouble-free. Have a look:

So I guess there is something wrong with your computer. Check all your drivers and make sure you’re using current drivers all the way, update your WIndows, check your whole system. That’s all I can say. Good luck!

Thanks a lot for checking this. Indeed, I’ll need to dig into my own machine.
Apologies for having wasted your time and thanks again!

Meanwhile I addressed the topic @Superwave and Chris Gill was kind enough to send me the registry keys to make the plug-in registration in “God mode”, circumventing the dialog box that wouldn’t open.
Now I have sound as well as a registered plugin. All good, time for some music.

Thanks again for the support!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.