Noodletrap tool - errors


(zooterman) #1

Hi

This is an awesome tool ( thank you @Danoise), but I am having scripting tool errors come up after a little while using it.

see attached.

Can anyone help fix this error? I really like this tool.


(danoise) #2

Thanks for reporting!

If you can you reproduce the problem, perhaps you could share this info too?


(zooterman) #3

It occurs after a round of phrase recordings; I’ll successfully record some passages but then after a little while of stopping and coming back to it some time later the error comes. I click OK and it makes the error message disappear, and while i can ‘start’ Noodletrap’ thereafter, it no longer picks up my MIDI for the recording to start.

Not sure what’s actually causing it.


(danoise) #4

Well, you gave me something to look for!

(you’re using MIDI for starters - there are many possible ways to use & configure this tool… )

I feel like spend a little time on this tool today, lemme just see if I can find & squash that bug…


(zooterman) #5

thank you very much. The things you are doing for your fellow producers and composers is much appreciated.


(zooterman) #6

any luck with this Danoise?

I base my whole writing around this tool…

If you’re too occupied to investigate it, I understand, no problem.


(danoise) #7

I’m quite happy with this tool as well, so let me just try to fix it.

Edit: a second attempt at reproducing the error, but I still didn’t manage to.

I think I really need more info from you, explaining _exactly_ how you are using the tool. There are many variables to consider here.

It occurs after a round of phrase recordings; I’ll successfully record some passages but then after a little while of stopping and coming back to it some time later the error comes.

  • Does the error happen as you are striking a key on yourMIDI keyboard?

Error message seems to indicate this.

  • How is the tool configured (settings) - record arming / start / stop ?

You can share the “preferences.xml” in the tool folder to answer this.

  • Does the error happen at specific places in the song (e.g. near end or start of song)?

  • Anything else that might be considered “unusual” ?


(zooterman) #8

I’m quite happy with this tool as well, so let me just try to fix it.

Edit: a second attempt at reproducing the error, but I still didn’t manage to.

I think I really need more info from you, explaining _exactly_ how you are using the tool. There are many variables to consider here.

  • Does the error happen as you are striking a key on yourMIDI keyboard?

Error message seems to indicate this.

  • How is the tool configured (settings) - record arming / start / stop ?

You can share the “preferences.xml” in the tool folder to answer this.

  • Does the error happen at specific places in the song (e.g. near end or start of song)?

  • Anything else that might be considered “unusual” ?

The error happens after approx. (random) 3 or 4 passes of using the tool. I’m able to successfully use it to record the first few phrases (stop/starting for each phrase).

Then without warning, I’ll go to do the next pass and as soon as I hit my external MIDI device, the error dialog comes up.

I have attached the preferences.xml file.

I’m unsure whether it happens at specific places in the song. The pattern it has followed that I’ve noticed is as above - able to do a few recording passes, then all of a sudden on the next one it fails upon hitting the MIDI device note input (after already set to ‘Start’ on the Noodletrap tool)

attachment.


(danoise) #9

Hi zooterman,

I’ve just put out a new beta of this tool which fixes all known issues apart from the one you reported:

http://forum.renoise.com/index.php/topic/43047-new-tool-30-31-noodletrap/page-4#entry370913

Would be really great if we could somehow squash this bug - here’s a couple of ideas:

* I create a special version of the tool for you, which prints debug info to the scripting console … which you can then share with me

* You record the screen while you’re using the tool, so I can study the exact way you’re using the tool


(zooterman) #10

thanks Danoise. I’ll d/l the beta version, and do a screen recording for you. Thanks