OSX 10.3.9: Demo Version Wont Start

Hi. I have a problem with Renoise demo. After downloading, when I try to open it I get the bouncing icon in dock, but after a couple of seconds it dissappears and demo won’t start. Where did I go wrong?

Trying to run it in a G4/733 Quicksilver with 10.3.9


We need more info.

Please open the Console (Applications -> Utilities -> Console) and locate ~/Libary/Logs/Renoise.log. Paste the messages that may be useful for us to help you.

FYI Renoise 2.5 (the next version) will require OSX Tiger (10.4) or higher and 10.3 will no longer be supported.

But, the Renoise 2.1 Demo should still work. So, let’s figure this out.

Okay, thanks for answering, here we go:

There seems to be a rather long log file, so I’m not sure about how much I Should paste. Here’s some stuff from the beginning:
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: Renoise
Path: /Volumes/Renoise2.1.0/Renoise.app/Contents/MacOS/Renoise
Version: ??? (???)
PID: 590
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 <<00000000>> 0x00000000 0 + 0
1 com.renoise.renoise 0x000025c4 0x1000 + 0x15c4
2 com.renoise.renoise 0x0000246c 0x1000 + 0x146c

I’m not too good at this, but I can paste more if needed, there’s a whole lot of it.

I’m already looking for a retail 10.4, but I was hoping meanwhile to try Renoise out. Strangely I’ve had problems installing my old Logic 6 Audio too…


Maybe it’s a ReWire crash…



Please manually trash the “Renoise Engine.plugin” in your “/Library/Application Support/Propellerhead Software/ReWire”, or Renoise won’t start.

Yeah, I was “hoping” for that myself when I saw that thread, but I don’t have Reason installed atm and there’s no such folders or files…

It’s not Reason though.

Renoise installs those files itself for the ReWire protocol. ReWire allows you to control two applications at the same time. Example: Ableton Live & Garageband. You don’t need Reason to use it.

Can you look again?

Theres a difference between /home/YOURNAME/Libarary and /Library, for example.

Oh, You’re right about Rewire, Ofcourse. But still there seems to be no such thing on my computer. Tried to find it manually and with search function.

And when I tried to open Renoise QuickStart Tutorial I get the error message saying “Couldn’t open the file. It may be corrupt or a file format that Preview doesn’t recognize.” I’ve tried to download it again for a couple of times but it’s still the same. Everything works beautifully on my wifes iMac, which is pretty new machine with 10.5.

Oh… You probably have Stuffit or something which is mashing up the archive.

Please use something like The Unarchiver and try reinstalling Renoise.


Hmm… could be. but then it shouldn’t work on my wife’s computer either? As I’ve tried also to download and unzip it there and move it here with usb memorystick. Didn’t help. I’m one big “?”


Newer versions of OSX have a better built in Archive support for more “Unix” like formats. OSX 10.3.9 comes from the Stuffit era, and there were some problems in the past, so I made an educated guess:


I’m also stumped, then.

Yeah, looking forward to get Tiger. It’s not new, but it’s a step up. I’m not sure if my old QS could handle newer versions. Even if it could, there would be issues with hardware drivers and such.

Thanks for trying to help. It’s very nice to get an answer to a newbie-question. Guess I’ll have to try Renoise on my wife’s computer when she’s not working.


Or attempt to swap your Wife’s computer for yours B)