Osx: Cursor Keys Work Intermittently In Pattern Editor

Running 10.5.8, mid 2009 macbook pro

I usually get 5 minutes or so of normal functioning and then my cursor keys become really unreliable when moving around in the pattern editor, I’d say about 6 out of 10 presses work. I’ve tried external an keyboard as well to rule out the hardware and the problem’s still the same. CPU load’s normal and it can happen with an almost empty song.

It’s been running fine for about a month or two before this with the same Vsts etc. installed.

any ideas?

Done any (OS)software updates lately or added software functionality?

Beside of what VV said I also have no real idea here. Sorry.

Have you installed some OS tools lately, something like menu bar tools, keyboard sniffers, recorders or something like this?

Does this only happen in Renoise?

If you reload the song, does it then temporarily solve the problem? Does this only happen in one special song while it works in others? Probably some VST or AU does something with the keyboard then?

There’s been the standard os x updates but that’s it as far as I know. I tried increasing the latency and this seemed to fix it for a bit. Happens in all songs after about 5 minutes.

On more than one occasion I’ve had it totally freak out and continually scroll upwards. Only way to stop it was to quit the program. I’m thinking it might have something to do with the trackpad, since you can use two fingers to scroll in the pattern editor with that.

I’ve tried reinstalling os x as well.

EDIT: Ok I’ve had another look at it and the problem goes away in a completely empty song file. Seems it doesn’t have anything to do with the trackpad. Taktik, it only seems to happen in Renoise, but then again that’s the only program where I use the cursor keys a lot. The reason I love renoise is how fast you can edit things and this is severely limiting me.

I’ll try removing VSTs one by one and see what happens.

Is there some kind of cpu powersaving or eco mode active?
I also recall someone having problems when AirPort network drivers were enabled.

There shouldn’t be any kind of power saving mode active, I’m connected to the power supply. I noticed that if I hold down the cursor key the scrolling shudders occassionaly and seems pretty intermittnet. I just loaded up a song and gradually deleted all VSTs and instruments, checking all the way. Seems the problem is still there even when I empty a song.

Tried switching off Airport but no difference. Thanks for the suggestion though.

Powersaving as things like Intel Speedstep:

Everytime i find something like this about the Mac, i’m just glad i’m not a Mac owner…

Oh FFS. I’m getting fed up with Apple not giving users any kind of control. It’s the same situation with the trackpad on my macbook, I can’t switch off any of the ridiculous multi-touch gestures.

Anyway I’ll give this a try and see if it helps.

Don’t want to be captain obvious, but do you have some stuck keys sometime? Or something?

I had an iBook G4 where my mouse button would be constantly “stuck” in the down position because, well frankly, it was simply broken.

Yes you can. I switched them all off. What are you talking about?

The quote about it on Wikipedia:
http://en.wikipedia.org/wiki/SpeedStep

Doesn’t seem to happen in any other programs and I’ve tried using a usb keyboard, same problem unfotunately.

These are the multi touch gestures I mean http://blog.room34.com/archives/3037

Ok, I’ve been playing around with the latency settings in Renoise and they seem to be having an effect.

10ms: I’ve been using for the past month or so, it stutters when I try and move around. Playback is smooth and CPU load is at ~10%

60ms:I can move the cursor down but not up (WTF?!). Cursor stutters when moving up. Playback is fine.

5ms: everything seems to be fixed. Playback is fine. CPU load at ~13%

1ms: same as above, however there are dropped samples (is that right?) unusable. CPU load at ~20%

To me this suggests that you’re right about the speed stepping vV. I tried coolbook to permanently clock the processor at 2.2ghz and disable throttling but it didn’t effect the behaviour in Renoise (temps did build up though so it did work). Seems to me that as long as I keep the processor load above 13% everything works fine. This is bizarre but it seems to work so far.

Thanks for your help.

i occasionally experience similar mysterious keypresses quite randomly… started a topic about it once. my experiences are similar to yours, fairweather, but with much less frequency or regularity i think… for me it’s just a small annoyance.

i’m using a macbook, the early 2009 white model, with 10.5.8. these strange scroll locks/false kepresses also occur on my early 2009 mac mini with similar specs. even happened a couple of times on the macbook with an external usb keyboard. never experienced anything like it on my linux or windows xp boxes…

no rhyme or reason, seems totally random…renoise is the only program i’ve ever noticed it in… i’ve tried to take note of any specific things i might be doing to cause this, but nothing has popped up yet. wish i had better info to give you taktik…

hope this makes sense… i’m kinda tired/buzzed

doesn’t sound like this is the problem in this case but key presses not registering or coming in late or doing weird things can be a problem with dead batteries in wireless keyboards.

Fairweather:
Do you only have this problem in the pattern editor and only while using the arrow keys to navigate while playing?
Do the arrow keys work just fine when for example navigating in the disk browser? (Click with the middle mouse button to the diskop, then you can use the arrow keys there).

Theres a keyrepeat setting in the Renoise preferences: “Preferences” -> “Keys” -> “KeyRepeat”. Does setting this to higher values help?

I was talking about gestures. (System Preferences > Trackpad) But whatever.

To be honest, every time you “help” a mac user, you tend to throw in a disparaging comment (I’m glad I’m not a Mac user) which is kind of lame. It’s like the guy trying to find the clitoris, glad he doesn’t have one though!

As for the keys, look at (System > Keyboard) and change the key repeat rate maybe? Also, the same settings are available in Renoise as Taktik has pointed out.

Finally, look at the Console. Maybe some log messages will shed some light.

PS: I run OS 10.6.X

What does “stutters” mean? Can you be more descriptive?

Also: are you touching the trackpad with two fingers while navigating, or something? Renoise will respond to these types of navigation gestures…

I don’t know about 10.5.8 (I was a 10.3, 10.4, and now a 10.6 user, I skipped 10.5 because I felt it was a pile of bloat) but in 10.6.X you can look at which gestures are ON/OFF in (System -> Trackpad) - Maybe it’s simply a matter of the way your fingers use the trackpad?

I was actually aiming for the fact that you have to pay for the solution to be able to control a very simple thing in an OS that should be solvable from within the OS with a simple toggle.
I just feel sad that some folks attempt to squeeze a buck out of the somewhat silly incompetence that can be found within the Apple Mac platform. And yes i’m sorry, Mac would not be my platform of choice any time soon… i’ve followed Apple development quite some 15 years to be more exact and to be serious, i never liked various Apple policies that contain really a lot of restrictions.

:rolleyes:

I use both Windows XP and OSX (10.6.1). No problem with the keyboard whatsoever.

This problem only seems to occur in the pattern editor, I’ve had no problem with key presses being detected in the disk browser. I tried changing the key repeat and there are still times when a key press is not detected, no real difference unless i’m holding the key down, in which case the selection moves slower as expected.

By stutters I mean that when I hold down either the up or down cursor key the selection bar does not scroll continuously and smoothly. It seems to get stuck for a fraction of a second at irregular intervals. It’s as though only 8/10 key presses are correctly picked up. For example, if I tap the down cursor 10 times it will arrive on line 7 rather than line 9.

I’ve tried holding down a cursor key to scroll and moving two fingers on the trackpad and it doesn’t reproduce the problem I have. The trackpad seems to take priority, it will scroll back up until I release my fingers, in which case the keyboard takes over and it begins scrolling down again.

I would disable the trackpad gestures if I had the option, but trust me, in 10.5 the option is not there.

Like I said, reducing my latency settings and placing more load on the processor seems to fix this problem. I am curious as to whether there are other people out there who’ve had this and haven’t visited the forum. It’s very strange.

Also, Conner and vV, I understand what you’re saying and appreciate your help but let’s not turn this into a fight over which OS is better. It really depends on the user and I’m sure you know this.