Osx: Cursor Tabbing Through Columns - Possessed Laptop

hey guys,

i have been seeing an issue with 2.6 on a mac that every so often when it starts up, the cursor/highlighted point in the track just starts flying across the columns, similar to as if i would just hold down the tab key and not let go. just flies across. even if i play the song, still keeps happening, there’s nothing i can do or any character i can hit to escape it.

anyone see this as well? or is my laptop possessed by some evil force? usually on a reboot i can get it to quit.

just downloaded 2.6.1 to see if it will quit - hopefully it does. just wondered if i was going crazy(er).


yeah… just checked, still doing it in 2.6.1

it happens very rarely to me as well. It looks like it happens when I very rapidly switch between LALT+TAB and TAB, or LCTRL+TAB and TAB.

usually, pressing LCTRL+TAB a couple of times convinces the cursor to stop

A few users on OSX have reported this, and for most of them restarting the computer or logging off/on magically solved this.

We also got reported that “Things” (a task management app for OSX) causes this problem when its running in the background. It also causes other strange keyboard bugs in other apps like Photoshop. Do you maybe have this “things” thing installed as well?

If I remember correctly the trick is to login as a different user, not just logout.

Posted here by dblue.

Ladies and gentlemen, we have a winner. I would have never thought to try that. I didn’t even have a second account in Snow Leopard, so I created one called “Temp”, logged into it, logged back into my main account, and the keyboard worked in Renoise. Awesome. Thank you!

I don’t have access to a Mac to test any such claims myself, but it seems to vary from system to system. I was dealing with a recent support request where the user mentioned that simply logging out and back into the same account seemed to work, while others in the past have reported that switching accounts was necessary. Definitely a weird little bug though.

thanks guys, i appreciate the help. glad i’m not the only one :)

i’ll just sign out if it happens again & wait to see when this might be fixed.

take it easy!

Ahh I’m so glad that someone else documented this. It’s really freaking annoying. Has been happening since 2009.

I get this issue too. OS X 10.6.
thought it was my bloody keyboard