Embarrassing Question

Hey everyone. This question is embarrassing since I’ve been using Renoise for years, but I am stumped. As a bonus though, hopefully this experience will motivate me to make more music and not let myself get so rusty. ANYWAY, on with the show.

Today I fired up Renoise (OS X) for the first time in months, loaded a sample, and tried to input a melody with my computer keyboard. Aaaaand it didn’t do anything. Pressing the keys did absolutely nothing. I uninstalled Renoise, downloaded and installed the latest upgrade, and tried again. Nothing. A couple times I did manage to temporarily fix it by doing my patented professional method of “slamming on random key combinations in a fit of frustration”, but after a few notes it magically stopped working again.

So, I ask you… is there some basic “computer keyboard input: on/off” checkbox somewhere that I never noticed, in almost 3 years of using Renoise? Thanks. :P

Two things you should check:

  1. Did you have your keyboard focused on Pattern editor?
  2. Did you have editmode on? (the [ESC] key)

Try logging out of your OSX user account, then log into a different account, then back out and into your original account.

There have been a few OSX keyboard related issues which this method seems to ‘fix’, so maybe it’ll work for you also.

Ladies and gentlemen, we have a winner. I would have never thought to try that. I didn’t even have a second account in Snow Leopard, so I created one called “Temp”, logged into it, logged back into my main account, and the keyboard worked in Renoise. Awesome. Thank you!

  1. Is the cursor inside a track on the pattern editor? And is the output routing right? (going to the master) Do you see the volume meters go up in that track or in the master vu-meter?

OSX keyboard issues have been cropping up a few times lately. Some people experience an inability to play or record any notes via the keyboard (as in this thread), while other users experience seemingly stuck keys (or behaviour related to this) that cause the cursor to move automatically, etc. There have also been some email support requests reporting similar things.

In each case I have suggested the logout/login trick, which seems to ‘fix’ whatever was ‘broken’, but I get the feeling that there may be more to it somehow.

Any OSX updates having past lately that might be behind all this?

I honestly have no idea. I’m not a Mac user myself, so I’m unable to do any testing of my own. It’s quite odd that changing user accounts seems to un-stick whatever gets stuck. I can’t really imagine what the trick would actually be resetting in the system to make it behave normally again… some flag or preference somewhere?

Nobody seems to report keyboard problems with any other software, though, so if it is an issue with the system itself then it only seems to affect Renoise for some reason.

I had a ‘stuck key’ issue today on Win 7 :S Happened after rendering. Restarting Renoise solved it. Strange stuff happening…