Osx&linux Renoise Do Not Support Mono Devices

Try as I might to get the C-Media USB Device (a XLR-cable to USB) function under OSX Renoise. It’s a mono USB audio device… Please could this be made to work?? :))

Renoise currently doesn’t like Mono.

OSX Renoise doesn’t… PC Renoise handles it like a trooper :)

Didn’t know that as far as the soundcard (driver) went but Renoise still doesn’t like Mono.

No mono tracks.
No option of mono output (aux routing for eq.)
No mono routing for rendering.


Kazakore, why are you telling me that stuff I know works on Windows, which I report as not-working on OSX, doesn’t work in Renoise?

Renoise 2.7.0 on Windows PC with C-Media USB Device:

This is simply not a case of Renoise “not liking” something. It’s a simple case of Renoise Windows having support for a Audio Device which Renoise OSX doesn’t have support for. I know that the mere plugging in of C-Media USB Device during Renoise playback (especially when ReWired into Ableton Live) would cause a massive crash of both softwares, and I know that Taktik knows of these things and has thusly disabled C-Media USB Device support on Renoise OSX - and I know that Renoise Windows supports said device - I’m just reporting that yes, Renoise OSX doesn’t like this device, and I’d like to simply notify the devteam of this bug, because it’d be splendid to be able to use this device with Renoise on OSX - since I use Renoise OSX daily.

So you can have a mono track in Windows can you?


Sorry the card doesn’t work in MacOS but does in Windows, as I stated I didn’t realise that initially. But do you know if that’s due to the drivers or if Renoise will not support ANY mono device in MacOS?

And it doesn’t change the fact that Renoise generally is not much of a fan of Mono or anything other than fixed stereo tracks. Which is a shame.

We are aware of this, don’t worry, and will try our best to support mono devices on OSX in the next updates. They will behave like doubled mono channels though, as they do on windows.

The crash that you are refering to had nothing to do with unsupported mono devices, and got fixed during the 2.7 beta.

Smashing news!

Hi. Just tried a Logitech QuickCamPro 9000 usb-cam and Renoise didn’t recognize it. D’you think there’s any chance that a near-future update to Renoise would have OSX USB Mono In Device support, please?

Hi, I hope that when you guys will support mono devices on OSX in the next updates, that you will also [support mono devices on linux in the next few updates.](http://www.renoise.com/board/index.php?/topic/22775-fixed-25-linux-alsa-assertion-crash-with-mono-capture-device/page p 181477#entry181477)