Osx: Scripting Terminal&Editor May Lose Keyrepeat (Again)

Yep, still occurs,

Could you please please give us a “bit” more info then? What exactly do you do before keyrepeat is lost? Which Mac OSX version are you using. Does this always or only sometimes happen. I could replicate this before 2.7.2, but no longer in 2.7.2.

I have had keyboard drop it’s repeatrate in the scripting editor, when cmd-tabbing (osx) from a browser back to Renoise, or from the Terminal back to Renoise. Also I’ve registered one time during 2.7.2 where my keyboard refused to be registered as sample_plays or even as entries to the pattern editor as notes - i.e. actual note keys were stopped from being recorded, even if record mode was on. The scripting editor performs better nowadays, which is very good, but one can still get Renoise to stop wanting notes altogether or to stop. I’m hoping that the “infinite tab” doesn’t appear on 2.7.2 anymore, as it seems to have almost completely stopped with 2.7 :)

Ok, I got it to happen in the scripting editor now. I’ve tried to paste 4 times from the OSX clipboard (to scripting editor) and I was wondeirng why it would constantly paste what I had in the osx clipboard - instead of what I just copied from the pattern editor, I went to paste the pattern editor stuff to textedit, then copied that to clipboard and tried to paste to Renoise scripting editor and saw that it was still pasting a preivous url - which was obscure. I then decided to copy that selection to clipboard inside Renoise Pattern Editor and started shift-cursor-keying to get to the first character of the current row, and then decided to press a cursor key down and noticed the repeat had been shot again.

I’ve had this happen on many occasions, and not limited to some sort of obscure XML pasting either.