Play & Loop selection ?


Wondering if it is somehow possible to play & loop only the selection into the pattern editor with the option “Selection in Pattern”, or is play only a global action ?

I discover the software, and instinctively, i was trying to loop only parts of the pattern editor, but perhaps it is not possible?

I think the closest feature to this would be block mode.

1 Like

Damned ! :D It was just below the play button… Yes, it was exactly what I was looking for. Thanks Veggies for the direction.

Ah yes, I see… The block tool is not very handy.

When one changes its size while playing sometimes it loses focus, and one can not change of block loops in realtime when play is on.

Perhaps there would be some space for enhancement in this domain ?

Might this tool get more closer to what you need?

Thanks for the link Vv.

So, now, it leads me to several remarks.

-It seems that I have a problem with the file the post pointed out (*.xnrx). I can download it, but once downloaded, it creates an instability into my system: right-clicking on it makes windows explorer crashes (under Windows 8, 64 bits). I tried to google about this issue, and the result is that such a bug would eventually be related with the file icon, but I don’t know if it is actually the case.

-As I can’t right-click the .xnrx file, I was not able to dezip it and modify the error present in the lua file (some extra parenthesis you pointed out in the thread above).

-Now, excepted those issues, it seems that the function is pretty close to what I was refering. I’m new to Lua, but was thinking that the SDK could allow that too:

1)Get the line beginning and the line ending of the selection  
2)Set a hotkey to play the current selection at the range set by the selection.  

But apparently, it seems to be a little bit more complicated as explained by the post of Danoise a bit after:

That said, yes, it is getting closer. :lol:

Sorry about my slackness of late but I believe I’ve corrected those issues and reuploaded. Sorry, forgot to change version number (yet again) but as it’s only released on the forum I don’t think I will bother changing it now…


Finally, my right-click bug is solved with windows repair disk utility and was not due to *.xnrx files.

Kazakore, thanks for the script example.

The file has not been corrected: I removed the extra parenthesis and now it works, if I may post it (cf attachment).

However, it seems that I can’t get to make it work properly, or only partially.

I assigned shortcuts to the four functions:

-Set Loop Start
-Set Loop End
-Loop Selection
-Clear Loop

If I correcly understood, it is a four steps action:

-clicking on first line then “Set Loop Start”
-clicking on end line then “Set Loop End”
-Then “Loop Selection”
-Then “Play”

However, it does not seem to function correctly this way. And also, “Clear Loop” makes everything kind of “selected”.

My guess is that if one could only select the first line and the end line, then just triggering the play along that selection with a shortcut, it would be very handy.

Also, one could imagine the ability to choose either if it plays all tracks, or only the selected pattern column.

I might look further into this, once I start to know a little bit more about Lua, I think.

Thanks for all the great help.

Good to hear :) But a bit worrying such a deep level (or at least sounds quite basic system) error is already existing in Win8.

Did you download from the last post, on page2? Or did you download from the old link in post11? I’ve just removed the old one (I forgot to before) but the one in the very last post of the thread I hope should be correct. As my comment says there did seem to be a couple of minor errors that had somehow made their way in although I thought I had tested it all fine before taking it home the last time (I think I might occasionally confuse myself by test installing and then ending up with two versions in the Tools folder, one in my “My_Tools” folder.)

There are two ways you can make a loop.

Loop Selection will read the first and end line of whatever you have selected in the Pattern Editor and set a Block_Loop-esq of this range. Due to the way the looping works in the API this loop only exists within the pattern from which you set it, unlike the native Block Loop. This could be advanced by using PlayPos, rather than EditPos to get which Pattern and then having a Notifier set to update this if you were to manually change which Pattern is playing somehow. Afraid it hasn’t been my plan to advance it to that point though…

Set Loop Start and Set Loop End will set the start or end point. Again they are Pattern (or rather Sequence Position) specific. The idea was to try and give the Transition Looping the thread was initially about but unfortunately, if you do span across more than a single pattern, you always get a slight glitch/repetition on the first line of the loop repeat. Responses in that thread lead me to believe that this can not be helped with the program as it currently stands.

This to me very strongly points to you redownloading the old version. I added a +1 in the Clear function of the newly edited one. Basically Renoise seems to set the loop limits to be 1:1 - FinalSequence:NoOfLines+1 to loop everything but have it all displayed as clear. I wish they had used 0:0 (and this does work in some cases but I found not all so had to change it.)

I hope that makes some sense…

That’s clearer now, Kazakore, thanks for your time.

It was indeed the older version I downloaded.

Also, I was not in “edit mode” while trying it, which may explain that it did not work correctly then.

I did not yet download any other tool, but now i have some basis with this example for digging further into selection concepts with Lua.

Cool to see too that there are plenty of resources for learning.

PS: I point to your post here for the current latest version:

Thanks! This helped me out. :slight_smile: