Problems With Echo Indigo Io Pcmcia Card?

Is anyone using Renoise with this card on a pc laptop with win xp? I can’t the asio driver to work. The program runs but there is no audio coming out. Every other app works fine (NI, Reason, Ableton, Cubase) I’ve got the latest driver but can’t seem to find any way around this…

Thanks for any advice,


Hey thanks for the reply. There is no message appearing at all. If I try loading the ASIO4ALL driver instead of the Echo WDM one Renoise comes back with an error saying the driver is already in use (MS GS Wavetable SW Synth active?) Then a message appears at the bottom, “No Asio Driver Error.”


According to Ableton this had something to do with the output of the MS wavetable SW synth (not sure on the details right now) but after disabling it’s midi output in the Live prefs. I was able to get it working. I also had a problem with energyXT but after doing the same it seemed to work. I can’t find any options in Renoise to disable the MS synth though… and this might all be wrong, I can’t be sure.


That’s it I know it. We have to able to disable the MIDI output from the MS GS Wavetable Synth. Then the card will work. I just re-created the process in EnergyXT and it followed exactly what Renoise is doing. When I disabled the output from the MIDI the card works fine. Question is how is this done??? I don’t see any MIDI Output options in the Configs menu.


I got it. Or at least a work-around for now. The GS wavetable defaults it’s output to the indigo’s virtual 1-2 outputs. Go to the “Sound and Audio Devices” control panel and click on the “Audio” tab. From the device output field select the “indigo io 3-4 Virtual Out”. Now in Renoise select your echo/asio drivers and there you go, music.


Let us know if this card is ok to use with Renoise. I’ve had my eye on that card for a while and I’m looking for user experiences. More of interest if it does work for you how far can you push the latency back using the card with asio4all?

This is wonderful news, if it’s true. I’ll try it on my Indigo tomorrow, will report back.

It works, fantastic. Thanks a lot.

Curious, though. My CPU gauge is at 100% all the time.

It has been a couple of months and I was wondering how the card behaves now under 1.5. Still 100% cpu usage?

I know this topic is really old, but I wanted to add that I’ve just got an Echo Indigo IO and the workaround (ie changing virtual outputs to 3/4) works perfectly…

damn! i had not seen this until today, i have a feeling i now know why i could not seem to get renoise to run very well on my thinkpad! might just have to pull it out of hiding, def have to see if they updated the driver!

looks like they have only updated the osx driver. (too bad no pcmcia slot on ibooks)

curious tho, i was able to get pretty nice latency with this card on my thinkpad (under debian linux), it looks like there could be even better latency with osx.
i wish i had a 15"powerbook!

I just purchased the indigo io and im not having any luck using it with my audio programs. My computer (powerbook g4) routes sound thru the card when i play something in itunes or quicktime but sound just come out of my laptop speakers if i open Ableton Live or Renoise. Any ideas? Sorry if there is an obvious solution…im completely new to this external soundcard thing. Thanks!

In renoise go to: “edit -> preferences -> audio” then select asio, and for device ASIO echo PCI (at least that’s what it says in my preferences). Make sure you have the latest drivers installed, and you may need to change the latency settings to improve playback.

I have ASUS laptop (3.2ghz 1gb ram) and ECHO indigo io pcmcia.
Bought RENOISE license couple of days ago.
Everything is stable and fine.

p.s. Thanks to RNS team for the tracker of my dream =)

Echo I/O is an OK card, but its build quality is terrible.

Be very careful or you will crack the plastic shell.

Also, the volume wheel starts crackling very quickly.

Hmm…dunno, my works fine. No crackles and stuff.

I usually make music in a sauna, so that might have something to do with it.

works great now! thanks for the suggestions.

suomi sauna =)

Thanks a bunch for figuring this out…