Render plugin to samples doesnt preserve quality...

I´ve never used this feature a lot, but i have to work on very weak computer now and modern plugins like Diva or Dune2 take a lot of cpu, so i thought that this feature can be solution. But when i use it, that rendered instrument doesnt sound good. Lets say it sounds 50% worse (i can make some examples when i get home) biggrin.gif/> .
When i insert a note of vsti and render it classic way it sounds same (nearly same) as from vsti.
When i use render plugin to instrument, it doesnt sound same, it sounds bad. It is good just for very basic sounds imho. Any complicated sound, mainly textures sounds lets say 2d, not 3d like original biggrin.gif/>

For now i have much better resault with inserting and rendering individual notes from vsti, but it is borring workaround…

Very apt description of the problem, I guess. Because when you render a complex sound, it might have sounded different on each keystroke, but the rendered version only has a single sample for any given velocity/pitch. So, it is essentially a 2d represention :slight_smile:

There are a number of things you can do to improve the result. I would suggest rendering the sound not once, but twice or maybe even three times, as each render should result in slight variations in the sound (assuming that the plugin has internal modulation that produce these variations…)
Then you can use a tool like the xrni-merger to combine those renderings into a single instrument, and enable the overlap/round-robin feature in the keyzones to make the instrument become more alive.

I am sorry. Because i wasnt deep it sounds that i dont know about things you mentioned. But i do and there is not the problem.
There is scenario:
a) I insert Diva, i insert c4 at full velocity and make it 4lines long. Then i render it. This render sounds same as playback of original vsti.
b ) I insert Diva i make “render plugin as an instrument”, select 4lines for lenght of sample, select full velocity and render it. When i later insert c4 it sounds much worse than in scenario a). But it should sound same (besides the changes in internal modulation of plugin) as i understand it.

Modulation inside the vsti should resault more in different sound than bad sound. I assume i should make same examples. I “hope” that things will go as i say and i am not doing fool of myself here :-).

Btw. xrni-merger is dope i know… But i had some weird failures with it when i was experiment so i wait for a updated version.

Can you please upload a simple demo XRNS song using Diva that we can test?

The song should include:

  • An instance of Diva VSTi with the exact preset you’re using.
  • A test pattern which plays the C-4 note.
  • A sample of the rendered note, so we can hear the correct/good result.
  • A sample from the plugin grabber, so we can hear the incorrect/bad result.

Please also mention which exact audio settings you’re using, such as your sample rate and so on.

To be honest, i dont use Diva, it was just example (but i use demo of dune2 that i wanna render out :yeah:).
But I can use any synth where i create complex patch. I will choose free one and demo of Dune2 also if you are ok with it. And i will do it today or tomorrow.

I am very happy that i didnt get answer: “We know about it, Renoise plugin gabber cant take quality of new plugins.” and it can be somehow solved ;).

If you already have Diva installed and you can recreate the problem using that plugin, then it would be great to get an example song which uses Diva.

I simply do not have Dune 2 installed. I could install the demo for testing, but I would prefer to avoid that if possible.

Else, maybe another user has Dune 2 and can fully test it.

I would recommend you download it and try it. It is number one synth for me, i love its sound, mainly its reverb and filters.
But i will download Diva, make some tests, upload it and we will see. Thank you.

Everything is fine, what the hell.
i am sure ive experienced this with my old computer and external soundcard, maybe i was just doing some mistake.
Sorry for panic, topic can be deleted.
Ive tested Diva (texture), OBXD (pad), and Syntmaster CM (sequence), every passed.

Did you changed parameters like polyphonic and maximum note counts? did you ran plugins sandboxed?
There must have been some setting that caused the experience.

Because it worked so well today i will use it much more now. If the bug will apear again i will write it here.
Maybe it was sandboxing, we will see. Or just my head :-).
Changing name of topic for now.

Just had this exact issue with Edirol’s Orchestral and Super Quartet VSTs (other plugins rendered fine). The sounds that were rendered appeared to be the raw samples from the VST but without any of the plugin’s effects or processing applied to it.

Here’s the weird thing: this happened yesterday, but I can’t recreate the issue today. It’s all working fine now.