Renoise 1.8.0 Under Wine

has anybody tried running Renoise 1.8.0 under Wine?

I’ve tried on Ubuntu 6.10 using Wine 0.9.32

the installation is performed succesfully, then while Renoise is starting, it gives some kind of error in a dialog with “OK” button, but I cannot read it since Renoise splashscreen goes over it and cannot be moved :)

a friend of mine who also tried to perform this task told me that he is having an error regarding Renoise being unable to find a cursor (.cur) file.

Does anyone have a solution about this?

…and please do not blame me for trying to run Renoise under Wine… there is a reason for this :)

the stupid me has managed to move the window (ALT+drag :rolleyes:)

yes, it is a missing .cur error:

Interesting to know if renoise will work under wine.

White or red wine? I’ve tried with red wine, and that works just fine! :P

hmm, i fuzzily remember wine having a directory structure similar to windows so that windows programs can access the familiar surroundings.
atm the only thing i can think of is: have you checked the permissions of the cursor file? maybe some reason wine doesnt have the right permission.
you may need some graphics libs too.

Some months ago I tried getting the Reason-demo to work in Wine and I think ‘choice’ is right about the permissions - I had to start the program with “sudo” as prefix for the program to get its permissions.

the cursor file is on an installation subfolder, anyway I tried to chmod-777 it with no luck.

looks like something similar to this old thread.

sudo didn’t help indeed

You mean, it didn’t helped either :)

i’ve got ubuntu running on my computer at work. i want to get in on figuring this out. if this can get tweaked into a semi working state, i won’t have to buy another mac to avoid windoze.

I installed ubuntu 6.10 about 2 weeks ago. pain free. But I’m a total linux n00b though

I’d like to see Renoise running though wine in Ubuntu.

let’s us know if you can figure this one out.

That was the worst joke I have read in years. And you edited it too! What was it like before!?



IT-Alien: I’ll give it a shot installing Renoise on Ubuntu 6.10 this evening and see if I can get it running any further, but I’ll probably hit the same barrier. :)

Well, I came as far as It-Alien did. Same Ubuntu, Renoise and Wine-version. “Failed to load resource file: ‘Cursor_Default.cur’! Please reinstall the application.”

I remember that I tried some old Renoise versions (1.1? 1.2? don´t know anymore) on SUSE Linux with wine and got the same error message, but logged in as normal user. It was running though with root access there and then everything nearly worked… except the keyboard duh

Guess I´ll try to give it a shot too with 1.8 these days :)

What you can try, for as far as i know is that Linux boots in a default runlevel set in a config file called RC or something.
You should set the init level from 5 to 3 so that only console mode loads.
In console you log on as root (this can only be done on the machine itself and not remote, not even by using su or sudo) and from that position you either startup initlevel 5 or you just boot xwindows, however xwindows may be dependant upon too many required background services that need to run prior to booting xwindows so it may not work in that case.
But if it works, Xwindows will run in full root mode in that particular situation.

But this is just from the back of my head, ofcourse if you google for this you get loads of information that will help you. I just point out a possible direction.

If you log into your X window system (thats the graphical login) as ROOT this will run everything as root. Runlevel 5 is the GUI, if you run RedHat and maybe SuSe. If you run Debian or Ubuntu, you are at runlevel 2. The runlevel your are at really should not have anything to do with whether you have root permissions in your X window session. But again, you may have to log in as root. On Ubuntu, they have made this a royal pain in the ass to do because, well, logging in as root is extremely dangerous. If you asked why, then that is your answer.

So if you are able to finally log in as root, be extremely careful, as root has omni-power. This means when you type “rm -f /” as root your entire filesystem will be gone, and your system totally f****ed, so be careful.

That is all

That is true, but logging into Xwindows with root seems impossible whereas in console this seems to be no problem unless you have to log on as user in console and SU(DO) to root there as well.
But indeed you’re better off giving a certain user more rights on different folders of the system and then install applications using that user account.

No joke is bad enough to make it even worse.

i don’t see why you can’t log in to X as root. I do it all the time. you just have to enable root logins in GDM (or whatever login manager you choose) which runs as root as well. Also, I don’t see why you can just do an sudo install and get the same effect as running your session as root. if you’re genuinely suspicious that sudo is lying to you about your privileges, run ‘sudo su’ and you’ll be root for sure. if you don’t believe me try running ‘rm -f /’ :P you’ll no doubt get a bunch of “Permission Denied” Messages as Linux tries to delete various file handles for hardware devices, your computer will stop working properly and, probably won’t boot linux again after you reboot to try to fix the problem.