Renoise 3.2 not plugin friendly?

I looked at this thread and this solution did not help me. I did have a bug report page come up too, but since that was after following the instructions on that thread I was not sure if it was worth your time.

A lot of my plugins just don’t work, I’m on windows 10 64 bit Pro-N with media updates installed… Renosie 3.1 works fine with all the plugins. I suspect the issue is that the plugins are 32 bit.

I mean my old version of Glitch doesn’t work… the 1.3 baby (you know aht I’m talking about) yet Glitch 2 works fine… Please help as I love the look of 3.2 but I can’t take the leap this way. Thanks

1 Like

Renoise is extremely plugin friendly. Actually too many friends here. Regarding 32bit in 64bit host, you should forget about that and move on, e.g. installing the 64bit version or replacing the 32bit plugin.

1 Like

I’m not sure if I was clear. Renoise 3.1 was fine with the plugins (and is) - I’m just wondering if I can apply a fix or notify the renoise team that their software isnt bridging correctly for some reason on my machine with the recent update.

I did not want people to think it was a repeated error and that I hadn’t done my research. Heaven knows someone has probably asked the uquestion better but I’m a dedicated renosie user and expreriencing a problem. I get the advantages of a fullt 64 bit but i like to go to some of my classics for comfort and ultimately, I shouldnt be forced to, so… help please :slight_smile:

Doesn’t matter. 32bit is considered outdated. Do you really want Taktik to fiddle around with the ultra complex, yet outdated 32-64 bit bridge? Since almost all other DAWs already abandoned it. macos does not support 32 bit anymore. Windows once will follow.

Or is it more easy for all, if you would replace this preset with another plugin, or maybe even use Glitch 2 then? Or simply use Renoise 3.1 for your classic songs then?

The main change of Renoise 3.2.0 / 3.2.1 is the GUI scaling. This influences the complements.

64bit plugins

If you have 64bit add-ons, they should all work without problems. If you have any problems with 64bit add-ons, it will surely be due to automatic scaling. You should only disable scaling in the properties of the plugin ([?] Button).

32bit plugins

Renoise 3.2.0 / 3.2.1 experiences performance problems when loading 32bit plugins. Any additional window display while using the 32-bit window of any plugin will cause considerable delays in the Renoise GUI (pattern editor, main menu). This is a known issue between Renoise and Windows 10, and supposedly, it is waiting for some solution.
But all of the above does not imply that you cannot load 32bit plugins. If so, be sure to name the operating system and the names and versions of the 32bit plugins. Maybe someone can help you.

It is tragic to abandon some 32bit plugins. But serious programmers must focus on 64bit and abandon 32bit development at once.

Renoise 3.2 is like a transition version. It is desirable that any 32bit development disappear in the not too distant future, and all software programmers focus only on 64bit and move on.

However, despite all this, Renoise 3.2 still supports 32bit plugins. I should do it correctly, yet. But it does not, supposedly because of the operating system. I know the situation in Windows 10. For Mac I don’t know what problems there are.

1 Like

I feel like you don’t understand how much I value using dated equipment. Yeah, I own Glitch 2 (doesn’t every renoise user? :wink: ) but you are missing the point. I want everything to work. I get that something is up, i want to fix it, sheesh whats eith the evangelical 64 bit brigade? Are you going to bring VST3 in too? Yeah i know other DAW’s have abandoned it, but then their users got jbridge, you know what i mean? Sometimes. its important to value why we work the way we do. Presently i work with multiple DAWs and truthfully I want to be only in Renoise. For that to happen… i need everything to work. Yes as it stands, I’ll just go back to the older version when working on older stuff, but im mid project and it would have been great to have this working.

I am just describing reality and a way for you to handle this with the minimal effort. You still can decide to deny it and hope for Taktik to fix your problem.

EDIT: Can’t Glitch 2 import Glitch 1 presets? If so, load up 3.11 with Glitch 1, export the preset, then load the song into 3.2 and so on…

Thanks for your answer. This is more like it… Yeah, loosks like my hands are tied. I use some basic 32 bit plugins for some of simple DSP chaining that i do, it hurts that I can’t use my old CamelAudio plugins, remember those guys? haha - anyway. Thanks. If a fix appears though… let me know, I mean it was weird that even jbridge wasn’t visible, as ive had to do that for another DAW i work in.

1 Like

Well, I am a dedicated user… and it is a genuine problem. Why wouldn’t i want this Taktik to solve my problem? how i get this fellow’s attention lmao?

1 Like

I did not actually know that, but the problem is more extensive than that. Like, I tested a super old-vocoder i have a love affair with… not working haha ;/

1 Like

The most simplelest is really to kkep an old machine (I do this too) for only using the older 32Bit plug in & move on ith the newer stuff. Old Laptops like Tinkpads are very cheapp & runs the older Renoise version perfektly fine!! Just my private Tip.

I don’t own Glitch 1 or 2. For what it is worth (maybe nothing) I quickly downloaded Glitch 1.3.05 32-bit and it seems to initialize the GUI here with 64-bit Renoise 3.2.1.

1 Like

I just retested to be sure… Mine definitely does not work. Reinstall did nothing either.

When you say ‘does not work’, do you mean that it crashes Renoise, or something else? Maybe posting the Renoise log file might help(?)

What I would start to do (for a bit more elimination) is to make sure I get Renoise in a position where it can only see say the Glitch 1.3 plugin (no other vst plugins are scanned or are available) and see if I can initialize that.

I’m running Renoise 3.2.1 here on Windows 10 Home edition (fully up to date, blah blah blah).

I can tell you that Glitch 1.3.05 is working just fine for me as a bridged 32-bit -> 64-bit plugin within Renoise.

Renoise32Glitch13

As @4tey said, it would be great to know exactly what doesn’t work here for you, and what exactly happens when you try to use it.

I cannot fix anything with the old Glitch 1.3, but maybe your feedback will help to reveal some other potential issue(s).

Speaking personally, I’m still predominantly using a bunch of classic old 32-bit VSTs that I simply cannot live without. They are all still working just fine for me in the latest stable build of Renoise, though obviously being bridged (which is less than ideal, but that’s life…)

Edit: A potential tip I can offer… If you have your VSTs installed in the usual default Steinberg folder within C:\Program Files, then try making a custom folder such as C:\VST, and then move Glitch (and other legacy plugs) into that folder instead. That may help with certain security/permissions problems with older plugins.

1 Like

Heyhey,

I did printscreen them, but in honesty I dont have a convenient way to upload an image - do people use Google Drive for that?

Anyway, to save wasting time, I have two vst folders, one for 32 bit, one for 64, both in my main drive folder the same as my OS. I get two popups regarding this issue.

1: Upon trying to open the plugin: An alert (Renoise with an exclamaton mark) with text:

Failed to initialize the plugin ‘VST: dblue: Glitch 1.3’ (for example)

2: Upon opening a file with aforementioned plugins in DSP chains: A ‘Missing Plugins’ alert.

The following plugins could not be found or failed to open

Track 01 (Kick) ‘VST: Camel Audio: Camelphat 3’
… I feel like adding more of these is lenghy and needless, I hope i have provided enough information


I feel like the bridge isn’t working somehow, but I don’t have the necessary skills to fix it on my own.
When you say that its bridged, just to make sure: this is an automatic feature of Renoise isn’t it? I have used jbridge in the past and do as mentioned above, but Renoise has never needed it. I really feel like this is a genuine problem that needs solving. I dont really want to have to have all of my kit suddenly 64 but, I’m pleased you sympathise. When this is fixed maybe you can recommend a few :wink:

In all seriousness, I’ll happily make whatever enquiries necessary if anyone has any further ideas.

Thanks for getting involved.

Also, do you think there would be any compromising elements to having both installed? in honesty, that was not deliberate, but usually Renoise updates, the sheer fact of the matter is that the older version remained and hence I was able to verify that the previous version does not have the problem. but might it be causing it?

If anyone has ideas, my gratefulness is eternal.

I assume that 64-bit plugins work?

Just my two cents. Two files that could be posted here. The Renoise log file. That is probably located in Windows at:

c:\Users\xxxx\AppData\Roaming\Renoise\V3.2.1\Log.txt

Second file, the Renoise plugin server file located probably at:

c:\Users\xxxx\AppData\Roaming\Renoise Plugin Server\V3.2.1\Log.txt

Those files may or may not contain any real helpful info, but it is worth posting nevertheless. If you don’t want to post those files publicly here, then maybe @taktik or @dblue would accept them from a personal message.

Now I’m going to tell you what I’d do (I’m not saying you should or that this will work.) Remember when you said that you reinstalled Renoise? I don’t think just deinstalling Renoise will completely remove those files in those directories that I’ve just pointed to you above. I’d uninstall Renoise and delete those directories. Of course any configuration you’ve made in Renoise 3.2.1 will disappear as well. Then reinstall Renoise. At this point you should have a fairly clean install of Renoise 3.2.1.

What I’d do here is make a seperate directory and copy the Glitch 1.3 VST dll to that directory and point Renoise to that new directory to force Renoise to only see the 32-bit Glitch plugin (so I know Renoise is only dealing with the one 32-bit plugin.) Point Renoise to that new directory and rescan. In Renoise try and load 32-bit Glitch 1.3.

Either it works or you get ‘Failed to initialize the plugin’.

Now if it is the latter, you can appreciate at this point Dalvidos how difficult it would be to fix that problem over a forum, but at least you’ve gone a bit further to eliminate as many vst plugins as possible that can maybe cause confusion.

1 Like

Cool, yeah I’ll do it right now. I know my settings like the back of my hand, it won’t take me long. I’ll just note down all my addons. Be with you soon as.

Potential humble pie here. closer to the solution but no cigar just yet.

I did as you requested. Full uninstall full reinstall. Paradoxically my tools just remained, perhaps they are saves elsewhere. So…

I created a new folder… caled TEST in the main folder of my directory. Then I pointed Renoise to the single folder and nothing else… Camelspace (which was all i put in there… worked) - I then redirected renoise back the folders that worked in 3.1 but not in 3.2… back to the same problem. Sugarbytes WOW2 is also not working, but this is definite progress. I’ll try continous testing of plugins this way… But surely that gives an indication of the problem?

There is no reason why one folder would be different to the other, I mean they are literally in the same location (main c drive folder)