Renoise not rendering song properly

I noticed Renoise won’t render the last 56 seconds or so of a song I’m working on. It just stops abruptly. I can’t find any reason why it shouldn’t. The only thing that’s different about this song is I’m using an LFO to modulate the LPB.

That’s pretty weird.

What version of Renoise? System Spec?

Is this a file you can share?

TBH,

You probably have some sort of automation you created or pattern command you entered, or other human error…

But give us your system spec, and if you can upload the project… if you are using vst’s, just render them all to instruments. and let us take a look

well, I’ve been mulling it over, and the only explanation I can come up with is that since I’m modulating the LPB with an LFO and also using ZL commands, I’m asking Renoise to basically run two tempos at once and it’s “confusing” it. When I removed the LFO on the LPB it rendered the whole song. So, hmmmph. :face_with_raised_eyebrow:

Does it sound fine when played in Renoise? What VST are you using?

I have another problem with render where currently the Spire plugin won’t render the first note properly, but the song plays fine which is a little weird.

I have contacted Spire developers weeks ago, still no reply.

Renoise have “Realtime” and “Offline” render modes, did you try both?

I’ve tried both, same problem with my issue.

@moodorf,
I have tried re-creating the issue but have not succeeded.
Could you possibly create a small ‘empty’ project that produces the same issue and share it (likely you will only need to copy the pattern commands and effect chain to an empty project file)?

This will be the problem in your case. Renoise checks/calculates the song’s length before rendering. The LFO is changing the length and thus making it hard to predict to the length. As long as the LFO isn’t set to random this actually even could be predicted, but we never had the chance to implement that.

The only workaround for scenarios like that would be recording the output via an external tool.

Maybe he can make another slightly “convoluted solution” without using an external tool.

  1. Disables the LFO on the last pattern written with a parameter.
  2. Add more patterns, which are more than 1 minute long.
  3. Use a tool like SamRender to render the entire song result in a sample.
  4. Remove the remaining end of silence from the sample.
  5. Save the resulting sample in a WAV or FLAC audio file.

Personally, I haven’t tried these steps, but if the issue is duration, this will probably work.

Wouldn’t it be possible to implement a “fake external tool” to render? I don’t understand how you can play the song in Renoise and not have that rendered out. You’d think the realtime render would do this, no?

Try MRecorder plugin from Melda for that ‘external tool’ workaround.

1 Like

That works, thanks for the tip.

I put ZT (stop song) command on the master track at the end of a song in Renoise and in MRecorder tick “Pause when playback disabled” to make it begin recording on play.

I will use this procedure going forward.

Little feature wish, maybe add a tail option for export? FL have it, which exports till silence: image
Would also help us to avoid empty patterns at the end of a song for reverb tails.

1 Like

Why he cant just add one empty pattern, then cut his audio?

He said 56 seconds isn’t being rendered, that’s a long empty pattern he has to guess the length of.

why u cant cut unsused silence, i mean it is an easy workaround.

edit: for the looping purpose - u still want to render a taril, to u know, add it in the beggining of the loop.

edit: grammar

grammar edit doesnt work anyway :slight_smile:

Renoise patterns LPB from LFO.
Add +extra empty patterns+ for the extra +time+.

so that Renoise can see your song length correctly.
You can see an indication of the time on the right top.