Resynth2 Released

I’ve just uploaded ReSynth2 final version to the tools page.

From the release notes:

Download ReSynth2 here



Had a bug running the randomize for a few times:

Hi, thanks for the bug report.

Fixed for 2.1 (pending approval)

really well done.
but i have issues.

  1. When selecting a wavebank and then a waveform on osc1, if osc1 is in Analog, choosing Waveform does not toggle the oscillator to Wavetable.
  2. After having selected a wavebank + waveform on osc1, and switching from analog to wavetable, the waveform is not loaded - it will only be loaded when you re-select the waveform.

When selecting a waveform for oscillator, switch from analog to wavetable. then load.
when selecting a waveform for oscillator, toggle oscillator-loop-mode=on.

i’m sad to have lost the one-cycle-waveform display mode in sample editor view, but i suppose that just can’t be helped if one is to be able to jam and switch settings without sound cutting.

thanks for the script.

notice the gui is very slow if you’re on the sample keyzone screen due to many large keyzones. this is a renoise issue though and not the script.
anyone know if a bug report has been made about this?

Wonderful tool. Finally a good native synth in Renoise! Resynth2 together with the instrument envelopes and dsp effects you can program really great sounds.
Perhaps an idea to include some wavetables and xrni presets for the next version?

I agree that some demo patches would be great. I’ll see what I can do. Until then try some tutorials (e.g.


Could it be a toggle in the GUI? someone might want to use <512 sample frames without loop. maybe it could be automatically toggled to loop when the sample is of a reasonably small size. Maybe not. Could it be a preferences setting or somesuch? Would that make it too convoluted?

The waveforms are not visible in the GUI (version 2.1) I made an wavebank in the waveforms folder. In this folder I placed several wav samples. When I launch the GUI I can see the wavebank but when I select this bank I can’t see any wav samples in the list. What kind of .wav files are supported?

As an example I used the chimes.wav in the c:\windows\media folder.

cheers, you have swept my wave generator away! :)

Well, samples < 512 frames would be < 5ms at 44.1khz sample rate, so autolooping them would make sense as the majority of the time this is what the user would want.

It lists all files with a ‘.wav’ file extension and uses Renoise built in file support, so any file you can load in the file browser should work.

However, I may have identified a bug: The waveforms list is populated on changing the wavebank, however, if you only have one wavebank it may never get populated. Could you add another folder (even if its empty), select that folder and then reselect the first folder?


When I add a new empty folder and switch between the two banks I am able to select the waveforms!!

So, will this “bug” be fixed for 2.2 or do I always have to add an empty folder?

Good! I have a good idea of what the bug is then.

I’ll fix in 2.2 which I’ll sort when I get back.

When you have selected a waveform it is not possible to deselect the waveform (choose “none”). Also when you use the reset button, so that all parameters are set to the default position, the wavetable data doesn’t reset.

When you want to make a new sound then in Analog mode, the waveform data is still selected.

I think the waveform feature is not working properly in 2.1.

When I select a waveform file (instead of the sine analog sound) in the first oscillator section, I cannot hear a big difference. I hear a sine sound more instead of the waveform I have selected.

When I play the wav file in the sample editor the wav sounds fine. (does not sound like a sine sound)

So it looks like the waveform will not be used even when you’ve selected one.

If you need more info, ask me.

This has already been reported.
When your oscillator is in Analog-mode, and you load a waveform, it is stil in Analog-mode. If you then switch to Wavetable-mode, it is still playing the analog sinewave. You need to re-select the waveform and load it, then it will change.

Mxb, I’ve got a request…

I’m loading extremely long filenames… And the GUI actually resizes itself according to the filename. So suddenly the (fairly pretty) GUI actually resizes quite a bit)

So, in this case, the loading of a large and long filename would be better to display in show_status…

Ok, now I hear the waveform. But I hear BOTH sounds, the sine and the wavetable. How can I disable the sine??

reduce the volume of osc2, osc3 and osc4 to zero and you will only hear osc1.

Ahhhh, stupid me :wacko:

Hope that this will be fixed in 2.2:
“When your oscillator is in Analog-mode, and you load a waveform, it is stil in Analog-mode. If you then switch to Wavetable-mode, it is still playing the analog sinewave. You need to re-select the waveform and load it, then it will change.”