Samples Added With Wrong Pitch

Hello Fellaz!

I started using renoise today. When ever I load a samle or loop it has the wrong pitch. This also happens with the samples that come along with Renoise, so it’s not like presented in the beginners tutorial video.

How can I load and play without having to readjust every single time?

Thanks for any advice and




One more thing. If I preview the samples they play just fine.

i think you need to be a bit more specific. you say that when you load a sample it has the wrong pitch. the only way for you to know that is to play the sample after importing it. the question is, how do you play the sample? my first guess would be that you play it using either a midi-keyboard or your qwerty-keyboard. the logical explanation would be that you play the samples too high on the scale.

try this: load up the sample, go into the sample editor and press Enter. the sample should play at the same pitch as in preview.
to find out what note you are playing: go into the pattern editor, make sure Record is on (press Esc) and type the key you used to play the sample, and which played the sample at the higher pitch. it should input a note. if this note is not C4 (assuming you have not changed the keyboard mapping in the instrument editor), my first guess was right.

(i’m assuming you’re on a Windows PC here - not sure about the shortcut keys on Mac/Linux)

Hi rhowaldt!

Thanks for the quick response on that. I think I found what’s wrong. Within the Instrument Settings the ‘Sync’ option of the sample properties needs to be switched on. After doing that everything works like a charm. :)

That is not necessarily correct. The sync option plays the sample at a pitch to match its timeline to a specific amount of lines in the pattern that will be played. If turning it on works for one of the samples that you tested, that is just a coincedence.
If a sample plays correctly in the prehear option that usually means that you are not striking the C-4 note key on the keyboard. If the Sync option was already turned on but had to be turned off, that would explain your problem more accurately.

that was my initial thought, but i figured he’d try it from a new song, so the sync button would be untouched. so i figured i’d not mention it and wait for the response. thank you for taking the words out of my mouth.

(i do hope that’s the answer though)

I was striking the Z key for playback as shown on the beginners tutorial video. I have been using the samples delivered with Renoise for testing.

Keep in mind the keyboard octave setting found in the transport panel. If this is set to octave 4 then Z will trigger a C-4 note, but if it’s set to octave 5 then Z will trigger a C-5, and so on.

Also take a look at the manual page on playing notes with the computer keyboard.

It is set that way. :)

I have set the ‘selected splits basenote’ to A-5 and now the Z key plays the right pitch… maybe that part that has been left out in the tutorial video. :)

Mmmm, no. If I set it to A5, it plays a A5 note.

sounds like you have to save the xrns-file of an example song and share it with us so we can see what is going on here.

Something rather obvious occurred to me the other night: PostNukeBabe is probably using a non-English keyboard layout where Z is not positioned in the same place.

QWERTY is not the only layout in the world, afterall. And sure enough, after I did some quick research, there is in fact a QWERTZ layout which is quite popular in certain parts of Europe.

And guess what happens with a QWERTZ layout? That’s right… Z plays A-5 instead of C-4 :)




There’s also AZERTY where Z would play a D-5 instead of C-4, and probably a few other weird layouts as well.

Seems like we may need to update some of the tutorials to take this into account, to avoid further confusion.

Dblue is spot on.

And to make this even more confusing, a lot of users in some of these countries (I’m one of them) actually use alternative layouts, where all the local and special characters are there, but the Y and Z are in their proper, “english” places. You can see that in the Windows keyboard settings dialog, with selections like Slovak vs. Slovak(QWERTY), Czech vs. Czech(QWERTY), etc… I would say QWERTZ is mostly being used by “non-techie” people who only work in their local language… because programmers and such, who need to switch between english and local would get major brain hurtage from the Z/Y jumping around :-)))))

i allways use the “Y” for a c-4, but it`s possible to change between german/english keylayout by pressing alt + shift.

Damn I´m impressed :) Mr Sherlock.

Now this would perhaps also be easier to understand if there was some place showing what note you play on the “mainscreen”.
Perhaps the cursor could show what you press even when not recording.

I thought Renoise used simply hardcoded key-scancodes returned by DirectInput… When using scancodes, it doesn’t matter what key is positioned above the H key and it indeed isn’t, but the user sees something totally different.