Slow framerate with HiDPI in fullscreen mode (on a Mac Book Pro 2018)

I have an issue with Renoise 3.2 HiDPI/Retina mode on macOS 10.14.6 on my 2018 MBP 15" (base model):

  • When I use the HiDPI/Retina mode with 200% scaling, the UI scopes updates are slow as if the framerate is at 15fps

  • Alternatively, when I right click on the Renoise.app and check the “Open in low-resolution” checkbox the performance of the scopes is normal (but I can’t use the display scaling anymore)

I hope you can look into this, as I would like to use the display scaling. Let me know if you need additional information.

I have same OS, thus this is 2017 13’ mbpro (the best config at that time) and works just fine…
When you use low resolution - retina HiDPI doesn’t work at all (so i assume scaling neither does), and this opts out 3.2 display improvement :slight_smile:

This! ~on 13’ it would be really useful!

It should be the other way around.

Are only the scopes slow, or everything else in Renoise too?

Especially the scopes, but also the scrolling in the pattern editor are influenced by the audio latency/buffer size as well. The lower the latency, the less buffering happens and thus the faster the GUI updates.

Have you probably set a very very high audio latency by accident?
Or enabled the “Limit Frame Rate” option at https://tutorials.renoise.com/wiki/Preferences#GUI

Hi Taktik,

Thanks for the quick reply. I am sure the Limit Frame Rate was set to 60 FPS in both cases. Latency was the same at 15 ms in both cases too.

I will do some more rigorous testing tonight and report the detailed results back here!

Lech

Hi Taktik,

I found out more about the issue, it seems related to switching to fullscreen while using Renoise 3.2.0 in HiDPI mode on macOS.

  1. When I run Renoise 3.2.0 in windowed mode the track scopes are smooth as expected
  2. However when I change to full screen mode, the track scope have a lower framerate

I made a screencapture video to illustrate the issue here: https://vimeo.com/356925847

I did a clean install of macOS 10.14.6 on my 15" MacBook Pro 2018. I am running the Built-In Retina display at it’s default resolution.

I tested with these Renoise settings:

Audio:
Out device: Apple inc: MacBook Pro Speakers
Latency 15 ms
Realtime Audio 12 CPUs

GUI:
Enable Retina HiDPI support = ON
User interface scaling: Auto
Limit frame rate to: 60 fps

From the Renoise.log file (when I switch to full screen):
GraphPort: Initializing in FullscreenMode
Graphport: Running fullscreen at ‘0,0,3360,2100’…
GraphPort: Successfully initialized

I hope this helps and you can fix the issue!

Can you try “sRGB IEC61966-2.1” color profile for your monitor and check again?

I’m having the same problem. The issue seems to be with the surface area Renoise has to render to: The bigger, the worse the performance. I get the same poor performance in a maximized window as I get if it is full-screen.

I don’t know how Renoise’s UI is rendered, but if it is not using the GPU, that may be the source of the problems as rendering on a 5K display as the iMac 27" I have with a CPU is going to be extremely costly. And it’s not like my iMac is a slouch:

image

What’s weird, though, is that disabling HiDPI mode doesn’t improve the performance (at least not observably). I get the same poor performance regardless of HiDPI mode, it’s only the size of Renoise’s window that affects the performance afaict.

The problem very likely will be the new color-profile handling in newer versions of OSX. See:

So far we haven’t found a way to disable the slow color profile conversions, but are still working on a solution.