[Solved] Asio4all Won't Love My Laptop :(

hey guys, i need a little help with my audio output setup. actualy i think i’m just too blind but i got little trouble with the great allmighty “microsoft GS wavetable” thingy, asio and my a “limited” laptop.

basicly i’m not able to use asio with renoise at all atm, but it’s fine with wavelab. its asio4all and a dell latitude lap, using sigma tel hd wdm drivers.

i was wondering why wavelab runs fine with asio but renoise wont so i found some trouble reports and fixes according to cubase where ppl forced the host tool not to use the great MS GS wavetable. it looks like renoise is starting the wavetable stuff or whatnot and this is what blocks my asio output device; wavelab doesn’t use the midi out at all so thats why i could have got the problem tracked, but who knows. same when winamp plays in background, blocks asio out in wavelab too. yea i wish my laptop got better drivers but it wont. :(


can i disable the ms gs wavetable sw synth midi out device … in renoise? … or in general just kick it somehow? i dont care bout it, its not any use to me at all.

is anybody else affected by this problem?

the log.txt says:

MIDI: Enumerating MIDI devices  
MIDI: Opening Microsoft GS Wavetable SW Synth  

… and then …

ASIO: Initializing  
ASIO: Trying to open 'ASIO4ALL v2'  
ASIO: LoadAsioDriver ... OK  
ASIO: ASIOInit ... OK  
ASIO: Using SampleRate 48000  
ASIO: postOutput = false  
ASIO: FillDriverInfo ... OK  
ASIO: InputBuffers: 2, InputChannels: 2  
ASIO: OutputBuffers: 2, OutputChannels: 2  
ASIO: BufferType : 0  
ASIO: OutputLatency: 256, InputLatency: 256  
ASIO: CreateBuffers ... OK  
ASIO: ASIOStart ... OK  
ASIO: Up and running  

no sound at all then again cos the device is “in use”

when i quit renoise it says :

ASIO: Stop Polling...  
ASIO: Releasing ASIO4ALL v2...  
MIDI: Closing Microsoft GS Wavetable SW Synth  

hmm. i ve an ibm t60 here, with asio4all (intel hda).
energyxt, ableton demo, audacity, etc. works fine.
but all of a sudden my output is unavailable in renoise … i see the meters kickin but no sound.
ive re- installed everything (plus registry-cleaning) but no success.
i think its the asio4all driver… but than again it occurs only in renoise.
just out of interest, do you ve something like " kasio reset request " in your log?

<?xml version="1.0"?>  
<ignoredmididevices version="1"><br>
	<ignoredoutdevice>Microsoft GS Wavetable Synth</ignoredoutdevice><br>

Save this next to Renoises Config.xml and Renoise wont touch (see or open) the Microsoft GS Wavetable SW Synth anymore.

The next release will have a bit more elegant solution for this.

w00t cheers taktik, thats exactly what i was looking for. gonna check it later though. … nope not any kasio entry in my log, engine.

but you seem to have the same problem. thing is, renoise lauches the wavetable before asio. in case your asio/soundhardware setup doesn’t support multi-out stuff whatever the output is blocked by the wavetable by the time renoise still booting.

anyway, no one uses this wavetable so its no need to change the init. order.

whats the filename? … any.xml didnt work :P

thanks basil & taktik!

but unfortunatly the ‘Microsoft GS Wavetable Synth’ still appears.
when i add the code in config.xml renoise gets an error and its reseting the config.xml
and when i delete the first line [<?xml version="1.0"?>] i can add it but it gets deleted as soon as renoise is shutting down.

edit: sorry, i should have stated that my second attempt was the creation of a new xml- file (IgnoredMidiDevices) but the ms gs wavetable synth is still there.
btw: i also tried old asio4all versions but the same…

ya same here.

“IgnoredMidiDevices.xml” it is…

hrm … still reading wavetable. … i just installed the latest backstage version. :panic:


arf, me stupid. it works! … its “Microsoft GS Wavetable SW Synth” not “Microsoft GS Wavetable Synth” on my system. cheers!

now asio works as well. me happy! :yeah:

Good to know. On Vista (which I currently have to use) its “Microsoft GS Wavetable Synth”. No longer a software in vista it seems ;)

hell no! its rendered through the 3D pipe native! lol … yes, winXP mine.

ive deleted config.xml and checked the spelling of the wavetable synth (obviously you re right basil). :rolleyes:
thats it.
my output is available again. yay!
thank you all for the quick help. ^_^

what do you mean by: “rendered through the 3D pipe native” ?

If it does support a callback based streaming and one can setup things like the latency/buffersize/samplerate, this would indeed be a nice alternative to ASIO. Thanks for the tip, I will try to find that out…

it was ment to be a joke, engine :P … bad one, ok ok ;)

Hi, I installed ASIO4All so that I can use my onboard sound, and all I get is a silent output, and the ASIO4All contol panel says:

Status: Unavailable!
-> In use by another application?
-> ‘MS GS Wavetable Synth’ enabled?”

What was the new solution you said you were adding, Taktik? I want to completely disable MS GS Wavetable Synth, as I’ll never need it. Many thanks.

(You wrote “The next release will have a bit more elegant solution for this.” and that was five years ago, so I presume you’ve fixed it by now!)

I believe if you want to use your onboard soundcard, Dr. Drum will suffice.
Or simply get a decent soundcard.
The onboard stuff are just cheap solutions to get you at least something. If you want to do serious music stuff on a computer, get decent hardware.
Renoise is kept affordable so that you can spend your dope on real gear. Now sush!

I don’t think it matters what hardware I’m using, if all my songs are generated using VSTs and samples, and mixed direct to .wav by Renoise?
My onboard sound is perfectly good, no background noise at normal listening levels. I really want to get ASIO4All working, can Taktik help? I know the previous solution involved creating an .xml file, but the config file doesn’t exist any more (unless I’ve missed it).

Did you tried this solution at least or do you still need this solution to solve it?
and the filename:

If that is so, i have not said anything.
If that solution isn’t working either, then you need to address the problem to the ASIO4all development.

Asio4all is working in Renoise… I can confirm that. I was stuck using asio4all when my budget was really bad in 2011, and I just needed a cheap card for my new windows machine, and new studio monitors. I had to go with the art usb… YUCK!!!

Anyways… Here is the manual http://artproaudio.com/files/owners_manuals/om_usbmix.pdf

Hopefully that helps… obviously what is not right here, are the control panel settings… if you read the art usb manual, you may be able to tweak your windows settings, and get asio4all to work.

IMHO… vV is correct. You must use a proper card. There is just not substitute… Things have really changed for me, performance wise - since I bought my Komplete Audio 6. Before 2011, I was actually using mac… back in 07, 08, 09, and 10… so I was using core audio…

With asio… I guess you need to have, “a proper driver.” I do not think asio4all is a good driver. The difference between NI Asio, and Asio4all is too apparent… imho.

I couldn’t use that solution, because I could only find a config.xml for the fonts, in the \skin\fonts folder. I presumed it had been got rid of since 2007?

It’s not the ASIO4All control panel settings, it’s Renoise, because Renoise uses the GS Wavetable Synth.
Sometimes ASIO4All works fine in Renoise for me, sometimes it doesn’t, and when it doesn’t, it’s because of the reason I explained in my first post, the GS Wavetable Synth is somehow running.

I don’t know why you are both saying I “need a proper card” - how can anything like that change my music making ability? I have ASIO4All working at 2.7ms and I didn’t even try to achieve that, I just adjusted the sample slider thingy in the control panel and it happened to show it was that low in Renoise, so I left it there, and when it works, it works perfectly. This is a software problem, no need for me to buy a soundcard that I don’t need, is there.