[Solved] Keyboard not working on 3.0


Got back to my “home office” from long vacation and installed Renoise 3.0. Now I cant get my keyboard working. Keyboard shortcuts doesn’t work nor navigating on the GUI. Keyboard worked fine on 3.0 beta versions and 2.8 version. I have already tried to install it few times and now keyboard doesn’t work even on the 2.8 version.

I’m using Windows 8.1 and haven’t installed nothing new to my computer.

Have anyone got clue what’s going on.

EDIT: Comodo was the culprit. Comodo HIPS (Host Intrusion Protection System) didn’t grant permissions to use the keyboard. Fix was running Renoise as administrator and give it full permissions when Comodo asked what to do with it.

There seems to be normal shortcuts available. I cant even edit the shortcuts because renoise doesn’t respond to keyboard presses.
I just made a few scans with different security tools and found nothing suspicious. Hijack this scan shows nothing abnormal.

Thanks!. Found the culprit. Comodo was blocking access to keyboard.