[Solved] Out Of Memory Errors

Hello

This happens very very often in last 2-3 days.

I have XP SP3 with 3GB of ram and latest Renoise 2.6

I also have this 2 messages appearing one after another:

==========================================
Document validation failed with the error:
Failed to parse the XML document. (Out of Memory! Please try to free up some memory and try again.)!

Failed to validate the document ‘F:\music\Renoise\testfile.rns’.
It’s recommended that you try saving the document again under a new name.

After clicking OK - song file seems to be saved [~10MB here] but I am scared to play with - what if song won`t open once?

I tried, I removed all 4 instances of Edirol Orchestra and I can save normally.

CTRL + ALT + DEL opens taskmanager where I see 2.14GB usage and I remember I was able [long time ago] to load song up to 3, even more GB file…?

Like said, I have 3GB of ram and after clean reboot I have ~400 mb memoru in use in WindowsXP, then opening song it takes 2.03 GB of mem. So I should have ~800 MB free, almost 1GB for samples and everything. But after saving, it looks like it saves everything but this message appears :(

Any idea?

  1. saving songs takes additional memory so, if you are running out of free memory, there could not be enough to allow saving

  2. Windows XP 32 bit cannot use more than 2GB of memory for each application, unless you set the /3GB option in Windows’ boot.ini file.

  3. see a recent similar discussion

  4. 400MB for XP startup is quite a lot: you should try disabling useless services (such as indexing, for example). When I was using XP myself, it started using about 180MB

Thank you! I should try with 3GB switch…

Here is some scary moments [to me] for possibility Windows not to boot… I will do it and have XP SP3, but there is mentioned a problem about XP SP1:

Boot.ini file /3GB switch example

This is what your default boot.ini file before you make the change might look like. The timeout and partition and other parameters depend on your setup. Pay attention to the line with the /fastdetect.

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Windows Server 2003, Enterprise” /fastdetect

And, below you can find what the boot.ini file should look like after making the change.

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Windows Server 2003, Enterprise” /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Windows Server 2003, Enterprise with /3GB” /3GB /fastdetect

Make sure you do not enter a typo in this file as it might result in being unable to start your computer.

Do I need to reboot the server after adding the /3GB switch?

Yes, the /3GB switch entered in the system’s boot.ini file and takes effect after a restart.
Which operating systems support the 3GB switch?

The /3GB switch applies to 32-bit systems only. The following is a list of operating systems that support the 3GB switch:

Windows Server 2003 Standard Edition
Windows Server 2003 Enterprise Edition
Windows Server 2003 Datacenter Edition
Windows 2000 Advanced Server
Windows 2000 Datacenter Server

This is a list of officially supported operating systems that can handle the 3GB switch. Other systems may or may not handle it well depending on the hardware and software configuration.

Can I use the /3GB switch on Windows XP?

Adding the 3GB switch to the boot.ini file in Windows XP SP1 can cause Windows not to start.

A supported fix is available from Microsoft, but it is only intended to correct the problem resulting from this specific setup. The solution to this problem is upgrade to the latest service pack. You can read more about this problem on the following Microsoft page:

Windows XP SP1 May Not Start with the /3GB or /USERVA Switch
http://support.microsoft.com/default.aspx?scid=kb;en-us;328269

Important warning

Any time you make a change to the boot.ini file, make sure that you have all your data backed up!

My BootIni on my XP SP3 is looking like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect

So I guess if I add 3GBswitch, it should look like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional with /3GB” /3GB /fastdetect

Am I right? I am scared to save and reboot… All my work can go bye bye… :S

Ok here is what I did and for now it seems I don`t have memory problems on WinXp SP3:

  • This was my BootIni file:

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect

Then I added “/3GB” switch so line will look like this:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional /3GB” /noexecute=optin /fastdetect /3GB

And finally my boot.ini will look like this:

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional /3GB” /noexecute=optin /fastdetect /3GB
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect

I set up default opening of WinXP to be with /3GB switch because I cant choose between WinXP and WinXP with /3GB switch. Cursor just dont move during booting countdown and I believe it is because I use USB keyboard.

So - procedure to stop memory leak in Renoise and use all 3GB per application would be like this:

  • Rightclick on MyComputer icon
  • Go to Advanced TAB, then start Settings button in Startup and Recovery
  • Then go to EDIT button and boot.ini will open in text editor as textual file.

In my case [I have WindowsXP SP3]

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect

Then I added COPY of bottom line to memory [Copy] and
[PASTE] it above with /3GB switch added to the word’s ends, twice, so final boot.ini file will look like this:

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional /3GB” /noexecute=optin /fastdetect /3GB
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect

Save, close all opened windows and Reboot. And after that, you will have no memory leak! Renoise will work like it addresses 3GB of memory [instead default’s - two. You will have one more gigabyte to load samples!!!

Thanks a lot, especially ITAlien to help me try this!

p.s. if you type any letter wrong, it is written that Windows wont boot anymore! So be sure that you dont make any errors or blindly copy this boot.ini from my file to yours!

Just simply copy the original first line to another one and you should be fine:
“multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“Microsoft Windows XP Professional” /noexecute=optin /fastdetect”
Perhaps raise the timeout if it is too short.
But if the original line stays in, you get too choices to start from: The Windows XP profressional and your alternative version. If that one doesn’t boot, you can always pick the original one and then retry from there.
Then there is also safe mode when pressin F8 during disk-boot time, to force Windows to start in safe mode if selected and then from there readjust your boot.ini settings.

Hi guys,

just to add strange things that happen when I open WinXP with this options: 80% of the fonts dissapear and won`t open in Adobe packages [Photoshop, Illustrator, AfterEffects… etc].

As I work design more than music - I had to put /fastdetect as second and to WinXP boot by default on classic mode [with “less” memory]…

I just wanted to add this strange behavior - but at least it works with Renoise perfectly ;)

All best ppl!
n.

you are not alone… looks like you have too much fonts in your system. I have found that page using this search; maybe it will help you find a solution, but I doubt there can be one