[solved] Renoise 1.8 Actually Performs Better Than The 2.0?

Hey all,

I’m running the demo version of Renoise 2.1.0

Before that, I was running 1.8.0, also the demo.

Now, somethings occuring that I do not understand.

In 1.8.0, I was able to play back this track I was making perfectly fine, which uses some complex VST libaries, even within the demo, without ASIO support, and I had quite a few running at once, without any hiccups for how long I was using it for.

Switch over to the new 2.1.0 however, and load this file up, and as more than 2 of these VST’s play, the sound starts to clip, and down goes an instrument, and I have to reload the song to hear it again.

What gives? :(

I may have to buy 1.8.0 (if thats even possible), and ignore the new version, ASIO support or not (if it worked perfectly fine for me before without it?)

I hope one of you can help. Its confused me, thats for sure :(

Not sure what is the reason for your problem, it is possible that renoise 2.1 actually uses more resources in some cases (just like win XP uses more resources than win 95), but please don’t quote me on that, I have never even used 1.8. There may be some configuration issues with either your system or renoise, wait for other replies.

About purchasing. Yeah, you can purchase 1.8, or actually, when you make the purchase now, you get updates until 3.1 (including), but you ALSO have access to all prior releases, including (but not limited to) 1.8, 1.9, 1.9.1 and 2.0.

Thanks Suva. Bit weird that though isn’t it? :(

I’m running Windows XP 32bit, SP3, 3GB’s of RAM, a Q6600 processor, and a Creative X-Fi sound card.

I’ve just downgraded back to 1.8.0 and its working fine, so its something to do with the new Renoise somewhere.

I never tested 1.9 to test if that had any issues or not. I just went to Renoise.com one day to find there was an update, and so tested it, and it happened to be version 2 :P

CPU usage while running the same VST 6 times on 1.8.0 gets a CPU usage of 10% max.

Whereas version 2 came up with a CPU error, saying that it had reached the cut off limit.

I have a 4 cored processor, I shouldn’t have any issues, especially not from an upgrade :P

I should mention that on both versions, the latencies, etc are set the same, and so is the Hardware accelation, so nothing has changed in that regard.

Not sure, but maybe this thread is related?


Yeah, do that:

  1. Make sure renoise is using 4 cores (not just one) under preferences.
  2. Post the log of your renoise session: Help => Show the Log File
  3. Wait a little.

Although it’s possible that 2.1 takes a little more CPU than 1.8, it definitely should not take that much more CPU so we definitely have some configuration issue on our hands.

Some other tips/questions:

Open the preferences, look at Audio, what latency do you have in 1.8? What latency in 2.1? The lower the latency, the more CPU will increase.

Also new to 2.1: Multi-core compatible. Make sure the settings one your plug-in are correct (click the [?] icon on the Renoise representation of the plug-in and adjust accordingly)

Thanks Conner_Bw!

Turns out the plugin couldn’t run in a multi-CPU environment in the (?) Took that off, and it worked straight away! Weird…

You don’t have to pay again to download an older version of Renoise btw.
You can just download them from backstage.