Sonic charge cyclone as fx

One of my favourite software samplers is the sonic charge cyclone , yamaha tx16w emulator
Sadly , the only way to sample directly into is to insert it as an effect ,
The workaround of renaming the dll to fx dll ( recommended on the sonic charge site ) is not working in renoise
1

Normaly the vst is called Cyclone.dll , duplicating the dll to Cyclone FX.dll and a config file to enable the inputs does nothing
It loaded once as an effect in renoise , but then Renoise would get all smart :slight_smile: and present a pop up it was an instrument , from then on it just totally ignores it as an effect
Both the instrument dll and renamed Fx.dll show up in instruments now
Too bad , because It’s such a wonderfull instrument for real time crunchy sampling

3 Likes

There’s a semi bug/hidden feature in Renoise which we’ve never fixed, cause it also can be useful:
If you open up the plugin Instrument list, you can drag and drop an instrument into an FX chain.

Notes can then be triggered to the FX by creating a VST FX alias as new instrument.

1 Like

I use this software heavily too.Great stuff.I think i understand what your saying.You know it can read aiff files?

1 Like

Wait…what?
wait_a_minute

…I’ll be damned.

2 Likes

Awesome !
But can’t get cyclone to sample at all ; renopise just totally ignores cyclone’s audio inputs
Just dragging theinstrument version into a channel , nada
Strange because in reaper in reaper it does.
@Toybox , have you got it working ?

No unfortunately not, I tried like you.So what I did is I made a few virtual floppy disks with aiff files stored on them.So I have tons of floppies now but I can’t sample into it.so I just use the floppies to process samples.But there’s no options or anything like that.

Even still it sounds fantastic.

Yeah strange , why it doesn’t work
Normally you should even hear the (virtual ) noise level rise when mic input is selected instead of line , but even that doesn’t occur

Taktik m could you shine some light as why it doesn’t work
Quick steps to go into samlping mode
Click on sample button
Make sure input potentiometer is turnend clockwise
Move cursor ( with arrow buttons ) to '‘GO’
All is done with the mouse pointer

1 Like

YUY , I got it working but a different approach
I copy -pasted and renamed cyclone.dll to CharleneFX.dll with accompanying confg file
It loaded as an effect and can now sample , make sure that autospend plugin is turned off
You can then either trigger the sampler with an instrument , but I tendo to just save it as an fxp and load it in a regular vst instance of cyclone ( which can be used multitimbral and has separate outputs )
Still it would be great if we could just use taktiks’ approach
2
3

1 Like

You fuckin legend you.Maximum respect.Try this later when I’m off work.

1

1 Like

Just learned about a fantastic feature on the cyclone
The ability to control parameter values with any midi cc number
Go to system set up , set slider , choose any cc nr ( default is 6 ) , when = always
now insert a renoise midi cc device , choose cc6
Now every parameter on cyclone can be adjusted with the slider instead of using the buttons

1 Like

I tried a similar config for a poppy. Something I didn’t succeed. can someone explain how to do it right?
CNFG

Mac doesn’t really use .dll ( dynamic link library ) , so I am afraid that solution won’t work

1 Like

Ok. Thnx. Maybe next time

I can’t get this to work,charlenefx shows up as an instrument,i can drag it into the fx section, however the audio is completely cut on whatever track it is put on,when monitoring audio for sampling, no input at all is detected.