Strange Automation Point

While working on a track I tried to adjust the vertical position of points within a selection by holding down the ALT key. And then suddenly something went wrong and out of nowhere appeared this point ˇˇ

Here’s the example file. See track 01’s volume automation.

This point acts weird as well. If you try to drag it around it stays where it is but creates a new ordinary one instead.

I played around a bit and it looks like there are actually 2 extra points in the envelope, both of them occupying the same time as another point in the envelope.

You can use the scripting terminal to get a closer look:

>>> rprint([1].tracks[1].automation[1].points)  
[1] => table  
 [time] => 1  
 [value] => 0.44047617912292  
[2] => table  
 [time] => 7  
 [value] => 0.34523808956146  
[3] => table  
 [time] => 8  
 [value] => 0.22619047760963  
[4] => table  
 [time] => 7  
 [value] => 0.71428567171097  
[5] => table  
 [time] => 8  
 [value] => 0.55952382087708  

Very weird indeed! Have you possibly been modifying the automation with some kind of tool before this?

Nope. I just created a new envelope on that track.

I usually love it when some weird glitch happens like this, but not this time because it means a problem in my Renoise :(

Perhaps annoying in bahvior, but on the fun side: looks like star-maps to me :D

This is just a little preview of the 0-attack automation possibility that will be in the next version of Renoise! :dribble:


Tried to create such a broken file, but didn’t managed to do so. Can you remember how exactly you did this or can you replicate this now with a blank song? Would be great if you could give us some more details, so that we can fix this.

If I paste the following into the envelope editor, I can duplicate the behaviour quite easily…

<?xml version="1.0" encoding="UTF-8"?>  
<envelope doc_version="0"><br>

Obviously, I introduced the error. But maybe a corrupt clipboard occurred?

I was about to suggest something similar.

You can really do some interesting things here :)

Lol! Can it also do scrolling test?

I remember getting an invalid automation point using the lbp tool from Mogue, dunno if that could be related to this issue? I had programmed a pattern, then shortened the pattern length without cutting away the last bit of programming, then expanded using the tool. ( Snippet: Convert Song From Lpb4 To Lpb12 )

hahahaha! =P

It was just trying to move two (maybe three) automation points within a selection while I held ALT. And that was it. I moved the points around a bit to find a desirable result and then there it was.

I have tried to replicate this for hours but haven’t found out what caused it. So I guess we just have to wait until it happens with someone else too… :D

The only way to quick fix this is if a situation is detected with multiple points, that automatically an undo action is being done, if the previous undo data is the automation data ofcourse.
We don’t want Renoise crashing because dblue made a nice Hello scroller with his script.


It’s quite interesting actually, because if you attach these weird envelopes to a Filter cutoff or something like that, you can see that Renoise still seems to process every point. My first thought was to try and make Renoise crash with some insanely extreme stuff here, but it actually handled it just fine. Even when I literally filled the envelope with so many points that it was just a pure white block, it still worked. (It was slow as hell to manipulate the envelope data, but otherwise it was ok)

Go Renoise!

So we can have instant attack and decay blocks?
That would open new opportunities!

next step: a 3d-graphics engine for demos and videgames