Sudden performance drop (cracking sounds)


(PPLo) #1

Hi guys!

Been using Renoise for a while without any issues but recently, it has started to have performance issues.

Some tracks I was working on now stops because of high CPU usage (which wasn’t the case before) and some VSTs (Nexus) are now unusable because they make cracking sonds when Renoise is using above 30% CPU. I had the same cracking sounds before BUT when I was at 80% CPU.

Since there were now big Renoise update, I supposed it’s one of my windows 10 updates that ruined everything.

I just wanted to ask if anyone had the same issues or know a fix for it.

I have a gig in June and am pretty nervous since I don’t have the money to buy a new computer.

Thanks!


CPU : 99.9% on my projects overnight
CPU : 99.9% on my projects overnight
(dblue) #2

Have you tried simply increasing your audio latency/buffer size?

In some cases just a few milliseconds of latency can be the difference between smooth playback and crackling problems.


(Paul Buck) #3

I still get random crackling in Renoise sometimes. I blame Win 10. Restarting Renoise works for me, as does changing sample rate on my interface.

My guess is it’s driver related in Win10.


(Conner_Bw) #4

WIndows 10 users, have you tried?

http://www.asio4all.org/


(Paul Buck) #5

WIndows 10 users, have you tried?

http://www.asio4all.org/

I will try this tonight. If anything,the disclaimer at the bottom of the page was worth it:

“Everything else on this page, including the numbers 16, 48 and 100 is or may become a trademark of Microsoft, Corp.”

Ha!


(ffx) #6

Maybe related to recent Spectre patches? Kernel I/O can be slowed down heavily AFAIK.


(PPLo) #7

Hey guys, thank you for your responses.

I’ve done some tests and am able to give you more details.

  • So first of all @dblue yes I have tried to increase latency. My sound card (Roland Duo-Capture Ex) allow max 13.1 millisec (576 samples).

It does reduce a bit the problem, but it is still here once I play a chord of more than 2 notes.

Before, I was at 4.4 millisec (192 samples) and I could play a chord of 5 notes before starting to have a little cracking sound.

  • If I switch to my cheap Behringer UCA202 sound card and set the latency to 24 millisec, it is nearly playable but the latency begin to be a bit too much for live play (especially for finger drumming).

  • @Conner_Bw If I switch to Asio4all and 11.6 millisec it reduce the problem a bit but I still hear the cracking sound.

  • If I switch to Direct sound 50 millisec, the problem disappear and I can play a chord of 7 notes without any cracking sound… but the latency is way too much for live play.

@ffx I don’t know what Spectre is. From what I have read online it is related to AMD, my computer has a Intel CPU.

So the problem is performance related for sure. The thing is I did not have this problem before and I didn’t made any major changes to my computer or configuration.

I have try to follow a random guide that I found where the guy explain how to disable some windows 10 services to increase performances, but it didn’t change anything.

I suppose the problem is related to my computer, not from Renoise specifically.

I am clueless about how to fix this since I am clueless about where this problem came from.

From now on I can see only two ways to go.

  1. try to update everything on my computer (but everything is supposed to be updated to the latest)

2.delete everything and reinstall everything on my computer

I will try to do some more tests and researches and keep you guys informed.

If you have any new idea I would love to hear them

Thanks again for taking the time to read and comment.

Cheers!


(ffx) #8

I don’t know how you googled, but it seems that your could improve your technique here :P. Spectre affects mainly Intel CPUs, and haswell or older are affected much stronger ( happy coincidence for Intel). Basically all kernel calls are massively slowed down. That s why maybe tried asio4all in non kernel mode…


(PPLo) #9

@ffx well I just googled “what is spectre” and then got lost on the internet :slight_smile:

Found a tool called InSpectre that checks and can disable “Spectre” and “Meltdown”. The tool told me that my system is not Spectre protected.

Right now I’m looking for something that is not up to date.

Feel free to keep sending me suggestions!

Thanks


(PPLo) #10

Just to keep you in touch with what I am doing:

-Running defrag

-Running CCleaner

-Uninstalling unused applications

-Making room on my C drive (even if there is already 100 Go of free space)


(PPLo) #11

Things are getting weirder…

I tried to plug my old pc (win7) and everything worked great in Renoise(2.8 on that computer)!

Old computer:

AMD Phenom 3 Core 2.3GHz, 4Go RAM (desktop)

A 10 notes chord made my CPU usage go to 40% without cracking sounds with the Nexus VST and the Grandpiano preset. Asio4all and berhinger uca202. 2.9 millisec latency.

Latest computer:

Intel Celeron 4 Core 2.16GHz, 8Go RAM (laptop)

A 5 notes chord made my CPU usage go to 80% and I hear cracking sound. Same VST same preset same asio4all same soundcard same latency.

Thoughts?


(The_Traveler) #12

Intel Celeron

I suspect it’s your CPU. I’m assuming your laptop is using a N28xx series processor. The Celeron shares it’s L2 cache between cores and your model lacks an L3 cache all together. The Phenom, on the other hand, has a individual L2 cache per core and a large L3 cache. In essence, there is not enough data being sent to the 4 cores of the Celeron via the caches to be processed in real time. On a laptop you have Intel integrated video that further loads the CPU as video memory is shared with data memory so some CPU cycles are dedicated to video updating.

When the Celeron L2 starts to choke, it falls back on accessing slower system RAM. The CPU loading you see increased is due to more CPU cycles needed to load the caches. That’s why you hear the crackling. If you were doing video processing, you would see “artifacts” on screen and much slower processing times.

Intel Celeron processors are best suited for desktop or laptops running low CPU tasks such as word processing apps, web browsers and so on. For audio work, I’d suggest at least an i5 multicore or comparable AMD CPU.

Cheers.


(PPLo) #13

Thanks for the informations @The_Traveler.

I am aware that this computer is not really good for music production. It was a cheap laptop that I bought with all my money for a gig in Germany.

One day I’ll have enough money to buy a better one.

Anyway, it doesn’t change the fact that this computer was running Renoise WAY more smoothly like a month ago!

I haven’t made any major changes on my configuration or installed a lot of applications lately.

This drop in performances is still a mystery for me.

Still looking online for clues. At this point I start to think it might be a physical problem.


(Conner_Bw) #14

Have you disabled CPU throttling?

http://isboxer.com/wiki/HOWTO:Disable_CPU_Throttling_in_Windows

(Related thread)


(The_Traveler) #15

I wouldn’t discount a Windows update having a negative impact. Intel and others released patches to fix the Meltdown and Spectre CPU exploits to directly access system memory via the L1/2/3 caches. The patches have varying performance hits depending on how frequently an application accesses memory. Audio and video processing would see noticeable decreases in performance.

As your running Win10, the MS patch was pushed to you, and I think it fits the time frame you mention.

https://support.microsoft.com/en-us/help/4073757/protect-your-windows-devices-against-spectre-meltdown

Conner_Bw has a point. You might check your power management settings and make sure they haven’t changed. I’ve seen all kinds of weird things change on my wife’s Win10 desktop after an update. Who knows? :wink:

Cheers.


(PPLo) #16

That is very interesting @The_Traveler and @Conner_Bw

That is also a lot of things I have never heard about and need to investigate (with my poor googling skills :wacko: ).

I will have time later today to do researches and tests and will keep you guys in touch.

Thank you for helping me out! Really appreciated :slight_smile:


(PPLo) #17

BIG IMPROVEMENTS!

While trying to follow @Conner_Bw link, I was first horrified to find out there were no more power options in my parameter window!

Turns out it was at another place now. You have to click on the battery logo to access them.

And there I realized that windows has changed my power saving parameter to “balanced” without asking me!

Switched it to “optimal” and I already saw a very significant change!

I’ll do some more test before putting this thread on [SOLVED] but I think you guys just solved my problem! :slight_smile:

More soon …

EDIT:

YOU GUYS DID IT! :yeah:

All my tracks are working again and I am able to play live VST without any cracking sounds (as long as I do not push too many keys at the same time).

I want to say thank you to the awesome Renoise community and especially to @The_Traveler, @Conner_Bw, @ffx and@dblue.

Thank you for your patience and kindness! You are awesome <3

And now back to music :slight_smile:

Cheers!


(The_Traveler) #18

Excellent! Happy to hear you were able to solve the problem. :slight_smile:

Cheers.


(NocifLentus) #19

Hello everyone, sorry to do that but I’m joining this thread 'cause I’ve had exactly the same problem since last week but I have an AMD FX 8350 (8 cores 4GHz) and I’m on win7, 16 Go Ram.

I’ve tried everything said on this thread (meaning format and reinstall windows, increasing the buffer, disabling CPU throttling, checked withInSpectre : says it’s metldown protected but can’t do anything about it…

and I checked my ram with memtest and my hard drives with crystaldiskinfo and there’s no problem with that)

And I checked for all my equipment and system updates…

But I’m not as lucky as PPLo…

The only thing I can see now is my blackbird onyx firewire is dead… but I don’t really know how all of this works so I’m left without a clue. Could it be the firewire cable? or the IEEE 1394 card?

I tried to put an old M-audio delta 44 and it was the same…

And I tried on both 32bit and 64bit version of Renoise. I have the same problem in cubase (both 64bit and 32 bit) with the asio load being 100%…

But I tried to make a short edit in Adobe Premiere and I had no problem.


(PPLo) #20

Do you have the same issue if you configure Renoise on direct sound or is it only on asio?