Tool Browser Url & Tool Updater Errors

RC1 has the wrong URL in the Tool Browser.

Tools -> Tool Browser
Click the HTTP button in the upper left.

Expected: Tools
Actual: 404

Regards,

:walkman:

:panic:

Thanks. Should work now.

getting the same thing here.

in “scripts/tools/com.renoise.ToolUpdater/main.lua”

change :
local DOMAIN = ‘http://tools.renoise.com/

to:
local DOMAIN = ‘http://www.renoise.com/

Then it should work.

:guitar:

Thanxs ! It works !

:drummer:

While this works, is this the only way to fix it? Not every user has the terminal enabled, also…I seem to have this tool installed 3 times??

Well, i guess the old tools folder is not being overwritten during Renoise installing so, if you have the old updater tool, yes this is the only way to fix it.
And if you don’t have the terminal enabled, you can still go to the preferences folder and from there visit the scripts folder in the explorer.
What’s the problem with opening the lua file in notepad?

you don’t get it do ya?

Don’t worry, i do get you:
I am solely speaking of a solution with RC1 here, not a solution that should be applied with Rc2 as well ;)
I understood from Taktik that on the server something also has been done to allow current old tool-updater to work. The only thing which can’t be controlled are DNS servers, hence it didn’t worked out for everybody when the change was applied.

Just to make clear what’s the status of this. We’ve moved the renoise server to a new IP, so it will take some time until it’s properly activated in the whole world and thus the problem will fix itself soon.

If it does not for some reasons, or you want to use the tool updater right now, you can hack the “local DOMAIN = ‘http://tools.renoise.com/’” manually to http://www.renoise.com/ as proposed above.

We will of course change the URL to http://www.renoise.com/ in the next Renoise update.

Sorry for the troubles.

Hey everybody ! I just update the tool updater http://www.renoise.com/tools/tool-updater and it would change nohting, I have the same error message as in the post form BreemiX !
I opened files in textedit and local DOMAIN = 'http://www.renoise.com/ is right !!! Strange mistake !

Yay, sorry. The problem turned out to be something else: It’s caused by an old updater tool that you have installed.

To fix the problem

  • open Renoise
  • launch the Tool Browser from the “Tools” -> “Tool Browser…” menu
  • find “com.Renoise.ToolUpdater” and “com.Renoise.UpdateChecker” within “Installed tools” and click on uninstall

Renoise will then use its bundled updater tools, which you should see in the Tool Browser on the very top.

Hello Taktik, ypu give me the right answer it’s working great :wink:

Merci

in “scripts/tools/com.renoise.ToolUpdater/main.lua”

change :
local DOMAIN = 'http://www.renoise.com/’

Then it should work.

A new version with the domain changed:


Help Menu: Find Tool Updates…

8289 com.renoise.ToolUpdater_V7.1.xrnx


Original tool page:
https://www.renoise.com/tools/update-checker

A new version

For those still running 2.7?

I can update the tool page if you want me to.

Not sure exactly when this tool started to be bundled with Renoise, but since a long time…

My mistake!

think something went wrong on my system (probably the grey matter!)

didn`t realise/ forgot this was bundled and was overinstalling with this version of the tool.

If you think its worth updating the tool page please do, but the API version in the manifest is probably wrong now…

I do not want to entangle, but this is very ugly:

http://www.renoise.com/download/checkversion.php?prod=Renoise&version=311&regged=1

Page notfound

The requested page “/download/checkversion.php?prod=Renoise&version=311&regged=1” could not be found.

This has remained fallen for many, many months!

Access: top menu of Renoise: Help / Check for updates…