Weird thing going on with the process DSP FX

So I’ve been using Renoise for a few months now, I’ve recently started to implement destructive rendering to my workflow but to my surprise the DSP rendering on Renoise is quite weird. I don’t know if I’m doing something I shouldn’t but everytime I render track DSP or sample DSP it sound totally different from the live processing/playback. I made two projects exemplifying my problem:

(sorry for the external link but I wasn’t able to directly upload them here)

I’m quite disappointed about it, maybe I’m just too dumb. But here some observations about the projects:

1 - The pattern rendering (ctrl+shift+r) works fine, no audible difference from the live playback.
2 - Needless to say but I used exactly the same plugins with the exact same settings in every case.
3 - I left spare clean samples in the projects in case anyone feels like testing this themselves
4 - My samplerate is set to 48khz.

Can anyone help me on this? I’d highly appreciate any insight on how to make the DSP FX processing (both track and sample) work properly.

Cheers!

Have you adjusted the Headroom setting in the Project Settings? By default this is set to -6dB and I believe this is the culprit. I have noticed this behavior as well. When rendering patterns, everything works as expected and appears to include the headroom adjustment, but when you Render Track/Sample DSP in the Sample Editor, it seems to pass the unadjusted signal. This causes over-compression, washed out reverb, resonances, etc. depending on the DSP being rendered. I just started adjusting the sample’s gain in the Editor before rendering to counteract this, might be worth a shot.

@taktik Is this behavior intended? I can put together a bug report to better illustrate the issue.

Everything is default on Renoise here, except the samplerate and a few shortcuts I made. I will try to disable the headroom option and see if it makes a difference.

Yeah, it didn’t fix it. Although the levels appear to be the same it still sounds different.

I’ll make more testing later.

Well, it seems the topic has died out. I at least hope the DEVs took note of this somehow. Or maybe I’m being too optimistic.

Can you post a steps to reproduce? No idea what to check… Your original beat sample seems to be 44,1kHz and you sampled it in 48kHz, and then it seems to be playbacked at 44,1kHz again, hence it sounds lower?

You can easily reproduce it using the project files I’ve uploaded. They contain an unprocessed sample of the break I’ve used to exemplify the issue as much as the fx chain used to process it. You can test it for youself in whatever samplerate you feel like. I agree with you tho, I should have tested it with different samplerates!

I’m a bit late here and can’t download your example file anymore:

Transfer expired
Sorry, this transfer has expired and is not available any more

Could you please upload it again or attach it here?

Sure, thanks for letting me know, link is now updated.