When deleting a track column, midi events won't joined together


(ffx) #1

Hi,

if I have a midi automation like this
24

and now am dragging the last track column one position to the left
38

and then decrease the number of track columns
51

the fx commands will not be reconnected together to valid midi events again (which will happen if I drag the column back to last position instead) and the fx stays/turns into ugly random like device on/off automation instead (** the midi automation actually will work again, but also the device automation will stay, see testcase below).

Also I would like to highly suggest to you to totally decouple on/off device automation from midi automation, e.g. using unique fx command instead of double-use Mx-commands and providing a automatic song conversion then. Or maybe it would be even even better, if you were providing graphical on/off automation.

Besides the above reason, there are also the following reasons to change the double-usage of Mx:

  • In the above scenario, if I accidentally change the song position and the song option “automation following” is enabled, and the song position now passes those values, a lot of on/off automation and preset hopping will appear, which also will not be saved in undo history. So it will end up irreparable

  • There are other scenarios AFAIK which I did forget in detail, when a midi automation will accidentally turn into on/off automation. I think it was quantization in adv. tools and also as a tool

  • You can never say for sure, if a device will be accidentally automated, because there is no automation indicator at all. So Russian roulette style. Also there is no indicator for preset switch automation

Thanks!

** TESTCASE

Here is a testcase song. Please repeat the above step 1, watch device no.1 “stereo expander” and device no.3 “eq5”. Make sure that you scroll over those values and have “automation following” enabled. Then reduce the column count. The midi automation is listenable again, but also device no.1 still has this automation there.

bug onoff automation.xrns (9.8 KB)


(ffx) #2

Added testcase

Also please read here: Ideas: Improving pattern midi automation


(ffx) #3

So it ends up with multiple automation for one command, device automation + midi automation at once. The title of this thread then is inaccurate, but I guess you already get it.


(taktik) #4

The title is just fine. Let’s simply stop misusing those “[XXX]” things as tags. Topics are getting read either way.


As you’ve already mentioned, the problem is the reordering - adding/removing new columns will work just fine.

The automatic “rewriting” of those existing Ms will always work when expanding the columns. But when deleting or reordering, they will start messing up existing contents of other columns, so it’s really a mess either way. The cleanest way probably would be disallowing to move/drag around such columns then.


(ffx) #5

Ok, but what if I want to get rid of empty columns? This currently only works, if I first move the empty ones to the right. The midi automation column is in the way then.

Or is there any other way that I am not aware of?

Isn’t it then more easy to remap the device on/off automation and preset automation to another unique letter instead (not using Mx)? Then also nothing would happen while dragging the midi column around.