Windows: Hotkeys forgetting settings with russian keyboard

Windows 8.1

Renoise 3.0.1 (started as admin)

  1. Hotkeys forgeting their settings constantly.

  2. Play from selected position in track editor - looses some lines before starts playing time to time.

If you do not run Renoise as admin, are keyboard shortcuts then memorized just fine? Which keyboard shortcuts are not memorized? When a scripts with keybindings fails to load, it’s keybindings are lost too cause they are not registered, not present anymore, cause the script is not running. Should never happen with other keybindings though.

Could you please also post your Renoise log file? (Renoise -> Help -> Show Log file…)

Could you please also give us a few more hints about the “play from current line” problem?

Run as Admin or as User - no difference.

Undo/Redo resets to just “CTRL” and “CTRL shift” w/o keys mapped

Also Open Render Dialog resets “CTRL shift” w/o keys mapped

As far as i can see - all key mappings reseted - just “CTRL’s” and “ALT’s” stays in list.

Here is the log file:

Play from current line issue is hard to reproduce - it happens occasionally, but i’ll try to find the conditions it happens and give more info.

From current moment i find out that it happens after you use PgUp or PgDwn keys to navigate the pattern, then pressing Play from current line key and you can find the play position jumps to place where cursor was befor the PgUp or PgDwn navigation used.

Which keyboard/input-language do you use?

Guess this started to happen all of the sudden for you and was not always like that. What changed (in your system) before this started breaking?

Keyboard - Logitech wired PS2 keyboard.

Language - Russian / English.

It started to happen when i fully reinstall system and went from Windows 7 to 8.1 + went from Renoise 2.7 to 3.1 it all happens in same time.

I suppose it may be concerned with Windows 8.1 higher securityrequirements (comparing to W7)

Now you need admin rights to change anything in folders like Program Files, Users, Program Data etc.

Anyone else using Renoise 3 under Windows 8.1 ? No issues ?

Sorry for small lag. The russian keyboard input language seems to be the problem: can replicate this here in Windows 8.1 too.

As a workaround for now, go to “Control Panel\Clock, Language, and Region\Language\Advanced settings” and enable “Let me set a different input method for each app window”. Set the language to english,start Renoise, reset all keybindings in Renoise’s prefs and restart Renoise.

You can then set language to russian in application when needed, but English must be the default to make things work in Renoise.

We’ll look into this here. Keybindings of course should work with any keyboard language.

Thank you! I’ll follow your instructions and will test Renoise behaviour then.

Will report if there are any more issues found.

Actually seems to be an old (but annoying) problem: if you don’t switch between multiple keyboard languages, always use the same keyboard language when starting Renoise, it will always remember all keys as expected.

Sorry, my fault about the jumping position bugreport!

As i found - it works as it should, found my mistake:

WinMenu (Apps) key was assigned to Global:Transport:Pause/Continue by default.

But in Renoise 2 it was assigned to Global:Transport:Pause/Continue (from cursor)

So i used to use it to play song from cursor position, and it jumps to pause position that makes me think it is a bug.

Now i reassigned this key to play (from cursor) and it works like a charm.

Sorry for false bugreport.

Now about the key bindings reset, i think your instructions with language settings is helping for now. Will do more tests.