Excalibur VST2 is mono in Renoise 3.3 & keyboard assignment issues

I was still using 3.1.1 (reverted from 3.2 because I don’t really like it for some reason) and today I upgraded to 3.3. As always I have my full backup, so I can compare things.

First - everything looks… worse, like in 3.2. Really - this thin font is ugly. But that’s not important. More important is - it sounds different! Not big difference but still.

http://www.thrash.pl/newvsold.zip - two very small fragments of wav. One rendered on 3.1.1, one (from the same song) on 3.3. Both versions have the same parameters (mixing quality, play quality etc).

So why these differences? Sorry that I can’t give longer example. And it seems to affect samples mostly, not plugins as far as I know.

Sure, I can finish my projects using old Renoise and then switch to new one, but… I want to know why these differences? If it’s some kind of mixing improvement - I can live with that and adjust to “new and better”. If answer is “no way, it should sounds the same, nothing has changed in that matter” then… well, then we will see. Maybe I made upgrade when I’ll have any VST3. :confused:

1 Like

They do sound different; although i prefer the more rounded sound of ‘new’ riff.
Ran the files through strings and diff and the data portion is 100% different.

Unfortunately I don’t have an old version to try the same test here, but think
it might be helpful to gather the logs from both export sessions for comparison.

The relevent portion looks like this:
Application: Enter MainLoop…

RenderToDisk: Prepare rendering with mode:'Entire Song', separate tracks:'NO'...
RenderToDisk: Validating render options...
RenderToDisk: Resetting the player...
RenderToDisk: Preparing the audio files (1 in total)...
RenderToDisk: Killing Audio IO...

ASIO: Stop Polling...
ASIO: Releasing Creative SBZ Series ASIO...

RenderToDisk: Rendering at 44100Hz with a block size of 448 samples...
RenderToDisk: Setup track routing...
RenderToDisk: Entering the render thread...
RenderToDisk: Preparing latency compensation: Will shift all content by 0 samples...
RenderToDisk: Starting to render...
RenderToDisk: Leaving the render thread...
RenderToDisk: Finalize rendering...
RenderToDisk: Closing all audio files...
RenderToDisk: Restoring the song...
RenderToDisk: Starting Audio IO...

ASIO: Initializing
ASIO: Trying to open 'Creative SBZ Series ASIO'
ASIO: LoadAsioDriver ... OK
ASIO: ASIOInit ... OK
ASIO: Using SampleRate 44100
ASIO: PostOutput is not supported
ASIO: FillDriverInfo ... OK
ASIO: Got kAsioEngineVersion (2)
ASIO: Got kAsioSupportsTimeInfo (yes)
ASIO: InputBuffers: 4 available, 4 selected - Type ASIOSTInt32LSB
ASIO: OutputBuffers: 6 available, 6 selected - Type ASIOSTInt32LSB
ASIO: OutputLatency: 448, InputLatency: 448
ASIO: CreateBuffers ... OK
ASIO: ASIOStart ... OK
ASIO: Up and running

RenderToDisk: Rendering finished...

I may agree, except it broke my job.

I’m just asking if offline renderer (and renderer in general) changes from 3.1.1 to 3.3.
It’s simply “yes or no” question. I can switch to new version step by step if I get confirmation. I don’t need to investigate problem, because this gives me nothing in fact. Just some info about changes in render (like “we increase precission” or “we added some extra processing procedure”).

Yeah, makes sense, and thanks for pointing this out; now i’m curious as well.
Had a look at the changelog and don’t see anything regarding this.

I found plugin that works bad. It’s called “Excalibur” and it works bad in new Renoise (sound is almost mute and becomes mono)! It’s paid plugin, so - sorry, I don’t want to that kind of improvement. And it’s only one plugin, who knows how rest of them will work.

Then another annoying thing (begins with 3.2 version) is changing of keyboard support. I don’t know what changes, but now it works different.

I have second program that have lot of key shortcuts assigned and some of them are the same like in Renoise. And because it’s complex filemanager, I was able to figure out how to eat cake and have one. So I made script for that problematic shortcut keys and if Renoise is active in system - other programs that starts with these shortcut keys, just don’t start. Key is still handling by that program (reading), but it gives no result. Ok, so Renoise works ok in 3.1.1 version because it reads keyboard somehow good no matter if other program use the same system-wide shortcut. Now Renoise can’t see SHIFT+F3 (for example) until I disable second program (or global hotkeys in it).

To be more clear - I run Corel Draw by pressing Shift+F3 in my system. And I don’t want to change that. But it’s cut track in Renoise. So program that starts Corel Draw checks (it has that option) if Renoise is in tasklist. If yes - then Corel Draw is NOT executed. And Renoise 3.1.1 just works fine, don’t care if any other program uses the same shortcut. From 3.2 version it starts carying and just stop using system-wide shortcuts.

Is any method to made option “old style keyboard handling”?

There have been no changes made to the rendering process.

I’ll look at the Excalibur VST (you mean this one, https://www.izotope.com/en/shop/exponential-audio-excalibur.html - is this correct?) Maybe its two mono inputs are now treated as one main input and one side-chain input. That’s the only related change we made to the VST2 support in Renoise 3.3.

In general, we’re not forcing anyone to run the very latest version. If you’re happy with Renoise 3.1 and it works exactly as you want, then simply continue using it. It will work in future as well.

1 Like

Yes, it’s that Excalibur.


Here is fully functional trial. And I bought it in very good price some weeks ago (for sure 152 euros is not worth for that plugin).

You’re right, I’m happy with 3.1.1, but I also want VST3 support.

What about keyboard handling? Is any way to add an option to use 3.1 version style? You changed it in 3.2 somehow.

And bolder font (in track) will be very useful btw.

I see no fix for this bug in last changelog. Is it detailed changelog of Renoise or just list of major changes (plus “several fixes”)?

I also want to know is this the right place to discuss and report bugs, or email / form is more proper?

I also have issue with their R4 reverb going mono https://www.izotope.com/en/shop/exponential-audio-r4.html

The same brand I think.

Seems like you are on to something because the R4 reverb works in stereo in 3.2.2, really hope you can fix this as it’s such a beautiful reverb

Yeah Exponential audio

Have you tried changing the font-size to Huge and maybe scale the interface to 125?

This will result of BIGGER fonts and everything will be bigger. I don’t want it bigger, I just want bold fonts.

TL;TD will be fixed in the next update.

It’s tricky to check if a VST2 plugin with two channels should be treated as two mono inputs (one main input and one side chain input) or if it’s plain stereo, in order to support side-chain inputs for VST. Seems that our tests didn’t do the job for izotope plugins, so we’ll now treat plugins with 2 inputs as stereo in doubt to fix this.

All this shouldn’t be a problem with VST3 plugins, so the izotope VST3 plugins will work fine right now as well. I understand that this is not a good workaround for old songs though…

Erhmm… oh you made me realize R4 actually comes in VST3 variant I just needed to install it and stereo does indeed work there, I must have many VST3 plugins to install.
… I wonder if I just shipped an Album with mono reverbs :thinking: :joy:

Is anywhere section where I can look to check when new version will be available?

When I may expect that update? It will be nice to switch to newer version with VST3 support without affecting old projects.

I think patience is the key here. :slight_smile:

On it. A new release will be published shortly…

1 Like