New Tool (3.0): CDP lua tool


(neopan) #201

Thanks for your work Afta8, this is a great tool! :w00t:/>


(emre_k) #202

Thanks a lot for this tool. I keep breaking it but really amazing stuff. :drummer:


(emre_k) #203

Seriously guys. This thing is too good. It feels like I’m using Renoise v4 or something with this tool. Everyone should give it a go. It makes you feel like a mad professor…

So in reality I’m still a noob at this and I’m probably missing something obvious here (not even sure if it’s the right place to ask) but… I can’t seem to make the reverb work no matter what I try. Anyone can help?


(Akiz) #204

Yeah, absolutelly amazing.
I am just missing one function. Something like “apply + create new sample” so i can have one original sample, apply some effects and then select what i like the most without trying and undoing :-).


(Djeroek) #205

I can be un-official support for this tool as I did most of the presets :) , what doesn’t work for you?

Please list ‘exe filter’ & defenition name, what you’re trying to do. Note that the terminal output can give hints on what parameters are set wrong, you might have to scroll up to see it. Also check out CDP’s documentation on what your chosen effect is supposed to do, sometimes parameters rely on specific audio characteristics and wont return any results if not found.

I take it you’re talking about ‘Reverb - Multi-Channel reverb’?

Works fie here no matter what I throw at it, mono, stereo, different bitrates etc. What settings did you use?


(emre_k) #206

Weird. I’m on 64 bit Windows 7, running 32 bit Renoise3. I have the CDP v.7.0 installed and i’ve got the CDP interface tool v.0.3. I’ve also put the “user_definitions.lua” file into the cdprogs directory. I’ve tried both “reverb” and “rmverb” exe filters on different filetypes (simple snare drum sample for instance at 44.1k, 16 or 24 bit, stereo or mono) and they just won’t work no matter what.

I’m sure I’m doing something very wrong but not sure what. I can make many of the processes work (filter, blur, modify, even the vocoding stuff works fine) but not the reverbs. I’ve tried every combination and it just says “output file not produced - check settings”. No error messages or anything btw.


(Djeroek) #207

I know there are issues with windows 7 and running the pvoc based processes, you’ll need to do extra stuff to make it work, from the first page of this thread;

http://unstablesound.net/cdpforum/index.php?topic=24.msg71#new

But if the blur processes work for you, I guess you already did this(?), maybe it is the 64 bit OS & Renoise 32 bit version mismatch that is the culprit? Can’t remember if similar problems been discussed in this thread before with the reverbs, if you’re up to it try going through the posts, or maybe ask on the CDP forum for support?


(emre_k) #208

I did that fix indeed, and I can run the pvoc stuff (in love with that pvoc process btw). Gonna try it with 64 bit renoise later, I suspected that too. Will try the CDP forum if nothing works. I’m still amazed with this stuff. No idea how I was able to make music before this! Should stop being lazy and read up on how the text file based stuff works.

Anyhow, thanks alot for your reply. I’ll probably pester you again later.


(vincentvc) #209

i just got this, im on a win8 machine and only get the error with every process:

cdpr7 is in my downloads folder. i also added CDP_SOUND_EXT to my Environment Variables.


(Djeroek) #210

Found this thread on the cdp forum; http://unstablesound.net/cdpforum/index.php?topic=14.0

Can you extract the contents of the zip to the progs folder, overwrite the old ones, and see if the reverb works now?

Can’t remember if there were compatibility issues with Win 8, maybe authority / admin settings needing to be changed? Better ask on the CDP forum; http://www.unstablesound.net/cdpforum/


(emre_k) #211

It does! Totally awesome. It didn’t work first so I figured I should reinstall the tool but that didn’t work either. So I had to move the progs folder somewhere else to get the tool “rescan” the updated exe’s and then it finally worked. In case someone else runs into the same issue.

Big ups man! Really love having an offline reverb and it sounds great :yeah:


(Akiz) #212

Even new Computer Music magazine writes about this tool and renoise…
Funny, it looks like it has made better impact than R3 alone :slight_smile:


(Djeroek) #213

lol, you salty. Can’t make a post without ribbing good ol’ Renoise, right?

What did Computer Music say about the tool, small blurb in the tracking section?


#214

Pretty much…
5122 photo.PNG


(Akiz) #215

Even my girlfriend hates me for this :slight_smile:


(xrxs) #216

Epic


(Djeroek) #217

nice


(thalamus) #218

Hey folks

Newb to this … but looks interesting indeed.

I get a Renoise error “An output file was not produced - Check your settings”

Any idea which settings need … er … setting?

Cheers


(Djeroek) #219

Have you read the first page of this thread? There can be multiple reasons why you get such an error notice, also you need to be more clear in the description on what process you’ve chosen, what you’re trying to do. In the tool there is a small terminal which displays possible errors, maybe you’ve set a parameter value outside of the range the process accepts?


(thalamus) #220

Yeah I’ve read it - though it’s slightly info overload territory so maybe I have missed something.

I’ve picked the ‘distort - distort reform’ process to simplify matters. Nothing is shown in the terminal window when I run the filter. Just get the error I described above.

Basically I need to get the filter EXEs in the right place, is what I’m taking away from all this.

I created a folder called ‘de.johann-lau.RunCommandsOnSelection.xrnx’ in ‘\Program Files\Renoise 3.0.0\Scripts\Tools’ and put all the filter .exes in there.
no dice.

I am missing the point here? :)