New Tool (3.0): CDP lua tool


(Djeroek) #221

No not at all,

First you need to install Cdp to a preferred location, than install the tool in Renoise, after booting up the tool for the first time it will throw up a notice about where it can find the exes. You need to point it to the correct folder. No need to drag the exes to Renoises script folder.

What operating system are you running?

edit;

I’ve just seen your edit;

This CDP Lua tool has nothing to do with Johann’s script! They are 2 different things, dunno how you can miss the top first link to the lua tool?


(thalamus) #222

Yeah I installed the CDP stuff already, of course.

I pointed the renoise tool to the stuff when it asked me to. I still get the error I described.

Maybe it’s got something to do with the environment variable thing (am on Win7).


(Djeroek) #223

probably, try the fix with setting the variable as pointed out on the first page.


(thalamus) #224

Anyone else here successfully set the environment variable?

I’ve got:

Variable:
CDP_SOUND_EXT

Value:
wav

still getting the error.


(Djeroek) #225

Maybe you can ask at the CDP forum;
http://unstablesound.net/cdpforum/index.php?board=1.0

edit;

do you get the particular error only with the distort reform process or with everything, does it also matter if mono stereo / 16 or 32 bit, do you have administrator rights?


(Djeroek) #226

I suspect the answer is somehwere here;


(thalamus) #227

I get the same error with all filters working on all bit depths and sample rates.

Well, I assume ‘all’ ;)


(thalamus) #228

Aha … thanks - I will try that out.


(emre_k) #229

Hey guys. Two things:

1-Would it be possible to add an option to the tool to insert the name of the process used into the new sample’s name? Would be pretty cool imo. I hate it when I have a super sweet sound and can’t remember what I’ve used to get it.

2-Can’t seem to get (at least) some of the spectral processes work in Mac OS (OS X 10.9.3, Renoise 3, 32 bit). Specifically Blur (first 2 processes in the dropdown list) and Spec Magnify. I believe I managed to do the extra steps for the Mac Installation. Filters, pvoc, distortion etc. work fine but not blur and spec. Any ideas?


(Djeroek) #230
  1. would be nice to have indeed, think I proposed it somewhere before.

  2. spec magnify works here on the pc, are you sure you’re not using wrong parameter settings, for example setting a time outside of the samples length? Does it make a difference using different sample/bit rates?

What does the terminal inside the tool say? (you can scroll up/down to see more info)


(emre_k) #231

Hey, it says “Invalid Data” and this

I can run them on PC too but somehow not on Mac. Tried some more and apparently many things won’t work: Spec, Blur, Hilite, Focus, Strange, Repitch so far. So I suppose something big is not right.


(Djeroek) #232

The answer is most definitely somewhere in this thread :P , on the pc you have to set some variables in the OS preferences, can’t remember if something similar need to be done on the mac or how?

there is this thread though in the mac section of the CDP forum;
http://unstablesound.net/cdpforum/index.php?topic=32.0


(emre_k) #233

It’s that one indeed. Turns out I forgot the most significant fix of all computer related problems… Restarting! So if anyone runs into a similar issue, you need to do the first two steps (I skipped the 3rd as it looked unrelated for Renoise) described in manualconfig.pdf found in the documentation for Macs. And then restart your machine.

Anyhow, helped me out here again man, thanks alot! Still blown away by the awesomeness of this tool… :yeah:


(Djeroek) #234

Got this bug notice entering in a value for a parameter and pressing ‘process’;

‘C:\Users\plugexpert\AppData\Roaming\Renoise\V3.0.0\Scripts\Tools\com.afta8.CdpInterface.xrnx\main.lua’ failed in one of its notifiers.

Please contact the author (afta8 | fathand@gmail.com ) for assistance…

std::logic_error: ‘ViewBuilder: invalid value for slider: ‘-1.#IND’. value must be [0 - 0].’
stack traceback:
[C]: ?
[C]: in function ‘__newindex’
[string “do…”]:22: in function <[string “do…”]:11>
main.lua:646: in function main.lua:645

Happened with the first process of EXE filter ‘pitch’ (Pitch Chord - Transposed version…)

This is a process that needs a transpose file to work, but when typing in a number for the first parameter ‘transpose_file’ it automatically throws up the notice, the value box will say ‘NaN’.

I understand why it happens, because of the limits I set in the definition file, but thought I mention here nevertheless :slight_smile: .


(re.dread) #235

Tried to get this to work, but i get:

ERROR: INVALID DATA
ERROR: Cannot open output file C:\Users\dread\AppData\Local\Temp\Renoise-0-2144\Renoise_TmpFile-0-121.ana

errors for nearly all presets too.

Win7 x64: i tried the suggestion above: XP Mode and User Acount Control thingy off.

What i did notice is that when you move the CDP folder to “\Program Files (x86)” os.execute() doesn’t work anymore because of the the white space in the filename.

Change line 499 to: return “”" … path…exe … “” " … mode and it works again (File names with spaces need to be “quoted”).

Not 100%-ish sure, but i think windows allows user names with spaces too? In that case all the other file names should be quoted for windows too, i suppose.


(Djeroek) #236

Tried to get this to work, but i get:

ERROR: INVALID DATA
ERROR: Cannot open output file C:\Users\dread\AppData\Local\Temp\Renoise-0-2144\Renoise_TmpFile-0-121.ana

errors for nearly all presets too.

Win7 x64: i tried the suggestion above: XP Mode and User Acount Control thingy off.

What i did notice is that when you move the CDP folder to “\Program Files (x86)” os.execute() doesn’t work anymore because of the the white space in the filename.

Change line 499 to: return “”" … path…exe … “” " … mode and it works again (File names with spaces need to be “quoted”).

Not 100%-ish sure, but i think windows allows user names with spaces too? In that case all the other file names should be quoted for windows too, i suppose.

So this didn’t work?

CDP and Windows 7, 64-bit Edition – current information

Soundshaper and CDP run well on Windows 7, but they do NOT run natively on Windows 7, 64-bit.

However, it is may be possible to run CDP / Soundshaper in XP Mode. Apparently, the procedure below can be done in the Windows 7 ‘Professional’ and ‘Ultimate’ Editions, but NOT in Windows 7 ‘Home’ Edition. Thus, CDP is not compatible with Windows 7 Home Edition.

Install the CDP exes into the x86 folder.

Change the permissions of the installation folder, and that of Soundshaper’s Temp ‘Sounds’ folder, and therefore all the contents of both, to 777 or ‘Total Control’ for all users: Right Click on the folder, ‘properties’, ‘security’ then set ‘system’ and all the ‘users’, including ‘administrator,’ to ‘Total Control’.

Turn off User Account Control.

Set all the exe files inside the CDP installation directory (e.g., in cdpr6_cdp_cdprogs, or perhaps in a ‘bin’ folder if installed exclusively for Soundshaper) to run under ‘xpmode’: right click on each exe, click on ‘troubleshoot compatibility’, try ‘recommended settings’, accept the suggestion to run in XP mode, then save that. Do this for each exe.

[I’m very grateful to Julian Thomas for finding this solution and providing the above information.

  • R.F.]

If you find out any more information about this, please post an email to the CDP User Group.

It is been a while since I’ve gone through this, but you also need to set some system variables or something for the pvoc processes, better look or ask on the official CDP forums for details as I’m not going through this 10 page thread :slight_smile:


#237

Tried to get this to work, but i get:

ERROR: INVALID DATA
ERROR: Cannot open output file C:\Users\dread\AppData\Local\Temp\Renoise-0-2144\Renoise_TmpFile-0-121.ana

errors for nearly all presets too.

Win7 x64: i tried the suggestion above: XP Mode and User Acount Control thingy off.

What i did notice is that when you move the CDP folder to “\Program Files (x86)” os.execute() doesn’t work anymore because of the the white space in the filename.

Change line 499 to: return “”" … path…exe … “” " … mode and it works again (File names with spaces need to be “quoted”).

Not 100%-ish sure, but i think windows allows user names with spaces too? In that case all the other file names should be quoted for windows too, i suppose.

Yeah the spaces in a path is an issue on osx as well, I will fix this for the next update.

I think there have been peopl who have got this working on Win7 x64 but I can’t help with that too much as I’m developing this on a mac. I think the answers are somewhere in this thread if you can face wading through it :slight_smile:


(emre_k) #238

Yeah I could get it to work in Win7 64bit. re.dread, have you done this step?

The usual cause of this error message is that the environment variable CDP_SOUND_EXT has not been defined (to wav). This can be done via Control Panel->System Settings->Advanced->Environment Variables.

We are in the process of preparing an update release (all platforms) where this variable is internally preset to wav by default, so that setting it explicitly will be optional. We will of course announce the update here, as well as on the CDP download page.


(re.dread) #239

That did the trick, thx! guess moving to Program Files (x86) and setting XP-mode ain’t really necessary then?


(emre_k) #240

Crap.

Looks like the Yosemite upgrade broke the environment variable thingy on MacOS. Can’t get the blur, spec, hilite etc. working no matter what. Any ideas? :frowning: Anyone on Yosemite running it? I managed to fix it before but not this time:

Hey, it says “Invalid Data” and this

XEiJMQt.png

I can run them on PC too but somehow not on Mac. Tried some more and apparently many things won’t work: Spec, Blur, Hilite, Focus, Strange, Repitch so far. So I suppose something big is not right.

UPDATE: This thread on the cdp forum fixed my issue:

http://unstablesound.net/cdpforum/index.php?topic=47.0

It was a bit random as I had to reinstall the tool and restart the computer a couple of times but it eventually did the trick.