New Tool (3.0): CDP lua tool


(Psynapsex) #421

Keeps saying “Output file was not produced - Check your Settings”

What settings??? I selected the Exe folder when it initialized


(Djeroek) #422

Keeps saying “Output file was not produced - Check your Settings”

What settings??? I selected the Exe folder when it initialized

What OS, which process are you trying out? Do all processes fail, do some fail? Moar info would be helpful.

Can you try; ‘distort - distort reform - convert to sinusoid’ on a sample and see if it works?

Then try a fft process like the first one that is initialized when starting the CDP tool; ‘blur avrg - average…’. If that one doesn’t work read back the last 17 pages of this thread as it is a reoccurring issue on some OS’s :wink: .


(Psynapsex) #423

Sorry for lack of info.

All processes say the same thing including Distort Reform - Convert to Sinusoid
All CDP files in Renoise folder located in documents

Using Windows 7 64

I did install tool before CDP was properly installed. I didn’t realize there was a second installation folder at the site o.O


(Psynapsex) #424

Ok … it’s working!

I tried a number of things, but I think what may have solved it was choosing the “_cdprogs” folder in the cdp7 folder, instead of the “_cdp” folder (one level up).

Which is kind of weird, because all the EXE filters/processes showed up fine when I chose “_cdp”, so I assumed they would work.

Or perhaps something else I did solved this? I installed Renoise 64-bit (probably not relevant), and the removed and re-installed the CDP tool itself numerous times.

Could be a case of something solved it, but who knows what. Anyways - it works! :slight_smile:

I tried everything you did and tried putting cdp in Renoise program files folder, uninstaled/ reinstalled etc. No dice for me


(Djeroek) #425

do you have administrator rights for both Renoise and the CDP progs?

Right mouse click Renoise icon, click the compatibility tab, tick the ‘run this program as an administrator’ option, then press apply and ok.

I think the CDP directory shouldn’t be installed in a program files directory, but directly in C: . So, something like; ‘C:\cdpr7’ . Can’t think of anything else right now, besides plowing through this thread perhaps you can serach the CDP forum for hints if the problems persist? (http://unstablesound.net/cdpforum/index.php?board=1.0 )


(Psynapsex) #426

distort - distort reform - convert to sinusoid works

Thanks!

I couldn’t get flutter to work. I checked the permissions in TXT folder and it worked. Other effects don’t have the same luck. Great job so far!


(moliminn) #427

I am using Renoise on a MAC and I always get the same ERROR

7653 Screen Shot 2017-11-02 at 00.07.40.png

Any idea what I am doing wrong?

[EDIT] I FIXED IT!! Saw a old post with the same problem
It’s because of the 7.1 update!!


(sumocloud) #428

I downloaded the free CDP zip from the unstable sound website and my antivirus says it contains a trojan. Can anyone verify this?


(Djeroek) #429

I downloaded the free CDP zip from the unstable sound website and my antivirus says it contains a trojan. Can anyone verify this?

Probably a false positive, but to be sure better also ask on the cdp forum;http://unstablesound.net/cdpforum/


(frank) #430

The cdp tool doesn’t seem to recall the last setting in the value scale and time scale, after closing and reopening. It might work a couple times then it just goes back to defaults
07%20PM


(frank) #431

Forget it, This program is useless for one reason the Notedata files are totally a mystery,
Terrible documentation on CDPs part


(Djeroek) #432

For the note-data files you have to dive into the docs indeed for the correct syntax per used process. Which one are you having troubles with?


(frank) #433

All of them. There should be a an example preloaded in the cdp tool perhaps with a little documentation above. Right there, instead of 0 0 0 0 etc…

Ive dug and none worked. It’s just not compartmentalized properly on the cdp docs page. At all. Its like they try to confuse you on purpose


(frank) #434

I fired up sound shaper on my old pc, and the different presets for stuff that requires note data come with preconfigured note data for a starting reference.
I’ll try and get those text files off the PC. The window in the cdp Renoise program is having trouble recalling things. Thats another issue. If I enter the note files is it using them?


(Djeroek) #435

Dunno what you mean with this exactly. When using the ‘load’ button in the ‘create breakpoint envelope’ window to load up a file, you have to press the ‘Apply’ button afterwards to arm it so to speak. Same for manually entering values in the text field, ‘Apply’ has to be used to make it work.

Note data files or input has worked here plenty of times, lemme know which process you’re having problems with. It can be that certain pre-configured note data / time combos won’t work because of sample length, also sometimes upper and lower limits will mess things up. For example, a process lowest allowed input value is >0, hopefully the terminal will give hints to what are the accepted values.


(frank) #436

Yeah, Ill hit apply, but If I go back it will be back to default.

Not the breakpoints but the timescale and value scale