Renoise UI is sluggish everywhere after Catalina update

2018 Mac Mini, latest version of Catalina, runs like greased lightning over here. Not sure why Renoise is running poorly for you. I don’t use any plugins or sound generators outside of what Renoise has built in or has been coded in Lua for Renoise. Not knowing whether you do or do not use plugins (assuming you might?) maybe there is an issue with a particular plugin?

Wish it worked for you - have you tried installing earlier Renoise versions- some people have success that way.

Good luck!

Thanks for the reply. The sluggishness occurs in a completely empty session, so it’s not due to any plugins :frowning:

Does increasing the soundcard buffer settings in the audio preferences help?

No, makes no difference. This seems to be a graphics issue. Changing the various audio settings has no effect.

Which Mac are you running Renoise & Catalina on? Most likely this somehow will be connected to retina displays. Are you using a retina display?

Does disabling retina support in Renoise’s Preference -> GUI make a difference for you?

HI taktik, thanks for the response.

I tried disabling retina (in the renoise prefs) on my imac / catalina system, but there was no change in behavior at all. Still sluggish responses to all actions on the UI.

Here are the specs of the iMac with the problem:

Catalina 10.15.4
iMac (Retina 5k, 27-inch, Late 2015)
4 GHz Quad Core i7
16 GB 1867 MHz DDR3
AMD Radeon R9 M395 2 GB

I also have a MacBookPro, which is currently running Mojave, 16GB ram, 2.5GHz processor, and the graphics card is: Intel Iris Pro 1536 MB – and everything is running just fine with Renoise on that system. Unfortunately though, the imac is my main music rig.

-Michael

Did you try the sRGB IEC61966-2.1 or the general RGB color profile for all your monitors?

image

1 Like

This resolved the issue for me - I was getting unusably slow performance on a 2019 iMac Pro
Switching colour profiles did the trick :partying_face:

Thanks!

Hi,
I confirm this slow behaviour / poor graphical performance is happening to me also using a 5K iMac in macOS Catalina. I´ve downgraded to macOS Mojave and Renoise performance became great again. So pretty clear that the culprit is Catalina.

Tonight i will upgrade to Catalina again and try that sRGB color profile suggested and then report back in this post.

1 Like

We shouldn’t have to change the color profile for our entire system just to use Renoise, though… so even if that ‘works’, I don’t see it anywhere close to being a solution to the problem.

But how should Taktik fix something he did not wrong at all? Renoise worked in previous macos versions, obviously Apple changed something and then did not document it. Also this is happening to a lot of macos audio developers. So you should call the Apple hotline or so.

Maybe Taktik can activate the sRGB profile for the used CoreGraphics renderer, only for the Renoise app.

In my theory macos decides, if an app using CoreGraphics will be rendered thru the CPU entirely or the GPU (the usual). This seems to depend on various things nobody knows for sure. One thing obviously is related to the color profile.

E.g. u-he doesn’t have a fix for this either so far, AFAIK. Or do they have a fix? I found you in the u-he kvr forum, too. If so, I am sure, Urs would share some info here.

That’s called the world of software development, and every developer is used to it (and frustrated by it, of course, understandably).

But look at it this way; Every other DAW managed to get themselves working on Catalina, but Renoise should be exempt from this responsibility? That would be terrible news for Mac-using Renoise users, no doubt!

Devs are furious with Apple all the time, it’s true. But if they aren’t interested in handling the issues with the updates, then they shouldn’t be selling the product on that platform. Keeping up with OS-level updates affecting software is part of the job, albeit a crappy part.

1 Like

I did a complete reformat and clean reinstall of macOS Catalina 10.15.5 on mi iMac 5K.

Using the default color profile “iMac” or “Adobe 1998” makes terrible laggy graphical performance in Renoise.
Changing the color profile to “sRGB IEC61966-2.1” makes Renoise to work smoothly.

Even changing color profiles while Renoise is playing makes difference immediately.

I can live with this workaround, using this specific profile for Renoise sessions and the default one for the rest.

This is a quite weird bug, by the way.

Maybe a OS X “Metal” renderer will be considered for upcoming Renoise versions?

1 Like

Thanks for posting your findings, Klez.

I can confirm the behavior: on my iMac, Catalina OSX, switching the display > color mode to ‘sRGB IEC61966-2.1’ fixes the graphical issues with Renoise.

That said, i’d really like this to get fixed. That particular color mode makes everything on my mac look bright and sort of ‘un-subtle’; it’s not something I can just leave on permanently and be OK with.

This means to use Renoise I have to go into my display settings before and after every use…Not Great.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

In case anyone else is interested, it seems like about half of the Catalina color profiles run pretty smooth for me so you may not be limited to just the profiles mentioned.
I ended up going with rec. ITU-R BT.709-5
That one runs nice and smooth and also looks good on my MBP.
Weird issue.

1 Like

that’s good to know, I’ll check them out for sure – the sRGB mode does some obnoxious stuff with colors on my mac. Thanks for the heads up!

Here another post by Urs (maybe outdated since they seem to have sorted out these kind of problems): https://www.kvraudio.com/forum/viewtopic.php?p=7966642#p7966642

This might be an interesting read, too: Developing a fast and responsive GUI - is JUCE too bloated? - Page 2 - DSP and Plug-in Development Forum - KVR Audio